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Going digital – what is a digital image?

A digital image is an ordered rectangular array (or grid) of integers (numbers: 0,1,2,3…).

Each element (=number) in the grid is also known as a picture element or ‘Pixel’

1 dimensional 

array

Spectrum

2 dimensional 

array

Image

3D array
(= volume stack or

video/Timelapse

Stacks



Types of 3D data



Filters, point operators, … and stacks

Upon running a function over a stack, you will often get a 
question:

Hence, all
- Filters
- Bandpass filters
- Point operators
- Binary functions
- etc...

Are also valid for stacks

Sobel filter on RGB Lena



Stacks

Type of stacks
1. 2D images with encoded Z information (e.g. AFM)
2. Channels (or layers) are multiple images stored 

within one file. Typically, they contain different 
color absorption functions of the same object

3. Z layers are images recorded at different depth 
positions through the object

4. Time lapse are images recorded at a different 
time point

5. Custom multi-dimensional datasets (n>3). E.g. 
Hyperstacks, Raman maps and hyperspectral 
maps

Prerequisites
- All the slices in a stack must be the same size 

(X,Y) and bit depth.
- The slice thickness is considered constant (Z)

3D array
(= volume stack or

video

Stacks



Height maps

e.g. AFM height maps
- 2D image
- Pixel value = height = height map

7.87 nm

3D Map (XY view, transformed height map) XZ view (10X)

Gwyddion
Open SPM (AFM, SNOM/NSOM, STM, 
MFM, …) data analysis software

Data by Gwendolyn Delepierre



2. Channels

Pseudo-color
= a single channel (grayscale) equipped with a LUT

Composite images (flexible: e.g. 5x16bit)
n layers, separated. For example LSM multi channel data  

RGB images (24 bit=3x8bit) 
3 layers, reflecting the natural red, green and blue colors 
(or HSL, CMYK, HSV, …)



2. Channels: Pseudo-color (Lookup tables (LUTs))

- Image = 2D array of numbers
- "Grayscale" Lookup table = a means to giving a 

graphical meaning to these numbers.
- But "Grayscale" is just one of these Lookup 

tables!
- Image > Look-up table (not for RGB images)

Look-up tables = dictionary in Python

brgbcmywPhysics EdgesMPL-inferno



2. Channels: Lookup tables (LUTs)



2. Channels: composite images 

Brightfield Astrocyte marker Synaptic vesicles Syntaxin Actin

Composite image



Channels tool

Image > Color > Channels tool

Composite: overlaying the layers of choice (also for RGB images)
Color:  showing only one layer, with LUT. Change the LUT of the selected layer
Grayscale: showing only one layer, in grayscale LUT
(Clicking on the channel selector = use the channel scrollbar below the image)

Make composite: splits the color image in its layers
Convert to RGB: joins the layers into a 2D RGB image (you will end up with  1 window)
Split channels: makes n windows of each channel
Merge channels: Tool to put n single channels together into a composite stack

Image > Color > Merge Channels

Combines n images into a composite image

- Prerequisite: all images have the same size (width, heigth and bitdepth)
- Choose the LUT (color)
- Once merged: check the "Arrange" menu entry (Image >  color > Arrange...)



Channels: split, arrange, and merge

EXERCISE 
Open Example 1

Convert to Composite
Convert a color image to a composite image (Image > color > channels tool: More > make composite)

Split a composite dataset in its grayscale components
Split the three channels (Channels tool: More > split channels)

Optional: change the LUT of each of the grayscale components
Change LUTs if required (Image Lookup tables)

Merge channels
Merge the channels again to an RGB image (Image > color > Merge channels OR Channels tool: more > merge channels)

Change the order of the grayscale channels in the composite dataset
Arrange: Change the order of the layers in the stack (Image > color > Arrange Channels...)



Channels tool: example RGB image



Channels tool: example RGB image



3. Z-stacks

1. One file including the entire Z-stack  
Native: TIFF
Non-Native 
- lsm (Zeiss): Use LSM toolbox
- lif (Leica): Use Bio-Formats plugin
- ...

Filter: regex patterning, e.g. ‘tif’ will only select images that have ‘tif’ in 
their filename 

2. Sequence = a number of 2D images (same XY size, same bitdepth) in a single folder 

Possibility to reduce the stack

Import options

File > Import > Image Sequence
Enter or browse the folder path



Opening sequences

EXERCISE 
Open Example 2 (the folder) and import the sequence 

- File > Import > Image Sequence
- Locate the folder
- (you do not see the actual files in the folder)
- Regex Filter: allows filename filtering (e.g. tif will only include files that have tif in the 

filename)

All images must have the same size! (X, Y and bitdepth!)
Watch out for OS generated thumbnail files

Possibility to open as virtual stack



Opening sequences

EXERCISE 
Open Example 2 (the folder) and import the sequence 

Stack of 124 Slices, now looking at slice 58

X = 128

Y = 107

Z = 124

Move through the 

stack

Works exactly the same if you would have 

opened a multi-image file (eg. Tiff)

What is the difference between TIF and TIFF?



Image > stacks  Add Slice, Delete Slice, Next Slice, Previous Slice, Set Slice…

Image > Stacks > Make montage Produces a single grid-image containing the individual images that compose stacks and hyperstacks

Image > stacks > Stacks to Images Releases the n images in the one stack window into n windows (watch out with large stacks!)
Image > stacks > Images to Stacks Takes all open Images and puts them into 1 stack. Regex filter possible.

Image > Stacks > Z project Projects the entire stack onto a 2D image
Image > Stacks > 3D project Maximum intensity projection of the stack

Image > Stack > Tools  Combine, Reduce, Make substack, …
Image > Stacks >Tools > Grouped Z project…Output: a new stack, but with each slice the average/max/sum or each group

Operations on Z-stacks



Z-Stacks: Extended depth of field

Depth of field: 
𝝀

𝒏∙𝑵𝑨𝟐
𝝀= wavelength
n = refractive index
NA = numerical aperture of the lens

Typical section thickness Depth of focus Relative in focus

Light microscopy 1-40 um 200-500 nm 0.05%-50%

Electron microscopy 40-100 nm 40-400 nm 40-100%



Z-Stacks: Extended depth of field

Projects a brightfield image of a large object in focus based on a focal series

Image > Plugins > Extended depth of field (EPFL: bigwww.epfl.ch/demo/edf) 



Montage tool

EXERCISE 
Try out the tools in the Images > Stack  menu and with Example 2

Open a stack, then:
Image > stack > Make montage...



Z-Stacks: Reslice (orthogonal rotation)

Reslice from top/bottom
(Plane B) XZ view

X=128
Y=124
Z=107

X=107
Y=124
Z=128

Reslice from left/right
(Plane C): YZ view

Image > stack > Reslice...

Other tools: 

X=128
Y=107
Z=124

(Plane A) XY view

z x

y

Bold: on-screen depicted dimensions

Dynamic reslice
Creates an arbitrary cross section 
along a user-defined line

Radial reslice
orthogonal reconstructions of a 
stack by rotating a line ROI around 
one end of its center. Useful for data 
with rotational symmetry



4. Hyperstacks

Hyperstacks are multidimensional images, extending image stacks to four (4D) or five (5D) dimensions: 
x (width), 
y (height), 
z (slices), 
c (channels or wavelengths)
t (time frames)

3D stack (z=5) 5D stack (z=5, C=2, t=51)4D stack (z=5, C=2)

Hyperstacks are displayed in a window with 2 or 3 labelled scrollbars. Similarly to the scrollbar in stacks, including a 
play/pause icon.



Hyperstacks



Videos/timelapse
Out of the box, ImageJ has limited support (no 

codecs, no audio). However, it can 

open/close uncompressed AVI formats.

Videos/timelapse
Can be understood as a 3D stack where the third dimension is 
not spatial but temporal

Image > Stacks > 
Animation > 
Animation options

File > Save as… > Avi…



5. Custom multi-dimensional datasets

FIJI Raw import does not interpret your data, it just reads it (remember Lecture 1).

Example: Cytoviva dataset

XY: image dimension
Z: spectral dimension

400 nm

1000 nm
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Image > stack > Plot Z-axis profile...



6. Virtual stacks

- Virtual stacks are disk resident (as opposed to RAM resident) datasets
- The only way to load image sequences that do not fit in your RAM.

1. Virtual stacks are read-only, so changes made to the pixel data are not saved when you switch to a 
different slice

2. Commands like Crop [X] may create a RAM issue since any stack generated from commands that do not 
generate virtual stacks will be RAM resident.

Edit > options >memory & threads will allow you to change the RAM allocated

RAM for ImageJ

Total RAM of PC

RAM for all other software



Measuring in 3D



Note on non-isometric data  (LSM, FIB, …)

When the axial resolution (in Z) is not the 
same as the spatial resolution (in XY):
Image > Properties

Original data After segmentation (from iLastik)

x

z y

Prerequisites:
- binary images (see lecture III of this series)
- Proper axial and spatial resolution set (Image > 

Properties)



3D Objects counter

Analyze > 3D OC options

Allows to set the Measurements that will be performed

Turn off



3D Objects counter

Analyze > 3D Objects Counter
Similar to ‘Measure particles’, but: Threshold is asked

(Poor) thresholding attempt

Move through stack

Eliminate noise or large clumps

Eliminate partial objects

Output



3D Objects counter: Output

Volume

Check the Look up tableCheck the Look up table

Surfaces



3D Objects counter: Output



3D Objects counter

EXERCISE 
Open Example 7 and calculate the volume of the objects using the 3D object counter. 

1. Check calibration   Image > Properties…  (for 3D spatial and axial settings)
2. Do the analysis   Analysis > 3D object counter
3. Change the settings and repeat  Analysis > 3D OC settings



3D suite (plugin)

Plugins > 3D suite

Help > Update … >

See next slide

(Morphological) filters in 3D

Local Linear filters in 3D

Measuring distances (e.g. border to border) 

Binary segmentation tools (e.g. 3D watershed) 

(experimental)

(scripting)

ROI 3D manager (see next)



3D suite (plugin)

Raw data and binary mask

Input Output

Intensity stats of each object

Binary mask

Binary mask

Binary mask

Binary mask

Binary mask

Binary mask

Binary mask

Binary mask

Binary mask

Binary mask

Binary mask

Position of centroid of each object (X,Y,Z)

Volume of each object

Surface of each object

Distance stats between center and shell

Caliper distances in 3D and ortho-planes

Sphericity and 3D compactness

Goodness of fit measurements

Ellipsoid: how much is sticking out

Fitting measures to elliposoid

3D convex hull



3D suite (plugin)

1. 3D segment (use binary Data!!)
you get a new window with your objects in different shades
2.    Add an image 
this adds the objects 

ROI3D manager



3D suite (plugin)

1. 3D segment (use binary Data!!)
2. Add an image 
3. Click “Live ROI: OFF” (makes it “ON”)
4. From the list, select obj35-val35
5. Then click “split in two”

ROI3D manager



3D suite (plugin)

EXERCISE 
Open Example 7 and calculate the volume of the objects using the 3D manager of 3D suite. 
Try to split some objects in the 3D suite

Image > Properties…  (for 3D spatial and axial settings)
Analysis > 3D object counter (and 3D OC settings)
Plugins > 3D suite > 3D manager
 - Segmentation
 - Add image



Visualization of 3D data



Visualizing 3D data

1. 2D depictions
2. Renderings

1. Surface rendering
2. Volume rendering



Visualizing 3D data: Depth encoded

3D stack

Image > Hyperstacks > 
temporal color-coded

Depth coded 3D stackAFM image AFM as 3D stack

(= depth coded, Fire LUT)



Visualizing 3D data: Orthogonal views and depth coding

EXERCISE
Open Example 3.

Try both:

Depth-encoded Color
Image > Hyperstacks > Temporal color-code 
/ choose a LUT (e.g. Grays)

Orthogonal views
Image > stack > orthogonal views



Visualizing 3D data: Orthogonal views

How to get rid of the marker lines?
Image > Overlay > hide overlay  (or remove overlay)

The intersection point of the three views follows the 
location of the mouse click and can be controlled by 
clicking and dragging in either the XY, XZ or YZ view. 

XY and XZ coordinates are displayed in the title of the 
projection panels. The mouse wheel changes the 
screen plane in all three views. 

Orthogonal views



3D rendering

Note: renderings require interpretation by the user. Hence, they are the convolution of the raw scientific data and the 
feature the user would like to see.

1. Surface rendering
 = binary threshold-based
2. Volume rendering
 = percentage threshold-based

Never publish only renderings. 
Always provide the raw data (i.e. 
orthogonal views)



Surface rendering: Isosurfaces

Isosurface 
A three-dimensional analogue of an isoline. It is a surface 
that represents points of a constant value within a volume.

Step 1: Creating an isoline by thresholding
Step 2: voxels to mesh by marching cubes
Step 3: Mesh to rendering through shaders

In

Out

Out

Out

Isoline («Border»)



Isosurfaces: Step 1: Thresholding the voxels

Threshold = 83

Original Binary

Edge only = isoline

A threshold is calculated
- Pixel value > threshold, the voxel is considered 

to contain the signal (=object). 
- Pixel value < threshold, the voxel is considered 

not to contain the signal (=background).
- This classification system is binary; it defines 

each voxel as containing either 100% or 0% of 
the signal

- Once classified, a surface is defined as the 
boundary between the pixels (=isoline)



Isosurfaces: Step 2: Isoline/Voxel to mesh conversion

Marching squares

Isoline 

(«Border»)

Mesh



Isosurfaces: Step 2: Voxel to mesh conversion

Marching cubes

Marching squares

Intensities -> Binary -> 64 predefined values / marching cubes 

This is called a 

polygon



Isosurfaces: Step 3: Reflection and intensity

Normal: vector 
perpendicular to the 
polygon

The normal defines 
the color (or shade) of 
the polygon

Polygons rendered without shader 
(flat)

‘Light source’  

‘Camera’ 

Light source

normal

Camera

 = angle between light and normal
 = angle between camera and normal

The smaller the difference between the angles
The brighter the polygon

Polygon







Light source
normal

Camera

Polynom 1

Isosurfaces: Step 3: Illumination

‘Camera’ 

normals

Modern hardware: use Phong (better than Gouraud, but a bit more intensive computing)

Gouraud shading
Bilinear interpolation of the intensities (color) between 
two normals

Phong shading
Barycentric interpolation of the normals themself

No shader



Isosurface: Rasterized vs ray tracing

Rasterized

project 3D triangles to the screen then fills covered 
pixels with interpolated depth, color, and lighting.

Projects geometries

Ray tracing
Cast rays per pixel into scene (i.e. from the camera), 
find first surface hit, then recursively simulate light 
bounces for shading.

Projects rays



Isosurface: Example

ImageJ 3D viewer (rasterization)

Isosurface and (very basic) volume renderer
Good quality, but limited
Buggy (in my view)

But: 
export as STL, wavefront ==> 3D printer

And volume calculation

Commercial renderer (rasterization)

Avizo/Amira/Imaris
Very flexible, commercial software
Good quality, extensive renderer

Available through SciIT 
(BioNano workstation)

Open source ray-tracing

Blender 5.1 cycles renderer
Realistic rendering possible
Slow

Free to download



Isosurface: Ray-tracing and GANs



Isosurface: surface rendering

EXERCISE 
Open Example 2 and try out the 3D viewer. 

1. Plugins > 3D viewer
2. Select Display as surface, color (your choice) and resampling factor of 1) 
3. Change the threshold (Edit > Adjust threshold). Set it to 50

Do not downsample (value =1)

Select a color
Select surface

Set threshold

File > Export surfaces (Wavefront, STL, ...) 
→ 3D printer



Isosurfaces: example

Advantages:
• Computationally fast
• Good 3D interpretation

Disadvantages:    
• Not suitable for noisy data (e.g. electron tomography)
• Preferably: thresholded/segmented  (binary) data

Main disadvantage: A decision for every voxel must be made.
This can produce:
• false positives (spurious surfaces) 
• false negatives (erroneous holes in surfaces)



3D rendering
Note: renderings require interpretation by the user. Hence, they are the convolution of the raw scientific 
data and the feature the user would like to see.

1. Surface rendering = binary threshold-based

2. Volume rendering = percentage threshold-based

Direct volume rendering methods generate 
images of a 3D volumetric data set without 
explicitly extracting geometric surfaces from 
the data (Levoy 1988). 

Never publish only renderings. 
Always provide the raw data.

Volume rendering offers the possibility for displaying weak or fuzzy surfaces. This frees one from the requirement to 
make a decision whether a surface is present or not.

    Every voxel should contribute to the image

1. VOLUME RAY-CASTING (or ray marching): Cast imaginary rays through the entire 3D stack
2. DEFINE TRANSFER FUNCTION: setup rules for color and alpha (opacity)
3. DEFINE EDGES AND LIGHT SOURCE: shading
4. ACCUMULATE THE DATA



Volume rendering: 1. Ray casting & interpolation

For each pixel of the final image, a ray of sight is shot ("cast") through the volume.
At non-orthogonal angles, interpolation is needed

Ray casting 



Volume rendering: Example - Maximum intensity projection

projects in the visualization plane the voxels with maximum intensity that fall in the way of 
parallel rays traced from the viewpoint to the plane of projection

For each sampling point: RGBA is computed (Red, Green, Blue and Alpha)



Volume rendering: step 2: Sampling and interpolation

For each pixel of the final image, a ray of sight is shot ("cast") through the volume.
At non-orthogonal angles, interpolation is needed

Ray casting           Interpolation



Volume rendering: step 2: Sampling and interpolation

Nearest Neighbour 
= unweighted
➔ Take the value of the 

closest voxel

1D NN: closest of two points

2D NN: closest pixel of four 
corners of a square

Linear 
= Center of mass
➔ Take the linear average of the two pixels 

the ray is intersecting

1D Linear: Center of mass  of two points

Bilinear: Center of mass of square corners
Trilinear: Center of mass of cube lattice points

Cubic
➔ Center of mass
= Lagrange polynomials, cubic splines or cubic 
convolution

1D Cubic: Center of mass  of 3th degree polynomial

Bicubic: Center of mass of 16 pixels
Tricubic: Center of mass of 64 pixels



Volume rendering: Example - Maximum intensity projection

projects in the visualization plane the voxels with maximum intensity that fall in the way of parallel rays traced from the 
viewpoint to the plane of projection

Image > Stack > 3D Project...

Original stack Maximum intensity (brightest point) Advantages
computationally fast

Disadvantages
May not provide a good 
sense of depth of the original 
data.
Two MIP renderings from 
opposite viewpoints are 
symmetrical images
No difference between left or 
right, front or back.



Volume rendering: step 3: shading

Shading
For each sampling point, a gradient of illumination values is computed. These represent the 
orientation of local surfaces within the volume. The samples are then shaded (i.e. coloured and lit) 
according to their surface orientation (normal) and the location of the light source in the scene.

Each sampling point is shaded according to its normal

Note: thresholding needed!

Avizo

Imaris



Volume rendering: step 4: compositing

Compositing
 After all sampling points have been shaded, they are composited along the ray of sight, resulting in the final 
colour value for the pixel that is currently being processed.

The total spectral radiance
x = position
0 = direction (angle)
 = wavelength
T = time point

The emitted spectral 
radiance

The bidirectional 
reflectance distribution
function

The spectral radiance



Volume rendering: Slices

EXERCISE 

Open Example 2 and try out the Volume viewer (plugins > volume viewer)



Volume rendering: Slices

Cross sections (orthogonal and non-orthogonal) Additionally draws the borders (edges) of the entire 
3D volume stack. Can help to provide context

Slices Borders



Volume rendering: Maximum intensity projection and projection

classic “maximum intensity 
projection”: along each viewing 
ray, only the brightest voxel is 
used to form the 2D image.

Adjust the alpha 
channel along 
the viewing rays

Color Transfer function



Volume rendering: The color transfer function

---

Horizontal Axis: represents the mapped intensity of voxels
Vertical Axis: the original intensities (black at the bottom, white at 
the top)



Volume rendering: Alpha transfer function - 1D opacity

Histogram (Intensity vs occurrence)
Alpha (orange area): a non-linear, intensity depending threshold
Global alpha offset: baseline opacity 



Volume rendering: Alpha transfer function - 2D Grad opacity

X-axis: intensities, y-axis: Gradient magnitude (!)
Alpha (orange area): In theory, different shades can be applied, 
but practically this is difficult
Global alpha offset: baseline opacity 

Opacity high at/near edge, low elsewhere



Volume rendering: Alpha transfer function - 2D MD

Mean = average brightness in a local neighborhood
Difference = magnitude of gradient

Opacity high at/near edge, low elsewhere
As a function of local brightness



Volume rendering: Volume lightning model

Using a transfer function to map voxel intensity to color and opacity.
Light: Adds a simple lighting model (ambient, diffuse, specular, shine 
controls).



Volume rendering: Decide what to highlight



BioNano has a workstation dedicated to Image rendering (amipc22.unifr.ch)
Soft Matter physics has also a workstation
More number cruncher available at Biology, Medicine, (physics?)

Imaris: dedicated to 3D LSM data

Volume rendering: Imaris

Volume renderingSurface rendering Object analysis



Volume rendering: Aviso

BioNano has a workstation dedicated to Image rendering (amipc22.unifr.ch)

Aviso: dedicated to 3D non-fluorescent 3D and 4D data

Volume renderingSurface rendering Object analysis

Volume renderingSurface rendering



Software requests?

Volume renderingSurface rendering Object analysis

I am thinking of creating ½ day hands on lectures on the following software packages:

• Blender / Cycles (realistic ray tracing and mesh rendering)
• Inkscape (Vector graphics editor, great for preparing 

publication grade figures)
• Avizo (Commercial 3D rendering and image processing, incl 

segmentation)

Which one would you choose?
 



Z-Stacks

✓ Congratulations,

You finished Part IV, 3D
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