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How does software measure objects in images?



How does a software measure images? 

Primary units: Area of an object

Histogram # of pixels = area

Analyse > Measure
(= Count pixels)

by Analyse > Particles)

Threshold

1 bit

Original grayscale

16 bit



Max eroded points

= endpoints after 
iterative erosion until 
only single-pixel lines 
remain.

How does a software measure images? 

Primary units: Count objects

Grayscale

Threshold

Distance transform

= a derived 
representation where 
every foreground pixel 
takes a value in function 
of the distance to the 
nearest background pixel

Histogram

Get # of black pixels
= # Objects



The perimeter of an object (a 128x128 square) depends on its 
angular position.

How does a software measure images? 

Primary units: Length (e.g. perimeter of an object) --> tricky (estimates)

“Perfect circles” do not 
have a circularity of 1

𝐶𝑖𝑟𝑐. =
4𝜋 × 𝐴𝑟𝑒𝑎

𝑃𝑒𝑟𝑖𝑚𝑒𝑡𝑒𝑟2

Of course, these are discrete representations 
of perfect circles (see lecture 1)



Boundary pixels

How does a software measure images? 

Primary units: Length (e.g. perimeter of an object) --> tricky (estimates)

Grayscale Threshold + Erosion# of edge pixels
≅ perimeter
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How does a software measure images? 

Primary units: perimeter of an object. the Crofton estimator

Grayscale Thresholded Crofton (based on Buffon's needles)

2 Way Crofton
(horizontal and vertical)

P = 191.8

4 Way Crofton
(2-way + 2 diagonals)

P = 187.5

෠𝐿 =
𝜋𝑝𝑁

2𝑚

N = total number of intersections
p = distance between parallel lines
m = number of orientations (e.g. 4 for a 
4-way Crofton)



Morphological operations



Thresholding / binarization / segmentation

1 bit 

8/12/16 bit



Morphological binary operations

Binary images
are images with only two values: black (usually 
intensity = 0) and white (intensity =1, or 255). 
It is assumed that objects are black and background is 
white, but this can vary.

Prerequiste: Binary data
Binary data is the output of thresholding

Morphological operations rely only 
on the relative ordering of pixel 
values, not on their numerical values
(hence: binary data)



Morphological binary operations – structuring element

Structuring element
Morphological techniques probe an image with a small shape 
or template called a structuring element. The structuring 
element is positioned at all possible locations in the image and 
it is compared with the corresponding neighbourhood of pixels. 

Fits A SE fits within the neighbourhood
Hits B SE hits a boundary
None C Neither hits not fits

Background = 0, black
Foreground = 1, white

SE

A

CB



Basic (primary) binary operations: dilation

1. Structuring element:

2. Consider each of the background (=black) 
pixels

3. For each background pixel (= input pixel) the SE 
is superimposed. (origin of the SE coincides 
with the input pixel).

4. When hit: input pixel (Black) is changed to a 
white foreground pixel (=If at least one pixel in 
the structuring element coincides with a 
foreground pixel in the image underneath)

5. When fit or none: do nothing

Input pixel

Structuring
element

SE

SE

Hit!

SE

Hit!

SE

Hit!

SE

Hit!

SE

Hit!

SE

Hit!

SE

Hit!

SE

Hit!



Basic (primary) binary operations: erosion

1. Structuring element:

2. Consider each of the foreground (=white)
pixels

3. For each foreground pixel (= input pixel) the SE 
is superimposed. (origin of the SE coincides 
with the input pixel).

4. When hit: input pixel changed to background 
(=If at least one pixel in the structuring 
element coincides with a background pixel in 
the image underneath)

5. When fit or none: do nothing

Input pixel

Structuring
element

SE SE SE

SE SE
SE

Hit! Hit!

Fit! Hit!

Hit!

Fit!

SE

Hit!

SE

Hit!

SE

Hit!Gray: ‘hit’ 
pixel



Basic (primary) binary operations: dilation and erosion

Dilation 

Gradually enlarges the 
boundaries of the 
foreground objects (i.e.
white pixels, typically). 

Erosion

Gradually enlarges the 
boundaries of 
background regions (i.e. bl
ack pixels, typically). 

Original cameraman

Thresholded cameraman



Secondary binary operations: close and open

Idempotence
The property of applying more than once 
does not produces a further change.

Original cameraman

Thresholded cameraman

Close: First dilation, then erosion

Fills in and connect foreground

• Fill small black holes inside objects
• Bridging small gaps or breaks
• Smoothing object boundaries from the 

outside
• Removing «Pepper» noise within 

foreground regions
• Preparing masks for segmentation

=closing 
foreground 
gaps

Open: First erosion, then dilation

Cleans up and separates foreground

• Separating weakly connections objects
• Thinning/trimming small protrusions
• Smoothing boundaries from the inside
• Pre-processing before segmentation

=opening 
foreground 
connections



Binary operations with SE 

Hit or miss
Finding ends and corners

Thinning
Reduces the object to a single pixel 
line (skeletonization)

Thickening
Calculate convex hull of object

Top hat 
Extracting bright (white top hat) or 
dark (black top hat) objects



Associated: tesselation

Voronoi tesselation
Boundary maps

Delauney tesselation
= dual graph of voronoi 
(=swap of vertices and faces)

red: Voronoi, black: Delauney

Applications

Face recognition

Fingerprint analysis

• Robotics: path planning, 
autonomous driving

• Terrain modeling
• Medicine: surgerical 

planning MRI mesh points
• ... (when point clouds 

need to be converted to 
mesh)



Binary operations: Euclidean Distance transform

The result: the Euclidian distance map. 
Each foreground pixel in the binary image 
is replaced with a grey value equal to that 
pixel’s distance from the nearest 
background pixel (for background pixels 
the EDM is 0) 

A distance transform, is a derived 
representation, in this case from a 
binary digital image



Binary operations: Ultimate eroded points

The Ultimate Points extracts the last 
point that would be removed if the 
object were eroded to completion. 

Iterations of eroding steps

Origin binary Ultimate eroded 
points

Overlay UEP with 
binary

Euclidian distance 
map



Binary operations: Watershed

Watershed segmentation 
Separates touching objects. 

1. the Euclidian distance map (EDM) is calculated 
2. the ultimate eroded points (UEPs) are calculated . 
3. Dilation of each of the UEPs until:

1. the edge of the original particle is reached
2. the edge touches a region of another (growing) UEP



How does a software measure images? 

EXERCISE 1
Open example 1A and count the number of coins using eroded points. Repeat for example 1B

Process > Binary > Ultimate points



File > Open...
Image > Adjust > Threshold...
113-255

Process > Binary > Fill holes
(Alternative: open / close)
Process > Binary > Ultimate points
(Calculates the EDT and then the UEP)
Process > Histogram
(In Histogram window) > List

How does a software measure images? 

EXERCISE 
Open example 1A and count the number of coins using maximum eroded points. Repeat for example 1B



File > Open...
Image > Adjust > Threshold...
113-255

Process > Binary > Fill holes
(Alternative: open / close)
Process > Binary > Ultimate points
(Calculates the EDT and then the UEP)
Process > Histogram
(In Histogram window) > List (count the non-zero pixels)

How does a software measure images? 

EXERCISE 
Open example 1A and count the number of coins using maximum eroded points. Repeat for example 1B



How does a software measure images? 

EXERCISE
Open example 1B and count the number of blobs using maximum eroded points. 

File > Open...
Image > Adjust > Threshold
Edit > Invert (make sure your objects are 
White)*

Process > Binary > Ultimate Points
Process Histogram

To count:
Process > Math > Multiply by e.g 1000
(In histogram) > List > check at value 255

* Note: you can also invert the look-up table (Image > Color > 
Invert LUT ​), this does not change your objects pixel values. I.e. 
black => 255, and white => 0, which can be very confusing)



EXERCISE 
Convert Example 2 – AuNP to a binary image. Compare with and without watershed

Binary operations: Watershed

Process > Binary > Watershed

To compare the two windows: Analyze > tools > Synchronize windows

File > Open…
Image > Adjust > Threshold…

Click ‘Auto’
Click ‘Apply’

Duplicate the image (ctrl+shift+D)



EXERCISE 
Convert Example 2 – AuNP to a binary image. Compare with and without watershed

Original

Binary operations: Watershed

Process > Binary > Watershed

B
in

ar
y

B
in

ar
y 

+ 
w

at
er

sh
ed

17 objects
(not touching the edge)

31 objects
(not touching the edge)



How does a software measure images? 

Given: 
- The primary units (area, perimeter, number)
- The position of all foreground pixels (array of X and Y)

Secondary units:

Centroid Average of all x and y within each object

Bounding Rectangle The smallest rectangle enclosing the object

Fit Ellipse Fit an ellipse to the object

Circularity 
4∙𝜋∙𝑎𝑟𝑒𝑎

𝑝𝑒𝑟𝑖𝑚𝑒𝑡𝑒𝑟2
, for each object

Aspect ratio
𝑀𝑖𝑛𝑜𝑟 𝑎𝑥𝑖𝑠

𝑀𝑎ℎ𝑜𝑟 𝑎𝑥𝑖𝑠
, for each object

Roundness
4∙𝑎𝑟𝑒𝑎

𝜋∙𝑚𝑎𝑗𝑜𝑟 𝑎𝑥𝑖𝑠2
, for each object

Solidity area/convex area. 

Feret's Diameter Longest distance between any two pixels in an object.
…

Everything relies on the thresholding 
step…



Thresholding, classification and segmentation



Thresholding, classification and segmentation

Level 1

Histogram-based



Thresholding

How?
By setting the transfer function to a vertical asymptote (=infinite contrast), preferably automatic (=non-subjective)

Two concepts for unsupervised pixel thresholding (a.k.a. automatic thresholding):
Histogram shape based
Image entropy based
(there are more, but these two classes are the most common)



Thresholding

Image processing to the rescue (pre-processing):

- Gradient background: Mean filter with large kernel
- Fireflies/hot pixels/dead pixels: Bin your data, Median 

filter with a kernel as small as possible,
- Shot noise / poisson noise: GIGO, non-local filters 

(maybe)
- Undersampling aliasing: low pass filters
- …

post thresholding: Morphological filters (open/close)
Touching objects: Watershed

Some thoughts:

- Use 16-bit data (or 32 bit). Not 8 bit
- Global thresholding is preferred over local thresholding

(=last resort)
- Try to go for easy, straightforward and known

thresholding algorithms (ISOdata, Otsu, ...), which are
discribed in the scientific literature (references)

- Auto-thresholding is preferred over manual
thresholding (reproducibility)

- There is no «correct» solution, just models that try to 
simplify the complexity of nature.

Continuous function > Discrete function > Binary function 



Auto – thresholding  

Clustering
• ISOdata
• Otsu
• Intermodes (assumes equal bimodal histogram)
• Minimum
• Mean (Mean of grayscale as threshold, initates ISOdata)
• Percentile (assumes foreground pixels fraction of 0.5)
• Yen

Entropy
• Huang and Huang 2 (faster) 
• Shannon’s entropy
• Li
• MaxEntropy
• RenyiEntropy
• Shanbhag

Metric
Triangle

Moments
Tsai

Image > Adjust > Threshold…



Unsupervised thresholding: clustering 

– the average intercenter distance between the clusters falls below a threshold,
– the average change in the intercenter distance between iterations is less than 
a preset threshold, or
– the maximum number of iterations is reached

Ideal for bimodal histograms!
You do not have a bimodal histogram? 
Use entropic thresholding

All pixels values are randomly assigned into 
two clusters (foreground and background)

The standard deviation of the values within 
each cluster, and the distance between 
cluster centers (between-class) is calculated

Pixel values are moved between clusters to 
minimize the deviations

Iterate!

U
n

ti
l…



Unsupervised thresholding: entropy

• Entropy difference is maximized (MaxEntropy)
• Entropy difference is minimized (MinEntropy)
• Fuzziness is minimized (Huang)

Better for non-bimodal histograms!

All pixels values are randomly assigned into 2 
clusters (foreground and background)

The entropy within each cluster is calculated:

𝐻 = −෍

𝑖=𝑖0

𝑖𝑀

𝑝𝑖 𝑙𝑜𝑔2(𝑝𝑖)

Clusters are re-arranged to minimize entropy

Iterate!

Information entropy: 
Quantification for Surprise
e.g.: flip a coin. The “surprise“ factor is 1/2

Relative occurrence of letters in the english language

U
n

ti
l… 0
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Probabilities
Entropy

MaxEntropy

Huang (fuzzy)

Li
RenyiEntropy

Shanbhag



Thresholding algorithms

EXCERCISE
Open Example 3 (A/B/C). Run a threshold and check the differences between the algorithms. Try it also 
on your own data.

Image > adjust > Threshold...
Note the difference between different pixel classification algorithms



Thresholding, classification and segmentation

Level 2

Machine learning



Thresholding: human vs machine



Thresholding: human vs machine

1 2 3 4 5
6

7
8

9
10

1112 14

13
15

17

16 18

19

20

21

22 23 24

CONTEXT



From thresholding to classification

FIB Data by Henry Lee

Au NP outside 
the cell

inside the cell

outside 
the cell
(background)



From thresholding to classification

Intensity in the neighbourhood (s = 1.00)
(a.k.a. Context)

Intensity

Statistical classification methods
• Artificial neural networks
• Decision tree learning e.g. Random forest
• Kernel estimation e.g. k-nearest neighbour 
• Linear classifier e.g. Bayes classifier
• Least squares support vector machine
… And many many more

Classification features
- Color/Intensity
- Gradient magnitude
- Distance to a local edge
- Texture
- Pixel isotropy
- Local curvature



From thresholding to classification

Intensity in the neighbourhood ( = 1.00)

Intensity



From thresholding to classification



From thresholding to classification to segmentation

- Use random forest ML to create a model
- Use the model to decide on other pixels in your sample (~1 000 000 pixel classifications / s on the Bionano workstation)
- (batch) Export the resulting data as probabilities or segmentations…and in case of 3D data: input them in 3D surface 

rendering software 
- Or quantify

Cell volume: 1871 um3

NP inside volume: 25.82 um3

NP outside volume: 0.7842 um3

(assuming spheres with a diameter of 50 nm)
Number of NP inside the cell 387815
NP per volume cell: 207 NP / um3 cell



iLastik

Standalone software iLASTIK
www.ilastik.org



iLastik

Standalone software iLASTIK
www.ilastik.org



iLastik: 1. Input data

P
ro

ce
ss

1. Add new > Add separate images… > 
• Example4-stack.h5 (for a fast PC)
• Example4-single.h5 (for a normal PC)

2. Click in the left process menu Feature selection

make sure your training images have
- Grayscale LUT
- No burnt-in scalebar



iLastik: 1. Input data



iLastik: 2 Feature selection
P

ro
ce

ss Select features…
(select all) > click OK

Click 3. Training 



iLastik: 3. Training the model
P

ro
ce

ss

Scroll button: change plane in 3D
Ctrl + Scroll button = zoom in/out
1, 2 … = label select
I = Image overlay
S = segmentation
U = Uncertainity / probability

Iterate and improve your result



iLastik: 4. Save the data
P

ro
ce

ss Single Image:

Tick: convert to unsigned 8-bit
Format: .hdf5 (tif also possible)
Click OK

Stack:

Tick: convert to unsigned 8-bit
Format: .HDF5
Click OK

----- OR -----

Tick: convert to unsigned 8-bit
Format: TIF sequence
Click OK



Back to ImageJ: Open the segmented data

File > Import > HDF5…
- Click on the data 

(/exported_data)
- Select «Individual hyperstacks 

(custom layout)»
- Data set layout: change to «zyxt»

Stack saved as HDF

File > Import > Image sequence
Filter: “Simple Segmentation”
(➔ “Count” should then become 49)

Stack saved as tif sequence Single saved as tif

File > Open…



Ilastik output

Min = 1, Max = 2

Normalize
Process > enhance contrast

Invert 
(Foreground objects = white)
Edit > Invert

Process > Histogram…

(i.e. all values are either 1 or 2)



Back to ImageJ: Loss of metadata

Before iLastik thresholding After iLastik Thresholding

Image > Properties …



Ilastik output

EXCERCISE 
Open the segmentation result.



iLastik: 5. Batch processing
P

ro
ce

ss Select raw datafiles …
Run «process all files» (can take a while)



iLastik

Value # of Pixels



Labkit: example and hands-on workflow

EXCERCISE 
Open Example 4. Duplicate 1 image of the stack. Train a model using LabKit



Labkit: example and hands-on workflow

EXCERCISE 
Open Example 4. Duplicate 1 image of the stack. Train a model using LabKit

- Install labkit from the repository: Help > Update … > Manage update sites > 

- Restart FIJI

- Open Example 4 

- Duplicate 1 image (e.g. # 34)

- Start Labkit: Plugins > Open current image with Labkit



Labkit: example and hands-on workflow

EXCERCISE 
Open Example 4. Duplicate 1 image of the stack. Train a model using LabKit

1. Train the model

- Select Draw in the top menu 

- Select background in the left menu 

- paint some background pixels blue

- Repeat for foreground pixels (nuclei)



Labkit: example and hands-on workflow

EXCERCISE 
Open Example 4. Duplicate 1 image of the stack. Train a model using LabKit

2.  Add a classifier

- In the left menu, click “Labelkit Pixel classification” 

- Click the cog wheel, check all basic filters

- Click the play button         (or CTRL+SHIFT+T)  

- Repeat step 1 to optimize the model



Labkit: example and hands-on workflow

EXCERCISE 
Open Example 4. Duplicate 1 image of the stack. Train a model using LabKit

3.  Check model uncertainity and segmentation

- In the Labkit pixel classifier, click the down arrow 

- Select “Show segmentation Result in ImageJ”

- Repeat with Show Probability Map in ImageJ

Segmentation Probability

3 bin histogram



Labkit: example and hands-on workflow

EXCERCISE 
Open Example 4. Duplicate 1 image of the stack. Train a model using LabKit

4.  Batch export: apply the model to all images in the folder

- Save the stack as a list of files: File > save as… > Image sequence…

- In Labkit: Others > Batch segment images…

- Select the folder with the separate images Example 4 (also as output)

- Do not use the GPU

- Run the batch (progress can be followed in the FIJI info bar)

- File import > Image sequence: point to the folder

- Filter: use ‘seg’ to filter for file names that contain segmentation

- The images are black!



Labkit: example and hands-on workflow

EXCERCISE 
Open Example 4. Duplicate 1 image of the stack. Train a model using LabKit

5.  Equalise the histogram of the segmented data

- With the segmented data stack open: Process > enhance contrast

- Check all except normalize

- Click OK

(alternative: Process > Math > Multiply: 255)

Before equalization After equalization 3D rendering



Thresholding, classification and segmentation

Level 3

Deep learning



Thresholding: human vs machine

Histogram based Thresholding
FIJI native

Classification
Labkit (FIJI plugin)
iLASTIK (standalone)

Classification
DeepImageJ
CSBDeep
StarDist



Deep Learning

have a look at www.bioimage.io



Deep Learning with Ilastik



Deep Learning with DeepImageJ

1. Add new > Add separate images… > Example4-ilastik-2D.h5



Deep Learning with DeepImageJ

Finally: click Live prediction



Deep Learning with DeepImageJ

Can we do this in ImageJ, too?



Deep Learning with DeepImageJ

• Open the Cell nucleus image 
(Example4-ilastik-2D.h5)

• Go to Plugins > DeepImageJ > 
DeepImageJ Run 

• Click the orange button 
«Bioimage.io»(toggles between 
locally installed and online models)

• The  search for: NucleiSegmentation
• Click «Install model»
• Click «Local». You will now see the 

locally installed models (i.e. 1)
• Click «Run»

Running a model from the model zoo



Deep Learning with DeepImageJ

Result: 2 images

Image1 = probabilities
32-bit image, with values between 0 and 1

Image 1: convert to segmentation

Process > Binary > make Binary

Image 2: Uncertainties
The brighter the pixel, the more 
uncertain the segmentation



Deep Learning with StarDist

Specific applications: nuclei and cell bodies, 2D only but scriptable

Original dataset Output:

Plugins > StartDist 2D Note: the colours are a false-colour
LUT. Change it to Grays if needed



Deep Learning with CSBDeep: : training your own model

How to train a model yourself?
> Install CSBDeep

Plugins > CSBDeep > DenoiSeg > Train

Training data:
1. Raw datasets
2. Masked (manually) segmented datasets
(e.g. 100 2D images at 512x512 px)

Training: use about 80% of your dataset, 20% 
for validation (e.g. 80 images for training)

Number of Epochs: the more the better
Steps per Epoch: the more the better
Batch/Patch size: do not change

Then: wait...



Deep Learning with CSBDeep: training your own model

Training DenoiSeg model: Plugins > CSBDeep > DenoiSeg > DenoiSeg Train 
→ Data in folder: Example 7



Deep Learning with CSBDeep

Training DenoiSeg model: Plugins > CSBDeep > DenoiSeg > DenoiSeg Train
> Data in folder: Example 7

Raw data Denoised result P(FG) P(BG) P(edges)

Preview window



Deep Learning with CSBDeep

Underfitting

the model is unable to accurately 
model the training data, and hence 
generates large errors

Overfitting

the model performs well on training 
data but poorly on the new data in 
the validation set.

Good fit



Deep Learning with CSBDeep

EXCERCISE 
Use the trained model on data from Example 7

- Open a dataset from the trained images (e.g. Images > test > Example7 test.tif)
- Duplicate 1 image
- Plugins > CSBDeep > DenoiSeg > DenoiSeg predict

model (a .zip)

Noisy image



Deep Learning with CSBDeep

EXCERCISE 
Use the trained model on data from Example 7

Original Denoised P(BG) Binary Watershed

Watershed



Number extraction



Blob analysis aka particle counting

Before you start:
- Can you trust your binary image?
- Is the scale properly set? (Analyse > set scale)
- Is the foreground particle white (if not: invert: ctrl+i)
- What do you want to measure (Analyse > Set Measurements)

Two step procedure:
1. Binarization (=threshold)
2. Measurement: Analyze > Measure particles

Assumption
Your data is binary (or at least segmented)



Size measurements: filters

Original (thresholded) Edge filter

particles touching the edge 
will be ignored

Size: 0-50

Size: 50-

Particles with size 
(=area) outside the range 
specified in this field are 
ignored. 

Size filter Circularity filter

Ranges from 0 (infinitely 
elongated polygon) 
to 1 (perfect circle).

0.3-0.5

0.0-0.3Interior holes will be 
included 

Include holes

Circ. = 4𝜋 ×
𝐴𝑟𝑒𝑎

𝑃𝑒𝑟𝑖𝑚𝑒𝑡𝑒𝑟2



Size measurements: Outlines, masks and overlays

Nothing: Neither Outlines, masks nor Overlays will be displayed.
Outlines: 8–bit image containing numbered outlines of the measured particles. 
Bare Outlines: 8–bit image containing simple outlines of the measured particles without labels. 
Masks: 8–bit binary image containing filled outlines of the measured particles 
Ellipses: 8–bit binary image containing the best fit ellipse (cf. Edit>Selection>Fit Ellipse)
Count Masks: 16–bit image containing filled outlines of the measured particles painted with a grayscale 

value corresponding to the particle number. 
Overlay Outlines: Displays numbered outlines of the measured particles in the image overlay.
Overlay Masks: Displays numbered and filled outlines of the measured particles in the image overlay.

If In situ Show is checked, the original image will be replaced by this image.



Size measurements: Results

Display results
The measurements for each particle will be displayed in the Results Table.

Clear Results
If checked, any previous measurements listed in the Results Table will be cleared

Summarize
If checked, the particle count, total particle area, average particle size, area fraction and the mean of all parameters listed in the Set 
Measurements. . . dialog box will be displayed in a separate Summary table (useful for “stacks”). 
Note that while single images ‘Summaries’ are output to the same Summary table, stack Summaries are printed in dedicated tables (named 
Summary of [stack title]). Also, note that descriptive statistics on Results measurements can be obtained at any time using the Summarize 
command.

Add to Manager
If checked, the measured particles masks will be added to the ROI Manager. . .

Results table

File > save as...

Saves the table as comma separated values (CSV)

Which can be imported in Excel, R, Stata, ...



Size measurements: Results

1. Image > adjust > threshold (use Default)
2. Analyze > Measure particles
3. Analyze > Distribution

EXERCISE
Calculate the mean radius of the AuNP in Example 2 – AuNP. Try with and without performing a watershed 

before. Show a distribution of the feret.



Size measurements: Results

EXERCISE
Calculate the mean radius of the AuNP in Example 2 – AuNP. Try with and without performing a watershed 

before. Show a distribution of the feret.



Quantification without thresholding and segmentation



Volume estimation with Cavalieri

Pro
Independent of object
Optical disector
Low coefficient of error

Contra 
thickness must be known
Over/underprojection

3D Object XZ side view XZ view Cavalieri XY view Cavalieri

Systematically uniform grid, 
randomly dropped

t

a/p



Volume estimation with Cavalieri

a/p = 1 cm2

Thickness: 2 cm
Repeat i times (with i = number of banana
pieces)



Volume estimation with Cavalieri

𝑉 = 𝐴𝑝 ∙ 𝑡 ∙ ෍𝑃𝑖

𝑉 = 1 𝑐𝑚2 ∙ 2(𝑐𝑚) ∙ 116
𝑉 = 232 𝑐𝑚3

𝐶𝐸𝑛𝑜𝑖𝑠𝑒 =
𝑁𝑜𝑖𝑠𝑒

σ𝑃
= 2.9 %

𝐶𝐸𝑆𝑈𝑅𝑆 =
𝑆𝑎𝑚𝑝𝑙𝑖𝑛𝑔

σ 𝑃
= 0.8 %

𝐶𝐸𝑡𝑜𝑡𝑎𝑙 =
𝑁𝑜𝑖𝑠𝑒+ 𝑆𝑎𝑚𝑝𝑙𝑖𝑛𝑔

σ 𝑃
= 3.7 %

V by submersion: 230 ml
𝑉 = 230 𝑐𝑚3



Contra 
thickness must be known
Over/underprojection

Volume estimation with Cavalieri: Holmes effect

→ optical sections!
→ Holmes effect

1 slice 5 slices 11 slices



Size measurements: Results

1. Open Example 8A
2. Reduce the Z stack by factor 5
3. For fun (and to make it no longer a binary image): add noise (e.g. with an SD of 50)
3. Throw a random grid over the Image, A/p of roughly 150 pixel^2
4. Count the number of crosses that fall onto the object, on all slices

EXERCISE 
Open Example 8. Reduce the number of slices by factor 10. Then throw a random grid over the stack and do a 

Cavalieri estimation of the volume



4. Analyze > tools > Grid…

5. Count on all slices (in the example: 6 (7?))
6. Volume = count x Area per Point x Reduction factor

Size measurements: Results

EXERCISE 
Open Example 8. Reduce the number of slices by factor 10. Then trhow a random grid over the stack and do a 

Cavalieri estimation of the volume

1. File > open
2. Image > stacks > Tools > reduce…

3. Process > Noise > Add specified noise… (yes, all slices)



4. Analyze > tools > Grid…

5. Count on all slices
(I got 122 counts)
6. Area per point:
200 pixels^2
6. Volume = count x Area per Point x Reduction factor 

Size measurements: Results

EXERCISE 
Open Example 8. Reduce the number of slices by factor 10. Then trhow a random grid over the stack and do a 

Cavalieri estimation of the volume

1. File > open
2. Image > stacks > 
Tools > reduce…

3. Process > Noise > 
Add specified noise…
(yes, all slices)

Cavalieri: 122 000 px3

ImageJ volume counter:

(119 968 px3)



Surface estimation with Buffon’s needle

𝑝 =
2

𝜋
∙
𝑙

𝑡



Surface estimation with Buffon’s needle

𝑆 = 2 ∙
1

𝑛
∙ ෍

𝑖=1

𝑛
𝑣

𝑙𝑖
∙ 𝑙

n = 3  (number of dimensions)
𝑙 = number of intersections
𝑣

𝑙𝑖
= Area per volume

t

𝑙

t = distance between two slices
l = distance between two lines

𝑣

𝑙𝑖
= 𝑡 ∙ 𝑙



Surface estimation with Buffon’s needle

XY XZ YZ

142 164 168

n = 1  (number of dimensions)
σ 𝑙𝑖= 474
𝑣

𝑙𝑖
= 70.7

→ 200 = 14 (distance between two grid lines)
→ 5 (reducing factor, distance between adjacent slices)

S = 
2

3
∙ 474 ∙ 14.14 ∙ 5 = 22 340 𝑝𝑥2

𝑆 = 2 ∙
1

𝑛
∙ ෍

𝑖=1

𝑛
𝑣

𝑙𝑖
∙ 𝑙𝑖

By software: S = 45 236 𝑝𝑥2

(The surface area is resolution-dependent! Using meadian filter to reduce the 
resolution:
Kernel 2 radius:  S = 37 528 𝑝𝑥2

Kernel 4 radius:  S = 33 744 𝑝𝑥2



Number estimation with the disector



Stereology



✓ Congratulations,
You finished Part III, Thresholding, segmentation and 
(particle) size analysis 
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