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e Executing the job

Experiment

1. Move to a fresh piece of the specimen.

2. Select Microscope > Set stage Origin from the Microscope menu to define the current

position as the starting point.

3. Use Execute from the same menu to run the job.
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Select the diagnostics node to see more information about failed correlation
alignments. In the above example, the quad 4 detector was set to External, resulting in
a uniform gray image.

If the alignment succeeds, you get the option to set the beam shift to correct for the
error. It is a good idea to select Yes and re-run the alignment. The second time should
also succeed, and the measured shifts should now be very close to zero.

Alignment result

Alignment succeeded. Shift (-7.1094 pm, -4.9219 pm).

Cotrect with Beam Shift?

e -

Experiment: STEP 3 — Aligning to the previous row

- Add a second correlation alighnment, setting it up identically to the first one, except:
+ The ReferencelmageOffset is 0, =10 um (instead of =10 pm, 0)?
+ Set the name to “Align to previous row”.

2. Select Layer 1 and sets its Alignment to be this alignment.

3. Set the template area to only just contain the circle; this also reduces the size of the
scan area and it should be possible to make the red border disappear.

4. When testing the circle needs to be about 10 um below the screen center, so make a
relative stage move of —0.010, 0.010 mm (assuming you still are where the previous
alignment was tested).

2 This will cause it to get a red border because you are now trying to scan outside

the field of view — we will fix this below

Demonstration: Nanobuilder User iNterface ...........uuueeuererurererereiiiiieriieiiienesesnnesenenennnnnneee 7

Demonstration: JOD @ditiNg .......ccveiiiiiiiii e 20
Tutorial: Creating and executing a job with alignment from file........ccccccevveiiiininenn. 26
Tutorial: Stitching multiple Write fields ......cccueei i 34
Demonstration: Job editing .........coeecciiieieee e, Error! Bookmark not defined.
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Demonstration: Nanobuilder User interface

Experiment: STEP 2 — Aligning to the previous column

Prerequisites:

1. Right-click Alignments and choose Add alighment > Correlation alignment. Sample loaded, stage pumped

. E-beam and ion beam active
Overview I
=+ s Job ; :
= & Project - Unnamed Project Learn about the graphical user interface
- % Lapers [3]i| Add alignment » ‘ AutoScript alignment
“ Layer 0 Correlation alignment Menu bar Graphical view of job
- Layer ) i
Layer 2 LineScan alignment

Be Edt et Yew Maoscope Heb

2. Click Browse in the dialog that appears, select the saved image, and click OK. s T .
ob overview
structure
3. The new alignment is automatically selected:
- Set the ReferencelmageOffset to —10 um, 0
(to make the alighment search at the previous site)
- Set the name to “Align to previous column”. — .
e | Describes
Fuance (::I(‘,lm') properlies of
4. Select Layer 0. . 100,05 job item
. . " (520 5) selected in
- Set the alignment to be the newly created alignment. e 00 258 overview

1000

True

- Ensure the AlignmentStrategy is CorrectShiftWithMicroscope.

300 pm
Line Scan Aligament Loyer
Detauit

5. Click in the center of the alignment to
select the Template area and resize it to

HorizontalFwldWidth
The horizontal feld width (magnication = size of Image
on mantor / s velue)

only just contain the central circle (by zoom-

. . . + 1821, 83 onnected RO MCroscope
ing in you are able to decrease the grid ‘T L :
pitch and make smaller steps when T
. L. Mouse Status bar Help area explaining what the selected item controls.
dragging). It is important to have as few location (In this example, the selected item is HFW.)

other features visible as possible, because
the alighment may otherwise try to

align these to random features (dirt) on the
specimen.
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7. From the Insert menu, choose Basic Shapes > Circle.
- Set the OuterRadius to 0.5 um, 0.
- Set the Position to 0, -10 um.

8. From the Insert menu, choose Basic Shapes > Path.

- Expand the Points section. =+" % Shapes (2)

- Set the first point to 1 um, 0. e ':!'C"ﬂ [on Layer 2]
& Circle D [on Layer 2]

=+ % Templates (1)
- Set the Line width to 200 nm. Y Path 0 [on Layer 2]

- Set the second point to 2 um, 0.

9. Drag the Path from the Shapes into the Templates section. It now becomes available
for Reference shapes.

10. From the Insert menu choose Composite Shapes > Reference (to a Template). In the
dialog that appears:

- Ensure the Template is set to Path O.

- Ensure the Rotation is set to 0°.

- Click OK.

11. Repeat 3 more times, setting the Rotation to 90°, 180°, and 270°, respectively.
12. Select all 4 References and set the Position to be —10 um, O.
13. Select Layer 2 and set the Time to 10s.

14. Save your file.

e (Creating the Alignments

You must first create a correlation alignment image that can be used as reference
image (the image to search for). The most convenient is to acquire it in the xT Ul, save
it and load that image into NanoBuilder.

Bounding box

Drag handle

Shape position
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ThermoFischer SCIOS 2 Introduction — Page 34

Tutorial: Stitching multiple write fields

Prerequisites:
Sample loaded, stage pumped
E-beam and ion beam active

Create repetitive designs with stage movement and correlation alignment

e Goal of the tutorial

The goal is an array with each cell consisting of an outer circle (donut), a cross and a
central dot. Between any two cells there is a stage movement.

At each stage location the following
will be milled (shown in red):

. a large donut in the write field
center

. the 4 lines that make a cross in
the column to the left

0 . a small dot in the row below

IStage move

To allow judging the alignment
quality each cell consists of parts
patterned at 3 different stage
positions (as shown in red)

Stage move

e Creating the job

Experiment
1. Start a new Nanobuilder job

2. Add new layers by right-clicking in the tree view.

D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland

ThermoFischer SCIOS 2 Introduction — Page 11

Circle
The circle represents a solid disk. If the inner radius has a value greater than 0, it
becomes a donut.

Shape-Specific Properties:
- Outer radius
- Inner radius

@0

Circle shape with inner radius >0

Circle shape

Path

A path is a single line or a number of connected lines, all with the same line width. To
edit the points (or add/delete points), select the path shape, right-mouse click and
select Edit Points. The shape will now be shown in Edit Mode, allowing you to drag the
points. Add points by dragging the red line between two points; this will insert a new
point between the two points. Alternatively, enter the exact point coordinates in the
shapes property area.

Shape-Specific Properties v EndStyle: Specifies how the two ends are drawn (rounded
or straight) v Width: The line width of the path v Points: The end points of the line
segments that define the path

Add point
Delete point Del
Stop editing points

Path shape

Path shape in edit mode
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4. Enable layers 1, 2, and 3 by selecting
them and right-clicking Toggle enabled
from the popup menu, or right-clicking True
in the Enabled property.

5. Set HFW to 300 um for each layer.
6. Set the thickness to 10 nm.

7. Cycle through each layer and set the
beam current for each layer. Choose one

of the available apertures. The range of
typical beam current settings is 1 pA to 1 nA.

Overview

3 = Job
= & Project-UIB
= < Alignments (1)
# L, Line scan alignment 1
- % Layers (5)
“ Layer0

-
mll L oyer 2
“ Layer3
“ Line Scan Alignment Layer
# % Shapes (1)
¥ % Templates (3)
# =1 Site list (empty: current site)

Properties of selected object(s)

8 Alignment
g Line scan alignment 1 v
AlignmentStrateqy No alignment
8 Exposure e scan alig

e Step 8: Disable layers not to be patterned

Load Change Pattern

GDsll |»(Configurel | pattern ||  the |-

File Layers Order Fiducial

Layer O (fiducial) and the Line Scan Alignment
layer help define the line Scan alignment and
should not be patterned, so they should be
disabled.

Experiment

Right-click on Layer 0 and choose Toggle
enabled from the popup menu. Or, right-click
True in the Enabled property.

Add Use Align- i
Align- [ mentin Disable Save
ment Layers Layers Job
Overview
5 =] Job
= & Project-LIB
= 4 Alignments (1)
# 1, Line scan alignment 1
= % Layers (5)
“ Layer1 Toggle enabled
“ Layer2 Bring to front
o Bring forward
“ Line Scan Alig| =
% % Shapes (1) fr\d backward
# % Templates (3) Send to back
# -1 Site list (empty: curre Delete Del

Disabled layers have a gray icon and are not drawn in the graphical view.

Text

With the text shape the design can be annotated with
text labels; these labels are patterned and behave just
like any other shape.

Shape-Specific Properties

- Alignment: Specifies how the text is placed with respect to the position
- Font: Specifies font type, style, and size

- Text: the text to display and pattern

e Composite Shapes

Composite shapes are shapes that are a combination of other shapes. The specific
composite shape defines how the shapes are combined.

Boolean Shapes and Reference Shapes can be identified within the composite shapes.
- Boolean shapes use logical operations like AND, OR, XOR to combine the child
shapes. The child shapes can be composed by dragging the shapes into the
composite within the tree view. Though Boolean operations are typically
applied to two operands, in NanoBuilder any number of child shapes is allowed.

The individual shapes that make up the composite can be edited
independently. With Boolean Shapes, all child shapes will inherit the layer of
the composite.

- Reference shapes implement the concept of re-using copies of an existing
shape (the template). Such references are based on a transformation or
repetition of one of the shapes that has been placed in the Templates
collection (see “Reference”).

Composites can be nested allowing you to create complex shapes.

Structure
A structure is a collection of shapes, typically used for grouping shapes in a functional
block. The individual shapes can reside on different layers.



pueazums | 8anoqui4 Jo Alsiaaiun | 21nisul 3PN aydjopy | ayaayuea
*T 3uswWudi|e ueds aul 33|9s pue sieadde 1eyi mosie umopdolp ayl uo Y1 ‘€

‘(yuawudie
ON sAes 11 auaym) eaue sainiadoud ay3 ul Juswusdi|y Jo 1S4 3y 03 Xoq ay3 ul Y1) ¢

(2112 + YIYS) €-T 494712335 °T

juswiaadxy

'si9he| 9|diynw uy uswugije 9|3uls e 3ulieys pue ‘uawudije oYUM siahe|
Suiney ‘siaAe| jualaylp 404 syuswudije JuaJap Suiney smojje dais eJIxd SIYL ‘M dsn
pinoys 1eys JaAe| yoes 031 paudisse aqg isnw jusawusije ayy ‘awudije ue Sululysp JaYY

qor siekeq slake jusw [eronply 18pI0 sioke a4
] uj Jusw -uBiy Ul e— uioNed < ~—| 11sas
9nes 9laesia ubiy es| pPPY wsjed abueyn ainByuod peo
sioAe| Joy3o ul Jusawudije sy asn :£ doys e
I ~ u0|| l pioday ] I saul aieiauar) I
Buiuies| ajyoid uesg

‘uawubije siy) jo aweu ay |

aweN
,S9ulq 91eJauan),, g ewbis yloows
g £ Aunnisuag
UM Sueds Ul 9y} dlesauasd-al < 0 NOPUM [DIG0G
ued noA ‘ugisap sy paiipow NoA | ssaujsnqoMisag uoneziwndo
| uawubije uesgaur awep
50 8J02S WnwiuIy
% ¥ Awonse(3

juBwubiy 5
¥ ‘YIPIM u0!12J331U| 1°§ ani] 189S0 uieb one asn
9 yipm uonesbau|
il : wri goL P pI81 |BIUOZLIOH
wn 00€ :YIPIM PI3!d |BIUOZIIOH 13S = L S—
sl | awn [|aMmg

jJuswiaadx3y uomsinboy g

:3|ge|ieAe aJe suoido 4o Jaquinu e ‘4 YU

T€ 9884 — UOIINPO.IU| T SOIDS 49YdSI40WIaY |

pueazums | 8anoqu4 Jo Alsiaaiun | 1nisu| P3N aydjopy | ayasyuea g

(9us awund) sayg 4

(fidws) sejeidwa) o ¢
(@ 09 anpruis =@
() vogoossoy (g6
(2) souamyq g
(2) vosnpg -

[0 /=) U] | ofuepey @ |
@) voun g
(g) sadeys -:'-. 8

sadeyg apsodwo?) ajdwexg - pala:d&@
-5
LT

MINRBAD
'301M} pauJaned

10U aJe syed Suidde|dano ‘@4n3onais ayl Ijun adeys 3iq SUO 03Ul SIUSNHISUOD
9y3 Suiduaw ‘uoesado YO uesjoog ay3 Jo Jusjeainba ays sI adeys uolun ay |
uoiun

‘3uianed |elas 03 195 S| J9Ae| 9Y3 JI USAS ‘uolysey |9]|eled
e ul pauJanied aJe 34n3oNnJls 3yl UlyHM sadeys ay3 ‘pa1da)|as si |9||eded uianied shem|y §|
saldadoud aif1pads-adoys

(aus wawno) sayg -
(fdwe) sepeidwia) o o
¢) uogossiew g
() souaseyq _ g
lpeiequo) | opi) @ |
[0 sofe uo] | afueay M
(@) uoun -2
(@) uosnprg -0
@ 09 amprug BB |
(g) sadeys o «-=

glofe]
(R
0Jofe] m-i
&5
(fdwa) spauubiyy - |
sadeys aysodwo) ajdwerg - palag & -5
qop n:_'.ma
MINBAQ

T 98ed — U0IIINPO.IIU| T SOIDS JaYISIoWIBY |



ThermoFischer SCIOS 2 Introduction — Page 30 ThermoFischer SCIOS 2 Introduction — Page 15

e Step 6: Add an alignment (only when fiducial patterning was successful) Intersection
The intersection shape is the equivalent of the Boolean AND operation, only patterning
. the overlapping parts of the shapes.

Load Change Patt Add Use Align- ) )
GDSslI _,_Clc_)nﬁgure | Pattern |—»| e;h:rn Align- mentin |»| Disable | | Save OVG‘V:GW

File ayers Order Fiducial ment Layers Layers Job -+ 3 Job

& ’ Project - Example Composite Shapes
Using alignments achieves two things: - < Alignments (empty)
. . . . - % Layers (3)
o Align a layer to the sample: Accurately position the patterns in a layer relative ] [P
to these marks by finding marks on the sample. Even if the position relative to - x;

the sample is not critical, it is useful to align layers with respect to each other.

o Drift correction: Correct for drift while patterning by realigning at fixed intervals
during patterning.

&+’ % Shapes (5)

o Redangle1[on§1er0]
.- @ Cicle 1on Layer 0]

- B Exclusion (2)

Experiment: Add an alignment : -9 Stucture 60 (2)

1. Select Alignments in the Overview. Sttes (cument site)

Exclusion
The exclusion shape is the equivalent of the Boolean XOR operation, patterning

everything except for the overlapping parts of the shapes. This is the inverse of the
Intersection shape.

2. Add an alignment either by right-clicking the alignment selection or by selecting “Insert
> Alignment”. In this example, choose Line scan alignment from the list.

Correlation alignment Add alignment re— | IE.;;;E I Overview
Line scan aignment Layer -+ % Job
) e e ’
Auto Seript alignment Pattern R = ’ Project - Example Composite Shapes
Reference » S Aignments (empty)
> Alignment » Correlation alignment 9' L:yetL:y(:f) 0
Line scan alignment i -‘ Layer 1
A new entry will appear in the overview list: Auto Seript alignment Lo oy
Ov:e:wew &3+ % Shapes (5)
=108 Job i

t" Exclusion (2)

. -E Rectangle 1 [on Layer 0]
“-@ Circle 1[on Layer 0]

- Difference (2)

- B Union (2)

&-'d’ Intersection (2)

i #-% Structure 60 (2)

.......‘:. Templates (empty)

== Sttes (cument site)

= & Project- Unnamed Project
=-4 Alignments (1)
to
#F | ayers (empty)
% Shapes (empty)
% Templates (empty)
- Sites (current site)

D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland
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Select an object (e.g. Layer 1) and find the patterning options under “Process”

v Layer
Horizontal field width 265 um
Name Layer 1
Enabled True
Color [ 128, 128, 0, 128
v Process Modified Default
Name Default
v Beam lon, 30 kV, 100 pA
Beam lon
Current 100 pA
Energy 30 kV
v Patterning 1 ps, 50 %, 0.15 um?*/nC
Dwell time 1s
CQverlap 50 %
Pitch (12 nm)
Auto blank True
Pattern sequencing Parallel
Volume per dose 015 pm?/nC
Blur 0 pm
Interaction diameter 0 pm
Maximum dose per area 0C/m*
Refresh time 0s
Relative interaction diameter 0%
Saturation current density 20 nA/nm*
Saturation sputter rate 0 myfs
Beam diameter 24 nm
GIS <no gis>

Note: default settings can be changed in File > Preferences

e Step 3: change the order of the layers

Load ) Change Pattern Add Use Align- )
GDSII Configure Pattern the > Align- » mentin || Disable | _| Save
File Layers Order Fiducial ment Layers Layers Job

Experiment: Change the layer order

The layers will be patterned in the sequence in which they are shown

Overview
= :- Job
- & Project - Unnamed Project
5 % Alignments (empty)
+- % Layers (3)
-+ % Shapes (2)
i aF Reference 1
9l Feference 2
= :l Templates (1)
=-Cg My Structure (3)
- Rectangle 1 [on Layer 0]
| @ Circle 1 [on Layer 1]

(] :
o L4 Polygon 1 [on Layer 2]
= Sttes (cument site)

a O

Template

[Hy Structure -

Rotation 45° Scale 0.9
(] O Name Reference 2

Posttion X  40.541 ym Position Y 1.4353 um

Array

The Array shape allows you to repeat in existing shape in a regular grid. Optionally the
repeated shape—which has to be a template—can be rotated and rescaled when it is
repeated in the grid

Shape-Specific Properties

- Template: The shape that should be repeated in the array (the referenced template)
- Rotation: Angle to rotate the template with (default is 0)

- Scale: Scale factor to increase or decrease the size of the template (default is 1)

- Columns, rows: The number of columns and rows for repeating the template

- Pitch X,Y: The spacing between the repeated shapes

- Center X,Y: This is an alternative representation of the position of the array, using the
center as the point of reference; this facilities aligning the center of the array to a
specific position
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Tutorial: Creating and executing a job with alignment from file

Prerequisites:
Sample loaded, stage pumped
E-beam and ion beam active

Load a file, specify the patterning, add alignments and execute the job

Note: Nanobuilder does not adjust focus and stigmation! Therefore, all the beam
currents being used must be in focus and stigmated. Small amounts (< 2 um) of beam
shift between the currents are allowed.

e Step 1: Import a GDSII file

Load Change Pattern Add Use Align- .
GDSIl |»{Configurel | patten |» the Align- mentin || Disable | | Save
File Layers Order Fiducial ment Layers Layers Job

Although you can create designs in NanoBuilder, this tutorial starts from a GDSII file, as
this is a common use case. You create your design offline.

Experiment: load a GDSII file

- File > Import GDSII > go to: c:\Program Files (x86)\Fei\NanoBuilder\ -
Documentation\Tutorials\Tutorial01

- Open the file Tutorial01.gds

Note: do NOT overwrite the file! Save is under another name.

e Step 2: Configure the layers

Load ) Change Pattern Add Use Align- )
GDSslI CEnflgure Pattern the | Align- —» ment in | »| Disable | | Save
File ayers Order Fiducial ment Layers Layers Job

- Pixel: The size of a pixel when patterned (pixel size = physical size/bitmap resolution).
The maximum possible dwell time of a pixel-if it has value 255—is the dwell time as set
for the layer.

Overview
=) :l Job
- _q_' Project - Unnamed Project
‘%) Alignments (empty)
=F 3
(| Layer 0
= :c Shapes (1)
-~ Bitmap 0 [on Layer 0]
v :c Templates (empty)
i Sttes (cument site)

StreamFile Shape

The StreamFile shape allows you to add an existing stream file (a native xT format for
specifying pattern points) to be included in the design. The stream file has to be
specified when the shape is added.

- The dwell times of the points in the stream file are not determined by its layer, but
merely by the times specified for each point in the stream file.

- The number of passes is determined by the layer. When loading a stream file the
number of passes for the layer is initially set to the value from the stream file, but you
can edit this afterwards.

- Because the number of points in a stream file can be considerable, not all points are
drawn for performance reasons. They may lead to interference patterns in the display.
Zooming in to scale of a pattern point will show all points within the view port.

Overview
=-+" % Job
- & Project - Unnamed Project
| % Alignments (empty)
—-#F Layers (1)
i el
4" Shapes (1)
| 338 streamfile_example Jon Layer 0]
i.-3” % Templates (empty)
232 Sites (cument site)
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Changing array properties
1. Select Array 0 in the Shapes list in the Overview pane.
2. Change the Maghnification to 0.2, and set the column pitch to 5 um

Reference Shape Influences Design

To see how changing the reference shape
influences the design:

1. Select the circle template.

2. Change the inner radius to 2 pm (from 10 um
before).

As shown below, both references have changed.
When you change a template, all references to that
template will change. Also note that the original
circle displays when it is selected in the Overview
pane.

Overview
= 5 Job
= & Frojea-Unnamed project
B Alignmers (nane)
= ® Loyers (1)

* = Ste bst (empty Current site)

Propenies of selected object(s)

B Patterning

ScanDirection CucularOutsideTolnside
& Shape

InnerfRadus 2 pm

OuterPadius 12

Ensbled Truw

Layer Layor 0

Name Circle pottem 0
& Postion 0 um, 0 um

D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland
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2. Click on the circle that appears to select it. Resize the circle using the drag handles or
enter the exact radius numerically.

3. Change the inner radius to e.g. 10 um and the outer radius to 12 um.
B Bt lost Yew Mooscops tep

Overview
= - job
= & Project- Unnemed project
B Agnments (none)
“ ® Layers (1)
- Loyerd
= % Shepes(1)
© Circls patern 0 [on Layer 0]
%% Templetes (nane)
® 4 Sae list (ermgay curren she)

Propertes of selected object(s)
O Patterning
Scanlwection CrodarOutsade Toinside
© Shape
10 pm
OuterRodus 12 pm
Enatied Trve
Leyer Layer 8
Name Circle pattorn 0
@ Poston 0 wm, 0 um

InnerRadius
The inner radius of the circle. A nor-2ero value gves a donut
shape

276, 127 Hm Cnme:mdto ITICOSCOpe.

4. Select the scan direction for patterning. (See also “Scan Direction” below)

B Patterning
CircularOutside Tolnside v
B Shape SerpentineBottomToTop
InnerRadius SerpentineTopToBottom
OuterRadius SerpentineLeftToRight
Enabled SerpentineRightToLeft
Layer Circularinside ToOutside
Name CircularOutside Tolnside
B Position 0 um, 0 um |

D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland
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