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 Executing the job 

Experiment 

1. Move to a fresh piece of the specimen. 

2. Select Microscope > Set stage Origin from the Microscope menu to define the current 
position as the starting point. 

3. Use Execute from the same menu to run the job. 
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Universal rules 

Rule 1: don't touch a control if you are not sure of the 
outcome of that action 

Rule 2: never, ever force anything beyond finger strength 

Rule 3: wear gloves when touching anything that goes into 
the chamber 

Rule 4: if in doubt, ask for help 
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 Adding stage sites 

Experiment 

1. Right-click Sites and choose  
Add stage site array.  
In the dialog that appears: 
- Set the row and column pitch  
to be 10.2 µm.3  
- Set the number of rows and  
columns to be 5 each (25 sites). 
- Leave the origin blank. 
- Press OK.  

2. Select the first site, select  
Execute specific layers and  
select only Layer 2. 

3. Select the next 4 sites  
(remainder of the first row),  
select Execute specific layers and select  
Layer 0 and Layer 2. 

4. Select the remaining sites, select Execute  
specific layers & select Layer 1 and Layer 2. 

5. Set the Failed site strategy to AbortJob.  

6. Save the job. 

 
 

3 Theoretically these should be 10 µm, but we're going to introduce an intentional error so the alignments 
have something to correct. Note that the error is cumulative, so the last site will have 0.8 µm error. 
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Select the diagnostics node to see more information about failed correlation  
alignments. In the above example, the quad 4 detector was set to External, resulting in 
a uniform gray image. 
If the alignment succeeds, you get the option to set the beam shift to correct for the 
error. It is a good idea to select Yes and re-run the alignment. The second time should 
also succeed, and the measured shifts should now be very close to zero. 

 
 

Experiment: STEP 3 – Aligning to the previous row 

- Add a second correlation alignment, setting it up identically to the first one, except: 
+ The ReferenceImageOffset is 0, –10 µm (instead of –10 µm, 0)2  
+ Set the name to “Align to previous row”. 

2. Select Layer 1 and sets its Alignment to be this alignment. 

3. Set the template area to only just contain the circle; this also reduces the size of the 
scan area and it should be possible to make the red border disappear. 

4. When testing the circle needs to be about 10 µm below the screen center, so make a 
relative stage move of –0.010, 0.010 mm (assuming you still are where the previous 
alignment was tested). 

 

 
2  This will cause it to get a red border because you are now trying to scan outside      
 the field of view – we will fix this below 
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Nanobuilder environment 

NanoBuilder is an application for rapid nano-prototyping using ion-beam processes to 
create desired structures available in CAD files. Examples of applications are:   

 a sloping surface to make a tilted nano-mirror 
 optical resonators 
 nano-imprinting  

The NanoBuilder Product Line consists of NanoBuilder itself and NanoArchitect™ (for 
use on a PC without a microscope), allowing you to create, view, and edit NanoBuilder 
jobs. NanoBuilder: 

 makes it easy to pattern CAD (GDSII CAD file) designs with the SEM/FIB.  
 Optimizes unique parameters for EBID and IBID operation.  
 Adds SEM- and FIB-specific information such as beam energy, current, 

patterning parameters, GIS parameters.  
 Automates the alignment of layers/patterns to fiducials on the sample, not only 

beam shift, but also rotation, magnification and shear errors.  
 Automatically patterns the layers/patterns with the given settings at multiple 

locations on the sample.  
 Allows designing structures without the need for an external GDS editor. 
 Allows creating structures that span multiple write fields.  
 Create structures that span multiple write fields 

Other GDS editors include: 

Name Website 
Layout Editor  http://www.layouteditor.net/ 
KLayout http://www.klayout.de 
CleWin http://www.wieweb.com 
L-Edit Pro http://www.tannereda.com/l-edit-pro 
Electric http://www.staticfreesoft.com 
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6. To test the alignment: 

- In the xT UI, make a relative stage move of 0.01 mm in x-direction (the 
  circle needs to be about 10 microns left of the screen center). 
- In NanoBuilder, right-click Layer 0 and select Test alignment. 

 
The alignment fails – what to do? 

Change the minimum score 
If the alignment fails the most common problem is that the minimum score is set too 
high. The dialog that appears upon failure tells the actual score. Select the alignment 
and set the MinScore to a value somewhat lower (e.g., half of) the value in the dialog. 

 
Other reasons 
Try to find the cause selecting the Diagnostics item (expand the alignment in the tree 
view). If you do not see the template in the Matched Image then most likely the 
detector settings are wrong or the shift is larger than the scan area. 
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Experiment: STEP 2 – Aligning to the previous column 

1. Right-click Alignments and choose Add alignment > Correlation alignment.  

 

2. Click Browse in the dialog that appears, select the saved image, and click OK. 

3. The new alignment is automatically selected: 
- Set the ReferenceImageOffset to –10 µm, 0  
   (to make the alignment search at the previous site) 
- Set the name to “Align to previous column”. 

4. Select Layer 0. 
- Set the alignment to be the newly created alignment. 
- Ensure the AlignmentStrategy is CorrectShiftWithMicroscope. 

5. Click in the center of the alignment to  
select the Template area and resize it to  
only just contain the central circle (by zoom- 
ing in you are able to decrease the grid  
pitch and make smaller steps when  
dragging). It is important to have as few  
other features visible as possible, because  
the alignment may otherwise try to  
align these to random features (dirt) on the  
specimen. 
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Demonstration: Nanobuilder User interface 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Learn about the graphical user interface 
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Demonstration: Shapes 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Learn about the three different shape types in Nanobuilder  

The shapes in NanoBuilder are grouped in a number of categories:  
- Basic shapes: Simple geometric shapes  
- Composite shapes: Shapes that are combinations of other shapes  
- Special shapes: Shapes that deviate from the general concept of a shape  

 Shape Properties  

Each shape has a number of properties that are shown in the property box when the 
shape is selected.  

- Some properties are applicable to all shapes (Name, Position, Layer), while 
others will vary from shape to shape.  

- The available ScanDirections, (in the order which the pattern points are 
generated/rastered), will also depend on the specific shape.  

 Display and Selection  

Shapes are visualized with the color of their layer and drawn in the same order as they 
are listed in the project. A slight transparency is applied to ensure overlapped shapes 
are still visible.  

A shape is selected by clicking on the shape in the viewer or by clicking on its node in 
the overview tree. When a shape is selected, additional annotation is shown: its 
position (red cross), the bounding box, and drag handles. 
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Experiment: STEP 1 - Acquiring the reference image 

1. Load a sample that is easily marked by the FIB, like a piece of silicon wafer 
(for example the calibration wafer on the standard multi-stub sample). 

2. Using the xT UI, set the stage to: 
- eucentric position  
- 52° tilt 
- optimize focus and stigmation for the FIB at 30 kV, 10 pA  
- Image resolution: 1536x1024 
- Dwell time: 10 µs 
- Detector: SE 

3. Run Auto Contrast and Brightness (F9). 

4. Move to a fresh piece of sample, with as few existing features and particles as possible. 

5. In NanoBuilder, right-click on Layer 2, select Execute at current location and wait until 
patterning has completed. 

6. In the xT UI grab a single FIB image (F6+F6)  

Any shift between patterning and acquisition will result in an alignment error, so don't 
wait too long (drift) and certainly don't use beam shift or stage moves to position the 
image. 

7. In the xT UI select File > Save as, 

- select Tiff 8 bit gray scale Image Files  
- unselect both Save Image with  
Databar and Save image with overlaid  
graphics.  
Save the image in the folder where 
 you saved the job. Right-click to execute it (without executing the other layers). 
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7. From the Insert menu, choose Basic Shapes > Circle. 
- Set the OuterRadius to 0.5 µm, 0. 
- Set the Position to 0, -10 µm. 

8. From the Insert menu, choose Basic Shapes > Path. 
- Expand the Points section. 
- Set the first point to 1 µm, 0. 
- Set the second point to 2 µm, 0. 
- Set the Line width to 200 nm.  

9. Drag the Path from the Shapes into the Templates section. It now becomes available 
for Reference shapes.  

10. From the Insert menu choose Composite Shapes > Reference (to a Template). In the 
dialog that appears: 

- Ensure the Template is set to Path 0. 
- Ensure the Rotation is set to 0°. 
- Click OK. 

11. Repeat 3 more times, setting the Rotation to 90°, 180°, and 270°, respectively. 

12. Select all 4 References and set the Position to be –10 µm, 0. 

13. Select Layer 2 and set the Time to 10s. 

14. Save your file. 

 Creating the Alignments 

You must first create a correlation alignment image that can be used as reference 
image (the image to search for). The most convenient is to acquire it in the xT UI, save 
it and load that image into NanoBuilder.  
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Demonstration: Shape editing 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Create new shapes in Nanobuilder  

When a shape is selected, its size and position is editable directly in the viewer. Adjust 
the size by using the drag handles that are attached to the bounding box of the shape. 

To move the shape, position the mouse cursor inside the bounding box and drag the 
shape (hold the mouse button down while moving).  

For ultimate precision, use the property box (lower-right part of the screen) to edit the 
position and dimensions (and other properties of the shape) using numeric keyboard 
input.  

Adjust the order in which the shapes are patterned (and displayed) by dragging their 
nodes in the overview tree. Alternatively, right-click on the shape in the overview tree 
and use the menu items Move Up, Move Down, Move to Top, and/or Move to Bottom 
to adjust the order.  

 Grid and Snap  

A grid with snapping drag handles is available to facilitate shape editing in the viewer. 
The grid can be enabled via View > Grid.  

The grid will scale dynamically with the zoom level with no need to specify the grid-
spacing. If you need a higher grid density, just zoom in. 

 Basic Shapes  

The basic shapes are the straight-forward geometrical shapes and can be considered as 
the NanoBuilder primitives.  
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Add two new layers. The first two layers will only  
be used to run an alignment; they will not contain  
any shapes. 

3. Select all three layers (to set all values at once): 
+ Set the horizontal field width to 50 µm. 
In the process section: 
+ Expand Beam and set the Ion Beam to 10 pA and 30 kV. 
+ Expand Patterning and set 1 µs dwell and 0% overlap. 
+ Ensure GIS is set to <no gis>. 
+ Set up all three layers at the same time to ensure they have identical 
settings. The time shows as (0 s) because no shapes have been added yet. 

 
 
 
 
 
 
 
 
 
 
 
 
4. Now shapes will be added. Select Layer 2  

5. Click in the graphical area. Press * (centers the zoom). This ensures that newly added 
shapes will not have an offset. 

6. From the Insert menu, choose Basic Shapes > Circle. 
- Set the OuterRadius to 3 µm. 
- Set the InnerRadius to 2.8 µm. 
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Tutorial: Stitching multiple write fields 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Create repetitive designs with stage movement and correlation alignment 

 Goal of the tutorial 

The goal is an array with each cell consisting of an outer circle (donut), a cross and a 
central dot. Between any two cells there is a stage movement. 
 

At each stage location the following 
will be milled (shown in red): 
 a large donut in the write field 
center 
 the 4 lines that make a cross in 
the column to the left 
 a small dot in the row below 

 
To allow judging the alignment 
quality each cell consists of parts 
patterned at 3 different stage 
positions (as shown in red) 
 

 Creating the job 

Experiment 

1. Start a new Nanobuilder job 

2. Add new layers by right-clicking in the tree view. 
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Circle  
The circle represents a solid disk. If the inner radius has a value greater than 0, it 
becomes a donut.  

Shape‐Specific Properties: 
- Outer radius  
- Inner radius 

 
Path  
A path is a single line or a number of connected lines, all with the same line width. To 
edit the points (or add/delete points), select the path shape, right-mouse click and 
select Edit Points. The shape will now be shown in Edit Mode, allowing you to drag the 
points. Add points by dragging the red line between two points; this will insert a new 
point between the two points. Alternatively, enter the exact point coordinates in the 
shapes property area. 

Shape-Specific Properties  EndStyle: Specifies how the two ends are drawn (rounded 
or straight)  Width: The line width of the path  Points: The end points of the line 
segments that define the path 
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Shape‐Specific Properties:  
- EndStyle: Specifies how the two ends are drawn (rounded or straight)  
- Width: The line width of the path  
- Points: The end points of the line segments that define the path 
 
Rectangle  
The rectangle represents a solid rectangular area, specified 
by its width and height.  

Shape‐Specific Properties: 
- Width: Horizontal dimensions  
- Height: Vertical dimensions 

Polygon  
A polygon is a solid multi-line shape, varying from three-point triangle to any number 
of points. To edit the points (or add/delete point), select the polygon, right-mouse click, 
and select Edit Points. The shape is now shown in Edit Mode, with points that drag. 

Points can be added by dragging the red line between two points. This will insert a new 
point between the two points. Alternatively, enter the exact point coordinates in the 
shapes property area. 

Shape‐Specific Properties  
The points are the end points of the line segments that circumference the polygon. 
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 Step 9: Save and execute the job 

 
Save the job 
Use File > Save to save the job as an .nbj. file. Or use File > Save as to give it a new name.  
Do not overwrite the original file! 
 
Note: GDSII is not savable, since that format cannot store the extra data that was added.  
 
Execute the job 

At this point, the color of the line scan alignments changes from blue to green, 
following successful line scan alignment at that line. Red indicates failure 

Select Microscope > Execute to begin the patterning / executing the job. The progress is 
shown in the progress window and in the status bar. The progress window is minimized 
by clicking Hide and reopened by double-clicking the status bar. 

 
Failed site strategy 
If an error occurs during job execution, a failed site 
strategy message displays in the Job window. 
 
There are two strategies: 

 ContinueWithNextSite: Stops execution at 
the current stage position and continues 
processing at the next site. 

 AbortJob: Stops execution of the entire 
job. 
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4. Enable layers 1, 2, and 3 by selecting  
them and right-clicking Toggle enabled  
from the popup menu, or right-clicking True  
in the Enabled property.  

5. Set HFW to 300 µm for each layer.  

6. Set the thickness to 10 nm. 

7. Cycle through each layer and set the  
beam current for each layer. Choose one  
of the available apertures. The range of  
typical beam current settings is 1 pA to 1 nA. 
 

 

 Step 8: Disable layers not to be patterned 

 
Layer 0 (fiducial) and the Line Scan Alignment 
layer help define the line Scan alignment and 
should not be patterned, so they should be 
disabled. 
 

Experiment 

Right-click on Layer 0 and choose Toggle 
enabled from the popup menu. Or, right-click 
True in the Enabled property.  

Disabled layers have a gray icon and are not drawn in the graphical view. 
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Text  
With the text shape the design can be annotated with 
text labels; these labels are patterned and behave just 
like any other shape.  

Shape‐Specific Properties   
- Alignment: Specifies how the text is placed with respect to the position  
- Font: Specifies font type, style, and size  
- Text: the text to display and pattern 

 Composite Shapes  

Composite shapes are shapes that are a combination of other shapes. The specific 
composite shape defines how the shapes are combined.  

Boolean Shapes and Reference Shapes can be identified within the composite shapes.  
- Boolean shapes use logical operations like AND, OR, XOR to combine the child 

shapes. The child shapes can be composed by dragging the shapes into the 
composite within the tree view. Though Boolean operations are typically 
applied to two operands, in NanoBuilder any number of child shapes is 
allowed. The individual shapes that make up the composite can be edited 
independently. With Boolean Shapes, all child shapes will inherit the layer of 
the composite. 

- Reference shapes implement the concept of re-using copies of an existing 
shape (the template). Such references are based on a transformation or 
repetition of one of the shapes that has been placed in the Templates 
collection (see “Reference”).  

Composites can be nested allowing you to create complex shapes.  
 
Structure  
A structure is a collection of shapes, typically used for grouping shapes in a functional 
block. The individual shapes can reside on different layers. 
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Shape‐Specific Properties 
If Always pattern parallel is selected, the shapes within the structure are patterned in a 
parallel fashion, even if the layer is set to serial pattering.  

Union  
The union shape is the equivalent of the Boolean OR operation, merging the 
constituents into one big shape. Unlike the Structure, overlapping parts are not 
patterned twice. 
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With it, a number of options are available: 

Experiment 

Set Horizontal Field Width: 300 m 

Set Integration Width: 4 

 

If you modified the design, you can 
re-generate the lin scans with 
“Generate Lines” 

 
 
 
 

 

 Step 7: Use the alignment in other layers 

 
After defining an alignment, the alignment must be assigned to each layer that should 
use it. This extra step allows having different alignments for different layers, having 
layers without alignment, and sharing a single alignment in multiple layers.  

Experiment 

1. Select Layers 1–3 (Shift + click).  

2. Click in the box to the right of Alignment in the Properties area (where it says No 
alignment). 

3. Click on the dropdown arrow that appears and select Line scan alignment 1. 
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 Step 6: Add an alignment (only when fiducial patterning was successful) 

 
Using alignments achieves two things:  

 Align a layer to the sample: Accurately position the patterns in a layer relative 
to these marks by finding marks on the sample. Even if the position relative to 
the sample is not critical, it is useful to align layers with respect to each other.  

 Drift correction: Correct for drift while patterning by realigning at fixed intervals 
during patterning.  

 

Experiment: Add an alignment 

1. Select Alignments in the Overview.  

2. Add an alignment either by right-clicking the alignment selection or by selecting “Insert 
> Alignment”. In this example, choose Line scan alignment from the list. 

 
 
 
A new entry will appear in the overview list: 
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Intersection  
The intersection shape is the equivalent of the Boolean AND operation, only patterning 
the overlapping parts of the shapes. 

 
Exclusion  
The exclusion shape is the equivalent of the Boolean XOR operation, patterning 
everything except for the overlapping parts of the shapes. This is the inverse of the 
Intersection shape. 
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Difference  
The Difference shape is the equivalent of subtraction operation, removing the parts 
from the first shape that are overlapped by the other shapes. The difference shape can 
be used to invert part of a design: use a rectangle as the first shape to define the 
'exclusion zone' (which is milled away), in which the other shapes will not be patterned. 

 
 
Reference  
The Reference shape holds the concept of re-using an existing shape (the template) at 
different locations and optionally adjusting its size and/or rotation. In order to re-use 
another shape, that shape first has to be promoted to a template, which is 
accomplished by dragging the shape to the templates node in the tree view. The image 
below shows two instances of a reference shape; with and without a rotational offset. 
In this example the referenced shape is a structure. 
 
Shape‐Specific Properties  
- Template: The shape that is used as the template for this shape  
- Rotation: Angle to rotate the template with (default is 0)  
- Scale: Scale factor to increase or decrease the size of the template (default is 1) 
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However, you want to change the order of layers so they are patterned in decreasing 
beam current order.  

The layer order can be changed via drag and drop. Alternatively, use the right mouse 
button to click on a layer and use Move Up/Down/To Top/To Bottom to change the order 
layer. 

 Step 4: Pattern the fiducial 

 
Fiducial = a point or line assumed as a fixed basis for comparison, your standard or 
reference mark. 
In this GDSII file, the fiducial is defined in Layer 0. 

Experiment: pattern the fiducial 

1. With the electron beam, navigate to an unpatterned area of at least 300 µm width.  

2. Set the beam current to 1 nA (NanoBuilder).  

3. Toggle all other layers not-enabled 

4. Save the job. If AutoSave Job is enabled, this  
will happen automatically.  

5. Execute only Layer 0 (containing the fiducial):  
right-click “layer 0” in the tree view and select “Execute at current location”.  

6. Verify in the e-beam that the fiducial patterning was successful. 
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Select an object (e.g. Layer 1) and find the patterning options under “Process” 

 

Note: default settings can be changed in File > Preferences 

 Step 3: change the order of the layers 

 

Experiment: Change the layer order 

The layers will be patterned in the sequence in which they are shown 
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Array  
The Array shape allows you to repeat in existing shape in a regular grid. Optionally the 
repeated shape–which has to be a template–can be rotated and rescaled when it is 
repeated in the grid 
 
Shape‐Specific Properties  
- Template: The shape that should be repeated in the array (the referenced template)  
- Rotation: Angle to rotate the template with (default is 0)  
- Scale: Scale factor to increase or decrease the size of the template (default is 1)  
- Columns, rows: The number of columns and rows for repeating the template  
- Pitch X,Y: The spacing between the repeated shapes  
- Center X,Y: This is an alternative representation of the position of the array, using the 
center as the point of reference; this facilities aligning the center of the array to a 
specific position  
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- Always pattern parallel: If selected, the shapes within the array are patterned in a 
parallel fashion, even if the layer is set to serial patterning 
 
The following image is a shape array using a 3 x 4 grid and a rotational offset. In this 
example the repeated shape is a structure: 

 
 

 Special Shapes  

The special shapes are shapes that deviate from the general concept of shapes, for 
example in how they are rastered or how process parameters are applied. 

Bitmap Shape  
The bitmap shape is a pattern that uses an image from disk as the basis for patterning. 
The different gray scale values of the pixels are translated to specific dwell times at the 
corresponding pixel locations, such that after patterning an imprint of the image 
remains. The result of the Bitmap Shape is equivalent to patterning a bitmap in the xT 
UI. 
 
Shape‐Specific Properties  
- Bitmap: The image used for the shape; to change files, click the [...] button in the field. 
A bitmap shape is always patterned in a row-by-row serpentine, starting at top-left 
corner.  
- Physical height and width: The actual dimensions of the image when it is patterned  
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Experiment: Configure the layers 

There are 5 layers in the file  
- Layer 0 is the fiducial.  
- Layers 1, 2, and 3 contain the shapes to be patterned:  

- the thin cross in the center 
- the four squares around it (blue) 
- the four L-shape polygons around the four squares (red) 

- The Line Scan Alignment Layer is used to align the layers. 
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Tutorial: Creating and executing a job with alignment from file 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Load a file, specify the patterning, add alignments and execute the job 

Note: Nanobuilder does not adjust focus and stigmation! Therefore, all the beam 
currents being used must be in focus and stigmated. Small amounts (< 2 µm) of beam 

shift between the currents are allowed. 

 Step 1: Import a GDSII file 

 

Although you can create designs in NanoBuilder, this tutorial starts from a GDSII file, as 
this is a common use case. You create your design offline. 

Experiment: load a GDSII file 

- File > Import GDSII > go to:  c:\Program Files (x86)\Fei\NanoBuilder\ -
Documentation\Tutorials\Tutorial01 
- Open the file Tutorial01.gds 
Note: do NOT overwrite the file! Save is under another name. 

 Step 2: Configure the layers 
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- Pixel: The size of a pixel when patterned (pixel size = physical size/bitmap resolution). 
The maximum possible dwell time of a pixel–if it has value 255–is the dwell time as set 
for the layer. 

 
 
 
StreamFile Shape  
The StreamFile shape allows you to add an existing stream file (a native xT format for 
specifying pattern points) to be included in the design. The stream file has to be 
specified when the shape is added.  

- The dwell times of the points in the stream file are not determined by its layer, but 
merely by the times specified for each point in the stream file.  
- The number of passes is determined by the layer. When loading a stream file the 
number of passes for the layer is initially set to the value from the stream file, but you 
can edit this afterwards.  
- Because the number of points in a stream file can be considerable, not all points are 
drawn for performance reasons. They may lead to interference patterns in the display. 
Zooming in to scale of a pattern point will show all points within the view port. 
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Demonstration: Job editing 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

NanoBuilder allows creating designs through shapes. Note shapes are supported that are 
not available in GDS, such as circles, Boolean shapes, bitmaps, and stream files. 

Note: NanoBuilder currently cannot save in the GDSII format, and the format of its 
native .nbj files may change in the future. 

Therefore, for long-term design use, it is better to make a GDSII file and convert that 
to NanoBuilder 

 Creating a Job 

Start NanoBuilder. 
Go to File > New Job to create a new job. 
 

 Creating a Layer 

1. Go to Insert > Layer to add a layer. 
2. Change the HorizontalFieldWidth and Thickness properties to the appropriate value 
for the size of the job. 
 

 Creating a Circle 

1. Go to Insert > Basic Shapes > Circle1. 

 
1 New shapes are placed in the screen center and are sized to about 10% of the screen width. 
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 Scan direction 

NanoBuilder defines six different scan directions: 
- Serpentine bottom to top 
- Serpentine top to bottom 
- Serpentine left to right 
- Serpentine right to left 
- Circular inside to outside 
- Circular outside to inside 
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Changing array properties 
1. Select Array 0 in the Shapes list in the Overview pane. 
2. Change the Magnification to 0.2, and set the column pitch to 5 µm 

 
Reference Shape Influences Design 
To see how changing the reference shape 
influences the design: 
1. Select the circle template. 
2. Change the inner radius to 2 µm (from 10 µm 
before). 
As shown below, both references have changed. 
When you change a template, all references to that 
template will  change. Also note that the original 
circle displays when it is selected in the Overview 
pane. 
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2. Click on the circle that appears to select it. Resize the circle using the drag handles or 
enter the exact radius numerically. 
3. Change the inner radius to e.g. 10 µm and the outer radius to 12 µm. 

 
 
4. Select the scan direction for patterning. (See also “Scan Direction” below) 
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 Creating a Reference 

1. Create a circle. 
2. Drag the circle from Shapes to Templates (in the tree view). 
3. Go to Insert > Composite Shapes > Shape Reference.  

 
This allows you to select a template shape (for reference), the rotation and scale, and 
the position (offset with respect to the template’s position). 
4. Under Template, select the circle pattern you just created. 
5. Change the scale to 3. 
6. Click OK. Your job now looks something like above.  
 

 Creating an Array 

An array is similar to a reference, but it allows you to make multiple copies at 
once. (Assuming the circle has been moved to the Templates section as described 
above) 
1. go to Insert > Reference > Array. The Define Array dialog box displays.  
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2. Select the circle 
pattern you created as 
the template. 
3. Change the scale to 
0.5 to reduce the size 
of the ring. 
4. Change the number 
of columns and rows 
to 3  
5. Change the width to 
30 µm and the height 
to 3 µm. 
6. Click OK. The result 
should be similar to 
that shown below. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 


