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Universal rules 

Rule 1: don't touch a control if you are not sure of the 
outcome of that action 

Rule 2: never, ever force anything beyond finger strength 

Rule 3: wear gloves when touching anything that goes into 
the chamber 

Rule 4: if in doubt, ask for help 
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Text size does not change 
when using Insert Pattern 
> Text > Change Font/Size. 

 
 

The Strikeout and 
Underline properties in 
the Text Font dialog do 
not work. 

Do not use. 

 
 SEM and scanning issues 

Issue Workaround 
Mode II Snapshot causes 
job to fail 

Do not perform this action. 

SEM blur does not work. If 
you specify a value for the 
blur and the SEM as the 
beam, the blur (defocus) is 
not applied during 
patterning. 

None. This does not work 

The immersion lens is not 
available after closing 
NanoBuilder. 

Closing the NanoBuilder application may switch off the 
UHR lens. When this happens, restart xT to reactivate 
the UHR lens and make sure to leave the password field 
empty in the Preferences dialog. 
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Line scan alignment fails 
with insufficient signal 
error 

Use the build-in diagnostics of the line scan alignment 
(see “Line Scan Alignment”), try to identify the root 
cause of the failure.  

- If the transitions are not visible at all in the scan 
profiles, the scan field may be outside of the alignment’s 
capture range. Either increase the length of the scan 
lines to increase the capture range, or realign the beam 
apertures.  

- If the scan profiles contain noise that obscures the 
transitions, increase the dwell time and the 
IntegrationWidth parameter.  

- If the transitions are too broad, calibrate focus and 
stigmation for the beam aperture that is being used. 

 
 Text issues 

Issue Workaround 
Text shapes do not display 
after creation. 

Change the zoom level of the shape display to force the 
newly created Text shape to be drawn. 

Text position does not 
refresh after changing 
coordinates. 

Zoom in/out to refresh the changes 

The font size of a Text 
pattern cannot be set 
from the Font dialog. 

Expand the Font property and set the size of the font 
directly. 

ThermoFischer SCIOS 2 Introduction – Page 5 
 

D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland 

Demonstration: Line scan alignment ................................................................................. 6 

Tutorial: Correlation alignment ....................................................................................... 12 

Demonstration: Patterning with a certain dose .............................................................. 18 

Demonstration: Parallel and sequential patterning ........................................................ 20 

Demonstration: Creating stream files.............................................................................. 22 

Demonstration: Setting default processes ...................................................................... 26 

Demonstration: Troubleshooting .................................................................................... 29 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



ThermoFischer SCIOS 2 Introduction – Page 6 
 

D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland 

 
 
 

Demonstration: Line scan alignment 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Nanobuilder provides two types of alignments: Line Scan Alignment & Correlation 
Alignment 

The line scan alignment works by scanning several line segments with the beam 
and measuring the detector signal along each line. Assuming the lines intersect 
with known features on the sample, transitions (jumps in the signal) will occur at 
these intersections. By comparing the actual transition locations with the expected 
locations, or the measured line profile with a reference profile, you can find the 
shift for each line. A fit to all the lines gives the shift, rotation, scale, and shear 
parameters that best match the measured shifts.  
 

 Creating a Line Scan Alignment 

1. Create a GDSII file with shapes on the Line Scan Alignment Layer that 
indicate where the lines are to be scanned and shapes on any other layer that 
indicate the features that the lines will scan over (the fiducial marks). 

Make sure that LineScanAlignmentLayer is set to 61 in the Preferences dialog box. 

2. Load this file into NanoBuilder. 
3. Use Insert > Alignment > Line Scan Alignment (or right-click on Alignments in the 
Overview tree) to create a new line scan alignment. 
4. The new alignment will automatically import the shapes on the Line Scan Alignment 
Layer as the lines to scan, checking for intersections with shapes on other layers. 
5. Optionally, train the alignment if you need best layer-to-layer accuracy (at 
the cost of absolute accuracy to the fiducial marks). 
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value of 
ElectronBeamSourceTilt...” 

At the start of job execution NanoBuilder prepares Quad 
3 for patterning and Quad 4 for alignments. As part of 
this preparation, NanoBuilder grabs an image frame 
with the beam blanked so that sensitive areas on the 
sample are not unintentionally exposed to the E-Beam. 
The workaround for this issue is to turn off blanking and 
consequently expose the entire write field to the E-Beam 
for a short period.  
Instructions:  
1. Start Windows Explorer and set the folder path to 
C:\Program Files\FEI\NanoBuilder.  
2. Create a backup copy of NanoBuilder.exe.config.  
3. Open NanoBuilder.exe.config in Notepad.  
4. Find line: 
 <add key="UseSourceTiltForBlankingEBeam"  
value="true"/>.  
5. Set the value property to “false”:  
<add key="UseSourceTiltForBlankingEBeam"  

value="false"/>. 
6. Save the file.  
7. If NanoBuilder does not start up after the modification 
to NanoBuilder.exe.config file, restore the original file 
and start over.   

 Line scan alignments 

Issue Workaround 
Linescan alignment for 
layer fails with the error 
message: “Cannot access 
data pipeline for RTM.” 

Save your NanoBuilder job and close the application. 
Restart the xT UI and the xT server, then start the 
NanoBuilder application again and load the job to 
continue. 

Line scan alignment 
limitation 

A standard detector mode must be used during line scan 
alignment. 

Alignment fails because 
the real-time monitor 
cannot be accessed. 

Restart the xT server 
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aperture is delivering more current than its 
nominal value, the current applied to the sample 
will be off by a factor. Apertures allow more 
current through as they age (wear out), and this 
will lead to deeper mills or thicker than expected 
depositions.  

• Beam chemistry depends on the precursor 
flux. If the needle alignment is off, or if the 
precursor has aged, the actual process speed 
will differ from the expected value.  

Perform a test exposure of critical layers, and if the 
actual mill depth or deposition height is different from 
what is expected, adjust the layer’s thickness 
correspondingly. For example, if the requested thickness 
is 1 µm but the actual depth is 1.2 µm, change the layer 
thickness to 1/1.2 = 0.833 µm. 

NanoBuilder does not 
support the xT wide 
screen display. 

NanoBuilder sets the display area automatically to fit 
with the server XT display screen ratio. For example: 
when setting HFW in NanoBuilder to 150 µm, the height 
is automatically set to 100 µm for the patterning area 

Restarting the xT server 
while NanoBuilder runs, 
will cause a crash 
(selecting the Microscope 
menu). 

Shut down NanoBuilder before you start xT. 

The graphical display 
updates slowly when a job 
containing many shapes is 
loaded. 

Reduce the number of shapes in the design to only those 
that need to be patterned with NanoBuilder. 

Using dwell times shorter 
than 25 ns will fail with a 
general error message 

Use larger dwell times 

E-Beam patterning fails 
with the message: 
“Cannot set the target 

First, inform the instrument admin 
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 Line scan alignment properties 

The following table 
provides detailed 
information on each of 
the properties of a line 
scan alignment. 
 
 
 
 
 
 
 

Property Description 
DwellTime This is the pixel dwell time for scanning the lines. A larger value 

will give better signal to noise, but also cause more damage 
per scan. It will also increase the total time to scan the 
alignment lines, but this is generally not a limiting factor. 

Elasticity If a line has more than a single transition, the real spacing 
between the transitions might be different from the expected 
spacing, causing the match to fail. This number influences how 
much the actual spacing may differ from the expected spacing 
by broadening each transition with a Gaussian. For example, 
for a line segment of 5 µm length, a value of 1% of the 
Gaussian has a sigma of 0.05 µm, meaning that each edge can 
be off by that amount relative to the other edges. 

EqualizeDose Keeps the dose constant at varying beam currents. 
HorizontalFieldWidth This is the horizontal field width (HFW ~ 1/magnification) at 

which to scan the lines. Use the same HFW in the alignment 
and in the layers that use the alignment to avoid small errors 
that might be caused by changing the HFW. This value must at 
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least be so large that an image acquired at this HFW will 
contain all the lines that are to be scanned. 

IntegrationWidth By setting a number larger than 1, you can automatically scan 
multiple parallel lines. This will increase accuracy and 
reliability. 

MinScore Each line scan line receives a score from 0 to 1 indicating the 
confidence in the correctness of the measurement. The 
alignment accepts only lines with a score greater or equal to 
the value specified by the MinScore parameter. Use the 
MinScore parameter to control the probability of a false 
measurement. 

Name The name of the particular line scan alignment. 
Optimization Determines the impact of redundant scan lines with a failed 

measurement on the alignment. There are two selections: 
• HighestAccuracy requires that all scan lines successfully 
measure the location of the underlying fiducials. Use this 
setting when the patterning process demands consistent 
alignment with the highest achievable accuracy. 
• BestRobustness tolerates measurement failures of 
redundant scan lines. The number of redundant scan lines is 
the total number of lines minus the number of parameters 
calculated by the alignment, which depends on the 
AlignmentStrategy field for the layer. 
The AlignmentStrategy field for the layer has two selections: 
— CorrectShiftWithMicroscope calculates two scalar 
parameters, namely shift in X and Y, 
— CorrectWithShapes computes scale in X, scale in Y, shear 
and rotation, in addition to shift in X and Y, resulting in a total 
of six scalar parameters. 
For example, a job uses the line scan alignment module 
located in the documentation folder to define an alignment. 
The alignment module defines four pairs, with each pair 
consisting of one horizontal and one vertical line. When using 
CorrectShiftWithMicroscope, the line scan alignment will 
tolerate the measurement failure of up to three horizontal 
and three vertical lines. On the other hand, the 
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Demonstration: Troubleshooting 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Known bugs or peculiar behavior and how to rectify it 

 General xT issues 

Issue Workaround 
Actual milled thickness 
does not match the 
specified value in 
NanoBuilder  

There are two main causes for this variation:  

• NanoBuilder does not read the actual current 
before calculating patterning times. Thus, if the 
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Processes dialog box. 

The Available processes  
are shown on the left.  

- Import from Server: This link is enabled if NanoBuilder is connected to a microscope. 
Selecting it will import all the patterning applications from xT to equivalent processes (as 
far as possible, as the applications do not specify a beam or its settings).  

- Import from Current Project: This link will import the processes from the layers in the 
currently open project in NanoBuilder (also see Editing a process below).  

- Remove Selection from List: This link will remove the items you have selected in the list. 
This is useful when importing more items than you need;  

4. Click OK to store the new list, which you can use in any project.  

 

 

 Editing a Process  

Modifying a layer's process influence only that specific layer. To make changes 
available to other layers, change the name of the process (give it a unique name), then 
select the Import from Current Project as described above. 
 

f you change a process called “ABC”, its name will change to “Modified ABC” to 
indicate it no longer corresponds to the original ABC. By typing in a new name, the 

“Modified” is removed, as it is now a different process. 
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CorrectWithShapes selection will only tolerate the failure of 
one horizontal and one vertical line because of the higher 
number of alignment parameters calculated in this case. 

SearchWindow Reduces the search range to a fraction of the profile data 
acquired over the entire scan line. The search range is 
centered to form equal margins from either end of the scan 
line. Decrease this parameter to suppress the detection of 
scan artifact peaks near the extremes of the scan line. 

Sensitivity The Transition method matches inflection points in the scan 
profile to line transitions. The Sensitivity parameter filters the 
inflection points according to the strength of the slope at 
which they occur. A small value will suppress inflection points 
with soft slopes and, consequently, will lead to fewer detected 
inflection points to be matched to transitions. 

SmoothSigma  Sets the width of the Gaussian used to smooth the detector 
signal. It is in units of points on the line that was scanned 
(similar to pixels). 

UseAutoGainOffset When set to True, the detector contrast and brightness will 
automatically be adjusted if the signal is too dark or bright. 
When set to False, you must manually adjust the detector 
signal while patterning with the real time monitor enabled. 

 
 Line properties 

The line scan alignment has a list of lines that are to be scanned when the layer is 
executed. At least two lines (nonparallel, ideally perpendicular) are required for 
measuring and performing a translation (shift) in X and Y. At least six lines (not 
all parallel) are needed to measure translation, rotation, scaling and shear. 
 

Property Description 
StartPoint The starting point of the line. Expand to edit the x- and y 

value. 
EndPoint The end point of the line.  
Length Read only, the distance between the start and end points. 
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SearchMethod • Transition: This method searches for inflection points in the 
profile and matches them to the line transitions. This is 
typically used when the intersection information comes from 
a GDSII CAD file and no knowledge is available on the actual 
detector signal profile. This works best if there are multiple 
transitions; the algorithm can then search for a sequence of 
jumps at the correct intervals. The more transitions, the less 
likely other features (like a piece of dirt) will match, 
decreasing the chance of a false match. 
• ScanProfile: Compare trained line profiles with the 
measured line profiles. This defines the scan field location 
where the training was done as the 'perfect' location, which 
the alignment will try to reproduce. 
 
If you want to position patterns with absolute accuracy 
relative toexisting features, use Transition. For the best layer-
to-layer alignment, use ScanProfile. 

TrainedBeam The beam that was used for training. 
TrainedDetector The detector that was used for training. 
TrainedHFW The horizontal field width at which training was done. 

 
 Use Single Lines with IntegrationWidth Parameter 

Line scan lines can be widened to a larger scan area by using the IntegrationWidth 
parameter. All pixels perpendicular to the line direction are averaged to reduce noise 
and lessen the impact of fiducial line roughness. Values of 4–8 typically achieve good 
results for beam currents ranging from 50 pA–1 nA. In general, use larger values for 
smaller beam current. 

 Choose Search Method for Line Scan Alignment 

The line scan alignment can search for the fiducial location in two different ways: 
- The Transitions method matches inflection points in the line profile with 
material or topography transitions described by the fiducial layer in the GDSII 
file. Depending on the nature of the fiducial and the particular imaging 
conditions, the location of the detected inflection points may differ slightly 
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- Set all the parameters at once, without 
having to know any of the details, by 
selecting a predefined process from a list.  
- Easily fine-tune any of the parameters by 
expanding the Process. 
 

 
 
 
 

 Changing Available Processes  

Experiment 

1. Open the Preferences dialog box by selecting File > Preferences.  

2. Select the field to the  
right of ProcessTemplates  
(see “0 processes”, ->) 
to display the Browse  
button 

3. Click the Browse button  
(…)to display the Available  
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Select Microscope > Execute and begin patterning. 

The job will now be executed. The status bar at the bottom of NanoBuilder displays the 
overall progress (0…100%), as well as a progress bar for the current activity. 

 
 
 
 
 
 
 
 

Demonstration: Setting default processes 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

A process in NanoBuilder contains all the settings to pattern a layer 

A process contains:  
- the beam settings 
- the patterning parameters 
- the GIS parameters.  

Aim:  
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from their respective calculated transitions. The Transitions method calculates 
the total shift from the average of the transition deviations to achieve “center 
of mass” alignment. 
- The ScanProfile method, on the other hand, uses a sample scan profile 
recorded during the training step of the line scan alignment to find the 
fiducial. 
 
Use the Transitions method when absolute pattern placement is critical and the 
edges of the fiducial display as bright narrow lines in the image. Typically, this is 
the case for features produced by a lithography process applied to a silicon 
substrate. The ScanProfile method is recommended when robust and precise 
alignment of the layers to each other is more important than absolute placement 
of the entire structure. 
 

 Line Scan Alignment Capture Range and Line Placement 

The capture range of the line scan alignment is determined by the length of the 
fiducial line. Individual fiducial lines milled by NanoBuilder should be spaced 
from each other by at least their length to avoid the sample-staining or mill 
artifact of one scan line to alter the acquired profile of a neighboring scan line. For 
fiducial crosses, place the scan line 3/4 from the center and set its length to 1/2 of the 
length of the cross arm. This will ensure a maximum capture range without scan line 
interference. 
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Tutorial: Correlation alignment 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Nanobuilder provides two types of alignments: Line Scan Alignment & Correlation 
Alignment 

The correlation alignment is based on cross correlation techniques, using a predefined 
template image that is searched in an image that is acquired on the microscope during 
the alignment task. Correlation alignment is most useful when: 
- Aligning to sites with prefabricated alignment fiducials. The following tutorial 
demonstrates how multiple crosses on the mapping wafer test substrate can be 
modified consistently with one NanoBuilder job. 
- You expect a relatively large shift. The line scan alignment typically has limited range, 
while the correlation alignment can handle much larger shifts.  
- When the amount of noise in the acquired line scans is too significant for a stable line 
scan alignment. Cross correlation is generally less sensitive to noise. 
 
Before beginning, prepare the microscope for patterning. Drive to a location on 
the mapping wafer sample, bring it to eucentric height, optimize the SEM and FIB 
images, and then align the ion beam with the E-beam using beam shift. 
 

Experiment 

1. Start NanoBuilder and go to File > Import GDSII... > C:\Program Files 
(x86)\FEI\NanoBuilder\Documentation\Tutorials\Tutorial03 and select the file 
Tutorial03.gds 

2. Right-click on Alignments in the Overview window and select Correlation alignment 
from Add alignment. 
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2. Select Layer to create a new layer.  

3. Select Insert > Special Shapes >  
Stream File.  

4. In the Open dialog that appears, navigate to the folder that contains the result of 
Step 16, above. Select the three .txt files and click Open. 

5. After loading the stream files, you should see three new layers. 

 
 
 
 

 
 

 Executing the Job  

Experiment 
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11. Select the CenterX box in the Field 1 row that was just added to the Fields of View 
box and change the value to 0. Do the same for CenterY.  

12. Repeat Steps 11 and 12 for Layers 1 and 2.  

13. Navigate to File > Save > ASCII Stream File and open the Browse for Folder dialog 
box.  

14. Select the folder that contains the tutorial02.gds file (or create a new folder) and 
click OK. This will create two files in the selected folder.  

15. Select Layer 2 and repeat the above step, using the same folder. 

16. Repeat for Layer 3.  

The folder should now contain 6 files:  
- Layer 1 - Field 1 [288µm 93pA].str  
- Layer 1 - Field 1 [288µm 93pA].txt  
- Layer 2 - Field 1 [288µm 920pA].str  
- Layer 2 - Field 1 [288µm 920pA].txt  
- Layer 3 - Field 1 [288µm 2.8nA].str  
- Layer 3 - Field 1 [288µm 2.8nA].txt 

 Load GDStoDB Output into NanoBuilder  

To add a stream file to a job, you must first have a layer to which to add it.  

- If you load a GdsToDb.txt output file, NanoBuilder will create a layer based on the 
settings in the file and will load the stream file into that layer.  
- If you load the .str file, it will end up in the active layer. You will need to set the layer 
parameters manually.  
 

Experiment 

1. Start NanoBuilder.  
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3. In the Properties window, set HFW to 150 µm. 

4. In the Template pane, click Reference  
Image to enable a Browse button at the  
right of that property. 

5. Click the Browse button to display the  
Change Image dialog box. 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. Expand the Acquisition Parameters and Beam Parameters properties and set: 
- Resolution: 1024x884 
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- Current: 100 pA 
- HFW: 150 µm 
 

 

 

 

 

 

 

If the correlation alignment is not good, increase the dwell time for better signal-to-
noise. 

7. Click Acquire. 

8. Click OK to close the dialog box. 

9. In the Template pane, set the following parameters: 
- X: –13% 
- Y: 26% 
- Width: 12% 
- Height: 12% 

10. Set the ReferenceImageOffset to precisely align the template to the fiducial displayed 
in Layer 0. The display of the fiducial pattern in Layer 0 helps align the image template, 
as shown in below. 

Once you have developed a robust alignment job, you can reuse it: save the 
alignment job. When needed, use the Merge Job selection on the File menu. After 
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navigate to tutorial02.gds and  
click Open.  

4. Select Layer 1 by clicking on the  
corresponding tab. 

5. In the Layers Parameters dialog box 
that displays, make the following  
selections:  

- Material: Si  
- Dwell time: 1 µs  
- Overlap: 50%  
- Beam current: 93 pA  
- Scan mode: Serpentine  
- Depth: 0.1 µm  

6. Click the down arrow next to the Apply button to display the Apply To All Layers 
button and click the button.  

7. Select Layer 2 and change the beam current to 920 pA (for this layer only).  

8. Select Layer 3 and change the beam current to 2.8 nA (for this layer only).  

9. In the Fields of View dialog box, select 288 µm for Field width 

 

10. Go to Add field and click in the center of the structure to create a field.  
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Demonstration: Creating stream files 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 
GDStoDB installed 

Create stream files with GDStoDB and import them into NanoBuilder. 

 

 Create a stream file set 

Experiment 

1. Start GDStoDB.  

2. In the System menu, select the  
tool type you will use (e.g., Helios  
NanoLab™).  

3. Go to File > Open GDSII and  
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you have merged the alignment job, move the fiducial layer and the burn-in layer, if 
present, to the start of the patterning list. 
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11. Right-click on Layer 0 to disable it so that the fiducial will not be patterned. 

  

12. Right-click on the Site List and select Add stage site array. 

13. Click OK on the Create array of sites dialog box that displays. 

 

 

 

 

 

 

 

 

ThermoFischer SCIOS 2 Introduction – Page 21 
 

D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland 

 Always Pattern Parallel  

Arrays  
By default the individual elements of an Array will be patterned one-by-one in 
Sequential mode. However, this can result in a very high number of start/stop 
patterning cycles, which is slower due to the cumulative overhead (especially for 
nested structures like Arrays of Arrays).  

If the total number of points for the Array is less than the maximum number of points it 
is more efficient to select the Always Pattern Parallel option of the array. This will 
pattern all the points for the array in one go, treating it as a monolithic shape. 

 

Structures  
Structure = a collection of shapes (which can even be on different layers). 

When a layer is executed in Sequential mode, all the shapes in the structure that are on 
the executing layer will be patterned one by one. As with the Arrays, the overhead of 
start/stopping patterning can be reduced by selecting the Always Pattern Parallel 
option for the Structure, in which case all the shapes in the structure which are on the 
executing Layer will be patterned in one go, treating the structure as a single shape. 
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Demonstration: Parallel and sequential patterning 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

The concept of Parallel and Sequential patterning in NanoBuilder  

There are some subtle differences between Parallel and Sequential patterning in 
NanoBuilder and xT. Conceptually the meaning is as follows:  
- Parallel: All shapes in a layer receive a single pass of the beam, then they all receive 
the next pass, etc., until the required number of passes has been reached.  
- Sequential: The first shape receives the number of passes specified for its layer, then 
the next shape, etc., until all shapes on the layer have been patterned.  

 Sequential Patterning Displays as Parallel in the xT UI  

Even if you set a NanoBuilder Layer to pattern Sequentially, the Patterning page in the 
xT UI will still show Parallel. The reason is that NanoBuilder patterns the shapes one by 
one, starting/stopping patterning for each shape. This allows it to use the maximum 
number of points (currently 8 million) per shape, rather than all shapes having to fit in 
this limitation together.  

ThermoFischer SCIOS 2 Introduction – Page 17 
 

D Vanhecke | Adolphe Merkle Institute | University of Fribourg | Switzerland 

 

14. Select Layer 1 in the Overview window and make the following property changes:  
- HFW: 100 µm (to pattern with the same HFW that is used for the alignment)  
- Thickness: 20 nm (to shorten patterning time)  
- Alignment: Correlation alignment 1 

 

15. Save the job (Go to File > Save) 

16. Execute the NanoBuilder job to modify the fiducials at four sites 
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Demonstration: Patterning with a certain dose 

 Prerequisites: 
Sample loaded, stage pumped 
E-beam and ion beam active 

Patterning with a certain dose is useful when exposing a resist layer. 

 Dose and Fluence  

Fluence:  the number of particles per area, expressed in C/m² (typically in 
nC/µm² or pC/µm²) 

Dose:  the total number of particles that hit the sample, expressed in Coulomb 
(typically in the pC or nC range).  

(The term dose is often loosely used, sometimes even in the meaning of fluence) 
 
The relation between dose and fluence is that the dose is the fluence times the 
exposed surface area. For a specific layer in NanoBuilder, the dose is its fluence 
multiplied by the combined surface area from all the patterns on that layer. 

 
 Set Thickness, Fluence, Passes, and Time 
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Specify the exposure for a layer by 
setting either Thickness, Fluence, 
Passes, or Time in the Layer Properties 
section. NanoBuilder will automatically 
calculate the other quantities and 
display their values in parentheses to 
indicate that they were calculated 
rather than specified. 
 
 
 
 
 
The following formulas are used: 

 

𝐹𝑙𝑢𝑒𝑛𝑐𝑒= 
𝑇ℎ𝑖𝑐𝑘𝑛𝑒𝑠𝑠

𝑉𝑜𝑙𝑢𝑚𝑒𝑃𝑒𝑟𝐷𝑜𝑠𝑒
 

𝐹𝑙𝑢𝑒𝑛𝑐𝑒𝑃𝑒𝑟𝑃𝑎𝑠𝑠= 𝐶𝑢𝑟𝑟𝑒𝑛𝑡 ∙ 𝑃𝑖𝑡𝑐ℎ
ଶ

∙𝐷𝑤𝑒𝑙𝑙𝑇𝑖𝑚𝑒 

𝑃𝑎𝑠𝑠𝑒𝑠= 𝐼𝑁𝑇൤
𝐹𝑙𝑢𝑒𝑛𝑐𝑒

𝐹𝑙𝑢𝑒𝑛𝑐𝑒𝑃𝑒𝑟𝑃𝑎𝑠𝑠
൨ 

𝑇𝑖𝑚𝑒=𝑃𝑎𝑠𝑠𝑒𝑠∙𝑇𝑖𝑚𝑒𝑃𝑒𝑟𝑃𝑎𝑠𝑠  

Calculated exposure values may be inaccurate as a consequence of the rounding to an 
integer in the calculation for the Passes property. Moreover, the Passes property 
cannot be smaller than 1. To reduce the dose with a Passes value of 1, you can select a 
smaller beam current or dwell time. 

 Selecting Apertures  

When a current is selected that is available by more than one aperture, the one closest 
to the lowest index (lowest beam current) is used. 


