
Introduction to ImageJ
Session 2: Advanced image processing

Dimitri Vanhecke

March 2024



Preamble



Preamble

(My) rule of thumb
- Always perform an algorithm on all pixels
- Be conservative in using filters/alogrithms/...

https://ori.hhs.gov/education/products/RIandImages/guidelines/list.htmlhttps://akademien-schweiz.ch/en/themen/scientific-
culture/scientific-integrity-1/



Overview

Part I: Transformations
Part II: Point operations
Part III: reciprocal space
Part IV: Filters
Part V: Machine learning



Part III Image transformations

✓ Flip, rotate, translate 
✓ Rename, duplicate
✓ Crop, bin, scale

Part I: Transformations



Transformations

These transformations could 
be equally well made at the 
microscope

No problem

Aliasing

Rule (of thumb)
You must perform every function on every 
pixel in the image, not just on some 
selected pixels

Transformations

Flip

Rotate

Translate

Scale/bin

Crop

Image > transform

Can be a problem



Binning / scaling

Binning Scaling

Location On the camera chip In silico/postprocess

Algorithm Integration or summation Summation, averaging, …

Factor 2 (1,2,4,8,16, …) Free

Interpolation no Yes



Scaling (interpolation)

Nearest Neighbour
= unweighted
Take the value of the 
closest voxel

1D NN: closest of two points

2D NN: closest pixel of 
four corners of a square

Linear 
= Center of mass
Take the linear average of the two 
pixels the ray is intersecting

1D Linear: Center of mass  of two points

Bilinear: Center of mass of square corners
Trilinear: Center of mass of cube lattice points

Cubic
Center of mass
= Lagrange polynomials, cubic splines or 
cubic convolution

1D Cubic: Center of mass  of 3th degree 
polynomial

Bicubic: Center of mass of 16 pixels
Tricubic: Center of mass of 64 pixels



Aliasing effects

Continuous signal 
(nature)

Discrete signal 
(image)

Transformations



Aliasing: Example of spatial aliasing

Original (nature) Camera / Detection grid 
(= reconstruction filter)
(= “pixels” on the camera)
(= photosensitive element grid)
(= point-sampling grid)

Image

Solution: low pass 
filtering

See: Shannon-Nyquist theorem: 2x sampling otherwise one gets weird artefacts due to 
undersampling. However, continuous signals of nature will ALWAYS be undersampled. 

Transformations



Transformations: Cropping

‘CryoTEM’ on Au nanorods chopsticks

Attempts to rescue the worst
Photoshop job in history with 
point operators and filter only



Transformations: Cropping

This said...

- Cropping an image for a publication figure is usually considered acceptable.
- Consider your motivation for cropping the image.

• Is the image being cropped to improve its “composition”
• or to hide something that disagrees with the hypothesis?

- Legitimate reasons for cropping include:
• Centering an area of interest
• Trimming “empty” space around the edges of an image
• Removing a piece of debris from the edge of the image

- Questionable forms of cropping: removing information in a way that changes the context.  Examples:
• Cropping out dead or dying cells, leaving only a healthy looking cell
• Cropping out gel bands that might disagree with the hypothesis

Don't crop too much
Remember the 300 DPI 
requirement: you need pixels.

Do not let image manipulation 
ruin good science



Part II: Point operations



for a(u,v) 

 a'(u,v) = f(a(u,v)) 

next

For each pixel in the image

Take pixel intensity and perform a function

Go to the next pixel

The new (processed image) contains pixel intensities in a’

Basic concept:

Point operations

U= image width, 
V= image height, 
u = a given position along the horizontal axis
v= a given position along the vertical axis
a(u,v) = the grayscale value in position u, v

U= 23
V= 20
u = 8
v= 6
a(u,v) = = 30 



Point operations: Addition, subtract, multiply and divide

for a(u,v) 

 a'(u,v) = f(a(u,v)) 

next

Add
a'(u,v) = a(u,v) + B

Adds a constant (B) to each pixel value (value increases)

Subtract
a'(u,v) = a(u,v) - B

Subtracts a constant  (B) from each pixel value (i.e. Mean brightness decreases)

Multiply
a'(u,v) = C x a(u,v)

Multiplies each pixel value with a constant (C) 

Divide  
a'(u,v) = 1/C x a(u,v)

Divides each pixel value with a constant (C) 

For each pixel in the image

Take pixel intensity and perform a function

Go to the next pixel

The new (processed image) contains pixel intensities in a’

Basic concept: This is called the
«mapping function»

B=-50
255 255 255
255 255 130
130 130 130

205 205 205
205 205 80
80 80 80



EXERCISE 1
Open Example 1 – GrayScale LUT and probe the effect of mathematical point functions add, subtract, 
multiply and divide on the histogram (CTRL + h or analyze > histogram)

Process > Math > Add
Process > Math > Subtract
Process > Math > Multiply
Process > Math > Divide

Add 50

Multiply by 1.5

Open the Brightness/Contrast tool (auto)

Point operations: Addition, subtract, multiply and divide



Point operations: Non-linear pixel value stretching

Normalized

LOG

𝑎′ 𝑢, 𝑣 = ln 𝑎 𝑢 ,𝑣 ∙
𝑀𝑎𝑥 − 𝑀𝑖𝑛

ln 𝑀𝑎𝑥 − 𝑀𝑖𝑛

Log stretched

SQUARE ROOT

𝑎′ 𝑢, 𝑣 = 𝑎(𝑢, 𝑣)

Square rootEqualized



Point operations

EXERCISE 2
Open Example 2 (diffraction) and probe the effect of mathematical point functions (LOG, EXP,…)

• Open the TIF image (Example 2 – Diffraction.tif)
• Adjust the brightness / contrast: Image > Adjust > Brightness / contrast (click

'Auto')

Try:
• Process > Math > log
• Process > Math > exp

Check the histograms of the processed images.

CTRL+SHIFT+d to duplicate the raw data to a new image
Be ready with the transfer function window (contrast/brightness) to adjust



Point operations: Summary

Point operations to a defined mapping function:

Point operator processing is a simple method of image processing. This technique 
determines a pixel value in the processed image dependent only on the value of 
the corresponding pixel in the input image. 



Part III: Fourier transforms



Reciprocal space

Ancient Greeks (BC)
The sun, moon, the planets move around the Earth in 
circles. 

Ptolemy (100 AD)
Wrong: if you watch the planets carefully, sometimes they 
move backwards.
Therefore: The planets still move around Earth, but 
describe little spring-like trajectories at the same time. 

Galilei (1600 AD)
Wrong: The sun is the center
(Wrong again… the church is against it)

Fourier (1800 AD)
You can reconstruct any signal alias by summing a large 
number of smaller «epicycles»



https://betterexplained.com/articles/an-interactive-guide-to-the-fourier-transform/

The Fourier Transform

መ𝑓 𝜉 =  න
−∞

∞

𝑓 𝑥 𝑒−2𝜋𝑖𝑥𝜉𝑑𝑥, ∀ 𝜉 𝜖 ℝ

𝑓(𝑥) =  න
−∞

∞
መ𝑓 𝜉 𝑒2𝜋𝑖𝑥𝜉𝑑𝜉, ∀ 𝑥 𝜖 ℝ

𝑒 𝑖𝑥 = cos 𝑥 + 𝑖 ∙ sin(𝑥)



Fourier transform: reciprocal space
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The Fourier Transform
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𝑓(𝑥) =  න
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∞
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Real space

Fourier Space
(or reciprocal space)

Fourier transform: 
when your index is 
continuous. (Nature)

Fourier series:
when your index 
is discrete.

Discrete Fourier series:
For infinitely long but 
periodic signals

Discrete Fourier 
Transform:
For general, finite length

Fast Fourier Transform:
like DFT but with square 
images with w,h = 
2n (faster, more efficient)

Higher 
frequencies

Lower 
frequencies



The Fourier Transform – expanded to 2D

መ𝑓 𝜉, 𝜚 =  න
−∞

∞

න
−∞

∞

𝑓 𝑥, 𝑦 𝑒−2𝜋𝑖(𝜉𝑥+ 𝜚𝑦)𝑑𝑥 𝑑𝑦 , ∀ 𝜉 𝜖 ℝ, ∀ 𝜚 𝜖 ℝ

𝑓(𝑥, 𝑦) = න
−∞

∞

න
−∞

∞
መ𝑓 𝜉, 𝜚 𝑒2𝜋𝑖(𝜉𝑥+𝜚𝑦)𝑑𝜉 𝑑𝜚, ∀ 𝑥 𝜖 ℝ, ∀ 𝑦 𝜖 ℝ



Fourier transform: reciprocal space
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And 1 central 
constant

Inverse Fourier transform:

For any real number 𝑥

𝑓(𝑥, 𝑦) = න
−∞

∞

න
−∞

∞
መ𝑓 𝜉, 𝜚 𝑒2𝜋𝑖(𝜉𝑥+𝜚𝑦)𝑑𝜉 𝑑𝜚, ∀ 𝑥 𝜖 ℝ, ∀ 𝑦 𝜖 ℝ

Easy: Intensity 
varies according 
to a sinoidal 
function



Fourier transform: reciprocal space (power spectrum)
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Fourier transform: Note on Frequency & phase

Real image Fourier transform𝑓(𝑥, 𝑦) 𝜉(𝑢, 𝑣)

መ𝑓 𝜉 =  න
−∞

∞

𝑓 𝑥 𝑒−2𝜋𝑖𝑥𝜉𝑑𝑥, ∀ 𝜉 𝜖 ℝ

𝑒−2𝜋𝑖𝑥𝜉 = cos 2𝜋𝜉𝑥 − 𝑖 𝑠𝑖𝑛(2𝜋𝜉𝑥)

መ𝑓(𝜉) = 𝑅( 𝜉) + 𝑖 𝐼(𝜉)
Real imaginary



Real imaginary

Fourier transform: Note on Frequency & phase

Real image Fourier transform𝑓(𝑥, 𝑦)

"where" the frequency component 
starts

Magnitude = 𝑀 𝜉 = 𝑅(𝜉)2 + 𝐼 (𝜉)2

𝜉(𝑢, 𝑣)

መ𝑓 𝜉 =  න
−∞

∞

𝑓 𝑥 𝑒−2𝜋𝑖𝑥𝜉𝑑𝑥, ∀ 𝜉 𝜖 ℝ

"how much" of a certain frequency 
component is present

Phase = 𝑃 𝜉 = 𝑡𝑎𝑛−1 𝐼(𝜉)

𝑅(𝜉)

𝑒−2𝜋𝑖𝑥𝜉 = cos 2𝜋𝜉𝑥 − 𝑖 𝑠𝑖𝑛(2𝜋𝜉𝑥)

መ𝑓(𝜉) = 𝑅( 𝜉) + 𝑖 𝐼(𝜉)
Cartesian → Polar

Power spectrum =𝑀(𝜉)2 Phase 



Fourier transformation: examples in image processing

Some examples of fourier transform / image processing in reciprocal space:

- Removing repetitive noise
- Lowpass / anti-aliasing filters
- Bandpass filtering
- Assessing the resolution of an image
- Remove blur / Point spread function / motion blur
- Cross correlation

Videos and interactives (just google these):
3blue1brown Fourier Transform
Ptolemy and Homer (Youtube)
Ptolemy's spheres wolfram 



Fourier transformation: filtering in Fourier space

EXERCISE 3
Open Example 3A – repetitive noise (=multiplicative noise) and try to remove the repetitive noise using 
Fourier Filtering

- FFT Example 3B
- Locate the 2 strong delta functions.
- Make a selection around the high frequency noise

spots. Check if your foreground color is 'Black'
- Fill the area at the delta functions with black
- Inverse FFT



Fourier transformation: filtering in Fourier space

EXERCISE 3
Open Example 3 and Display an FFT. Try to remove the repetitive noise

1. Open the data

2. Make an FFT (Process > FFT > 
FFT)
Note the 2 strong Delta functions. 
These reflect the repetitive 
(sinoidal) noise in the image

3. Make a selection around the
high frequency noise spots
(hold shift to create 2 separate 
circles)

4. Edit > Clear 
Or fill the selection with black
pixels (CTRL+F), make sure
that foreground color is black: 
edit > options > Colors...

5. Unselect the yellow
selection.

6. Inverse the FFT (Process > 
FFT > inverse FFT)

Note, in the FFT, the cursor position shows info like this: r=200 
p/c (5). This is the radius of cycloid (=amplitude), the pixels per 
cylcoid and the frequency. Phase is not covered in this imageRemember Ethics...

Never change only
part of the image...
i.e. the real image



Fourier transformation: filtering in Fourier space

2D crystals (cyclic nucleotide gated

potassium channel MloK1, H. Stahlberg)

100 nm



Fourier transformation: Lowpass filter
Masks in Fourier space:
Black = remove frequencies
White = pass (keep) frequencies

1. File > New > Image...
2. Pick white: Edit > Options > Colors
3. Specify a centered, round concentric circle (Edit > 

Selection > Specify)
4. And fill it (Edit > fill)
5. Rename the new imag"Mask" (Image > Rename...)

My first Fourier space filter Apply your firstFourier space filter

Analyze > FFT > Custom filter
Choose your mask

Aliasing / Moire: frequencies that are (just) above the resolution of the image



Fourier transformation: Lowpass filter an anti-aliasing filter

Hamming filter
Is a low pass filter with a 
Gaussian gradient. This 
reduces "ringing"



Fourier transformation: bandpass filter (Inverse notch filter)

Masks in Fourier space:
Black = remove frequencies
White = pass (keep) frequencies

Fourier bandpass filter

Analyze > FFT > Bandpass...

Filter large structures = high frequency cutoff (here 40 pixels / cycles)
Filter small structures = Low frequency cutoff (3 p/c)
Process > FFT > Custom filter allows to use your own filter

Apply your first Fourier space filter



Example 3B – white noise

Fourier transformation: Resolution

Example 1D – non-native
(from 1st lecture)

1 (square) pixel =
4.05 nm wide/high

Power spectrum (FFT) Power spectrum (FFT)

Radial profile plot: 
https://imagej.net/ij/plugins/radial-profile.html



Example 3B – white noise

Fourier transformation: Resolution

Example 1D – non-native
(from 1st lecture)

1 (square) pixel =
4.05 nm wide/high

Power spectrum (FFT) Power spectrum (FFT)

Radial profile plot: 
https://imagej.net/ij/plugins/radial-profile.html

Image decorrelation plugin_
Example 3B – on the particle



Fourier transformation: deconvolution in Fourier space

Can you remove the motion blur?

A convolution of the light source with hands

Convolution, deconvolution are
DIFFICULT in real space but are
simple multiplications and division in 
Fourier space



Fourier transformation: filtering in Fourier space

Sampling in the temporal dimension
was not a point but a line: convolution
(i.e. the camera moved....)

Convolution, deconvolution are DIFFICULT in real 
space but are simple multiplicationsand division in 
Fourier space

Real Space Fourier Space

"impulse response of a linear 
time-invariant system"

FFT of the image

𝑦 𝑢, 𝑣

𝑥 𝑢, 𝑣

Observed image

Ground-truth image

ℎ 𝑢, 𝑣 blurring vector

* denotes convolution

𝑦 𝑢, 𝑣

ℎ 𝑢, 𝑣

𝑦 𝑢, 𝑣 = ℎ ∗ 𝑥 𝑢, 𝑣 + 𝑛(𝑢, 𝑣)



Fourier transformation: deconvolution

EXERCISE 4
Open Example 4 – Motion blurred and try to remove the motion blur

Can you remove the motion blur?

1. Open Example 4 – motion blurred, the motion blurred image.
2. Also open the point spread function of example 4.
3. Do the deconvolution: Process > FFT > FD math.
4. Image1 is the motion blurred image, Image2 is the Point spread function. Use 

deconvolve and check «Do inverse transform»

Deconvolution algorithms,
which allow to improve the resolution of an 
image, are exactly running these functions.



Fourier transformation: deconvolution

EXERCISE 4
Open Example 4 and try to remove the motion blur

Can you remove the motion blur?

1. Open Example 4, the motion blurred image.
2. Also open the point spread function of example 4.
3. Do the deconvolution: Process > FFT > FD math. 
4. Image1 is the motion blurred image, Image2 is the Point spread function. Use 

deconvolve and check «Do inverse transform» or run the inverse FFT afterwards

= →

Fourier Space
Real Space

𝑦 𝑢, 𝑣

ℎ 𝑢, 𝑣



Fourier transformation: deconvolution

Deconvolution algorithms
allow the improvement of the resolution of an image. Deconvolve algorithms try to
mimick the PSF (point spread function) produced through diffraction and deconvolute it
to improved the image.

Point spread function (XY)*
Imaged in 
defocus

Imaged in 
focus

Axial Point spread function (XZ)

* In electron microscopy you may see the contrast transfer function (CTF) or modulation transfer function (MDF)

aperture

Airy disc



Fourier transformation: deconvolution

𝑦 𝑢, 𝑣 = ℎ ∗ 𝑥 𝑢, 𝑣 + 𝑛(𝑢, 𝑣)

𝑦 𝑢, 𝑣

𝑥 𝑢, 𝑣

Observed image

Ground-truth image

ℎ 𝑢, 𝑣 PSF, OTF, CTF, blurring vector…

𝑛 𝑢, 𝑣 Unknown additive noise, independent of x(u,v)

* denotes convolution

ො𝑥 𝑢, 𝑣 = 𝑔 ∗ 𝑦 𝑢, 𝑣

ො𝑥 𝑢, 𝑣

𝜖 𝑢, 𝑣 = 𝔼 𝑥 𝑢, 𝑣 − ො𝑥 𝑢, 𝑣 2

The estimate of with a minimized
cost function

𝜖 𝑢, 𝑣 Cost function (Mean square error)

𝔼 Expectation

GOAL: find g(u,v) so that:

𝑥 𝑢, 𝑣



Fourier transformation: Wiener filter

𝑦 𝑢, 𝑣 = ℎ ∗ 𝑥 𝑢, 𝑣 + 𝑛(𝑢, 𝑣)

ො𝑥 𝑢, 𝑣 = 𝑔 ∗ 𝑦 𝑢, 𝑣

𝐺 𝑎, 𝑏 =
𝐻∗ 𝑎, 𝑏 𝑆(𝑎, 𝑏)

𝐻 𝑎, 𝑏 2𝑆 𝑎, 𝑏 + 𝑁(𝑎, 𝑏)

𝐺 𝑎, 𝑏 Fourier transform of g(u,v)

𝐻 𝑎, 𝑏 Fourier transform of h(u,v)

𝑆 𝑎, 𝑏 = 𝔼 𝑥 𝑢, 𝑣 2 the mean power spectral 
density of the original image x(u,v)

𝑁 𝑎, 𝑏 = 𝔼 𝑉 𝑢, 𝑣 2 the mean power spectral 
density of the noise t(u,v)

෠𝑋 𝑎, 𝑏 = 𝐺 𝑎, 𝑏 𝑌(𝑎, 𝑏)

Rewritting this a bit:

𝐺 𝑎, 𝑏 =
1

𝐻(𝑎, 𝑏)

1

1 +
1

𝐻 𝑎, 𝑏 2𝑆𝑁𝑅(𝑎, 𝑏)

𝑆𝑁𝑅 𝑎, 𝑏 =
𝑆(𝑎,𝑏)

𝑁(𝑎,𝑏)
 = signal to noise ratio

Zero noise➔ 𝑆𝑁𝑅 𝑎, 𝑏 = ∞➔ = 1 = 
simple inverted system

noise not zero ➔ 𝑆𝑁𝑅 𝑎, 𝑏 drops ➔ > 1 = 
frequencies are attenuated locally



Fourier transformation: Cross correlation (pattern matching)

Image A Image B
Overlayed and false color coded

Used in:
Confocal LSM (tiling, …)
SEM / EDX (drift correction)
TEM (eucentric heigh alignment)
FIB-SEM (tracking)
…



Real spaceFourier Space

Fourier transformation: Cross correlation (advanced!)

EXERCISE 
Open Example 5 (both images) and try to align them

1. Process > FFT > FD math... 
2. Find the position of the main peak:

a. Process > math > Log
b. Process > Find maxima). 
c. Analyze > Measure

3. Translate Example 5B



Fourier transformation: Cross correlation

EXERCISE 
Open Example 5 and try to align the two images

1. Make a cross correlation 
between the two images 
(Process > FFT > FD math...). 

2. If you did not check ‘Do 
inverse transform’, do an 
inverse FFT

3. The result shows the cross correlation. 

4. Find the position of the
Main peak:
- Stretch the contrast (Process > math > 

Log). Update the B&C
- Find the peak (Process > Find maxima).
- Preview the point selection
- If needed, adjust Noise tolerance until

you have 1 maximum



Fourier transformation: Cross correlation

EXERCISE 
Open Example 5 and try to align the two images



Fourier transformation: Cross correlation

EXERCISE 
Open Example 5 and try to align the two images

5. Measure the position of that point
(Analyze > Measure)
X = 103
Y = 113
These is the translational distance
seen from the center of the image
(128,128) (why?)

6. Translate Example 5B
- Find the X and Y position in the

Results tab, subtract 128:
- (-25, -15) (why?)
- Translate Example 5B over the

found shift (Image > transform > 
translate…)

Image A

Image B, shifted



Fourier transformation: Summary

Functions in reciprocal space

In reciprocal space: convolutions become simple multiplications, deconvolutions simple divisions.



Part IV: Filters



Spatial filters

Use surrounding pixels to compute each new pixel intensity.



Spatial filters

[1] [2]

0 0 0
0 1 0
0 0 0

1 1 1
1 1 1
1 1 1

1x1 kernel (=point operation)

3x3 kernel  (=filter)

Local filters

Surrounding pixel info is used: kernel

Non-local filters

Find information similar to the current pixel, anywhere 
in the image. Replace it by the mean, median, … of 
those non-local values

Examples:
Non local means
Bilateral filter
Anisotropic diffusion
 

Smoothing filters
Gaussian filters
Gradient filters
Laplacian filters 

Linear filters Non-linear filters

Median filter
Variance filter
Minimum filter
Maximum filter 

Smoothing filters
Gaussian filters
Gradient filters
Laplacian filters

Linear filters



Linear filters: Box filter (or mean filter)

for a(u,v) 

   for x 

      Array=(u+/-x,v+/-x))

      a'(u,v) = f(Array) 

   next 

next

Basic concept: u= image width, v=image height, x= kernel size

For each pixel in the image

for the size of the kernel

Put the pixel & all the surrounding pixels in an array

perform a function. The result is the new value

of the initial (central) pixel

end the kernel

Go to the next pixel



Linear filters: box filter (mean filter)

3x3 smoothing filter

Each new pixel value is the average of the pixel and its surrounding pixels (eg: a 3x3 filter is 1 central pixel and 8 surrounding 

pixels)

𝐼 =

σ

𝑎00 𝑎01 𝑎02

𝑎01 𝑎11 𝑎12

𝑎02 𝑎12 𝑎22

𝑛

1 1 1
1 1 1
1 1 1



Linear filters: box filter (mean filter)

⊗ =
1 1 1
1 1 1
1 1 1



Linear filters: box filter (mean filter)

⊗

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1

=



Linear filters: box filter (mean filter)

⊗

1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1



Linear filters: box filter (mean filter)



Linear filters: Gaussian

3x3 gaussian smoothing filter

Each new pixel value is the weighted average of the pixel and its surrounding pixels (a 3 x 3 filter is 1 central pixel and 8 

surrounding pixels or radius=1 )

1 2 1
2 4 2
1 2 1



Linear filters: Gaussian

3x3 gaussian smoothing filter

⊗ =

Each new pixel value is the weighted average of the pixel and its surrounding pixels (a 3 x 3 filter is 1 central pixel and 8 

surrounding pixels or radius=1 )

1 2 1
2 4 2
1 2 1



Linear filters: Gaussian

5x5 gaussian smoothing filter

⊗ =

Each new pixel value is the weighted average of the pixel and its surrounding pixels (a 5 x 5 filter is 1 central pixel and 24 

surrounding pixels or radius=2)

1 4  6  4  1

4 16 24 16 4

6 24 36 24 6

4 16 24 16 4

1 4  6  4  1



Linear filters: Gaussian

11x11 gaussian smoothing filter

⊗ =

Each new pixel value is the weighted average of the pixel and its surrounding pixels (a 11 x 11 filter is 1 central pixel and 120 

surrounding pixels, radius=5)

1 ⋯ 1
⋮ ⋱ ⋮
1 ⋯ 1



Linear filters: Gaussian

Box filter, 11x11 Gaussian filter, 11x11



Linear filters: Mexican hat (difference)

3x3 difference filter

Coefficients of the matrix (not the central value) are < 0

➔ Differences with the central pixel are accentuated

−1 −1 −1
−1 10 −1
−1 −1 −1



Linear filters: Mexican hat (difference)

3x3 difference filter

Coefficients of the matrix (not the central value) are < 0: differences with the central pixel are accentuated: sharpening!

⊗ =
−1 −1 −1
−1 10 −1
−1 −1 −1



Linear filters

Process > Filters > Convolve... To design your own filter or load a premade filter (space between the coefficients)

Use the ‘Normalize kernel’ option ! (why?)

Why would you (willingly) blur your data?

EXERCISE 
Open Example 6A  (Lena), Example 6B (Fabio) or camera man and try some smoothing and Gaussian filters



Linear filters: why?

EXERCISE 
Why would you willingly blur your image? Try Example  7 - gradient

Background gradient
 correction



Linear filters: Image gradient magnitude

How to calculate a derivative of a discrete function??

(meaning h cannot made smaller than the pixel size…)

How can we express/quantify the strength of the gradient (or the «intensity» 

of an edge)? What about direction of a gradient?

10 60 10 200 210 250 250



Linear filters: Prewitt gradient filter

Prewitt filter: simplest of derivative (gradient) filters

= rate of (intensity) change 

= edge detection

Horizontal gradient magnitude

−1 0 1
−1 0 1
−1 0 1

⊗ =

Vertical gradient magnitude

−1 −1 −1
0 0 0
1 1 1

⊗ =



Linear filters: Sobel gradient filter

Sobel filter: improved with a weighted average filter

1 0 −1
2 0 −2
1 0 −1

=

−1 −2 −1
0 0 0
1 2 1

=

[1 0 −1]

x derivative

1
2
1

Weighted average

[1 2 1]

y derivative

1
0

−1
Weighted average



Linear filters: Image gradient magnitude

Horizontal gradient magnitude

Vertical gradient magnitude

Gradient is encoded in the pixel value. High 
value = border

Gradient magnitude



Linear filters: Image gradient magnitude

Gradient angle is encoded in the pixel value.

Gradient angle

Horizontal gradient magnitude

Vertical gradient magnitude



Linear filters: sobel filter

EXERCISE
Open Example 8B or (Example 6A/B/C) and perform a Sobel filter

Process > Filters > Convolve... To design your own filter or load a pre-made filter



Linear filters: sobel filter

EXERCISE
Open Example 8 or (Example 6A/B/C) and perform a Sobel filter

1. Duplicate the image (you need an X and a Y)

2. Process > Filters > Convolve... To design your own filter or load a pre-made filter

Make sure «normalize kernel» is switched on (this causes each coefficient to be 
divided by the sum of the coefficients, preserving image brightness). See the live 
preview by clicking «preview»

Sobel edge finding filter:

3. Convert each image to 16 bit (Image > mode) – this ensures you will not overilluminate during the next steps

4. Square each of the images (Process > math)  

5. Sum them up (with process > image calculator, use ‘add’, and 32-bit, new window)

6. Finally, square root the result (Process > Math)

Gradient magnitude



Linear filters: Laplacian of Gaussian (LoG)

First derivative

Second derivative

Laplacian
= the divergence of the gradient of a function in Euclidean space
= second derivative

10 60 10 200 210 250 250



Linear filters: Laplacian of Gaussian (LoG)

0 −1 0
−1 4 −1
0 −1 0

⊗ =

−1 −1 −1
−1 8 −1
−1 −1 −1

Is another approximation of the second derivative of a discrete function and 
therefore also a Laplacian of Gaussian filter (LoG)



Linear filters: Laplacian of Gaussian (LoG) vs Sobel

The LoG is
• Computationally faster
• More precise

Then why using a Sobel filter? 



Linear filters: Laplacian of Gaussian (LoG) vs Sobel

The LoG is
• Computationally faster
• More precise

Then why using a Sobel filter? 

EXERCISE
Open Example 9 or 10 (A, B or C) and perform a Laplacian of Gaussian filter. Then try a Sobel filter



Linear filters: Laplacian of Gaussian (LoG) vs Sobel

EXERCISE 
Open Example 9 (A, B or C) and perform a Laplacian of Gaussian filter. Then try 
a Sobel filter

The LoG is
• Computationally faster
• More precise
• Very prone to noise

LoG

Sobel gradient magnitude



Linear filters: Overview

Averaging → smoothing

(all coefficients > 0)

Difference → sharpening

(some coefficients < 0)
Laplacian → edge detection

(second derivative)

Gradient → edge detection

(first derivative)



Spatial filters

[1] [2]

0 0 0
0 1 0
0 0 0

1 1 1
1 1 1
1 1 1

1x1 kernel (=point operation)

3x3 kernel  (=filter)

Local filters

Surrounding pixel info is used: kernel

Non-local filters

Find information similar to the current pixel, anywhere 
in the image. Replace it by the mean, median, … of 
those non-local values

Examples:
Non local means
Bilateral filter
Anisotropic diffusion
 

Smoothing filters
Gaussian filters
Gradient filters
Laplacian filters 

Linear filters Non-linear filters

Median filter
Variance filter
Minimum filter
Maximum filter 

Non-linear filters

Median filter
Variance filter
Minimum filter
Maximum filter 



Non-Linear filters

minimum filter 

Maximum filter

Median filter

Linear filters: all pixels in the kernel are used

Smoothing and blurring ≠ noise removal

Non-Linear filters: from all pixels in the kernel, one - the most appropriate - is chosen

Camera man Camera man – minimum filter 2px radius Camera man – maximum filter 2px radius Camera man – median filter 2px radius

for a(u,v) 

   for x 

      Array=(u+/-x,v+/-x))

      a'(u,v) = f(Array) 

   next 

next



Non-linear filters



Non-linear filters

EXERCISE
Noise reduction: open Example 9 or Example 10(A/B/C) and try to reduce the noise using linear filters (Gaussian 
smoothing) and non-linear filters (median).

Linear filter
Process > Filters > Gaussian blur

Non-linear filter
Process > Filters > Median



Non-linear filters

Camera man + Pepper & Salt noise 

(=multiplicative noise)

Process > Filters > Gaussian blur / Median

EXERCISE
Noise reduction: open Example 9 or example 10 (A/B/C) and try to reduce the noise using linear filters (Gaussian 
smoothing) and non-linear filters (median).



Non-linear filters

Camera man + noise Linear filter (Gaussian) Non-Linear filter (Median)Original camera man



Non-linear filters: Variance

EXERCISE 
Exploit the relative absence of variance in the background to mask the cells (use Example 10)

Example: Bright field image of cells. 

Process > Filters > Variance...



Non-linear filters: Variance

EXERCISE 
Exploit the relative absence of variance in the background to mask the cells

Raw data Variance filter (r=1)

Substract 50000

Median filter Result (overlay)

Example: Bright field image of cells. 

Process > Filters > Variance...

Laplacian of Gaussian

Example of a image processing pipeline!



Spatial filters

[1] [2]

0 0 0
0 1 0
0 0 0

1 1 1
1 1 1
1 1 1

1x1 kernel (=point operation)

3x3 kernel  (=filter)

Local filters

Surrounding pixel info is used: kernel

Non-local filters

Find information similar to the current pixel, anywhere 
in the image. Replace it by the mean, median, … of 
those non-local values

Examples:
Non local means
Bilateral filter
Anisotropic diffusion
 

Smoothing filters
Gaussian filters
Gradient filters
Laplacian filters 

Linear filters Non-linear filters

Median filter
Variance filter
Minimum filter
Maximum filter 

Non-local filters

Find information similar to the current pixel, anywhere 
in the image. Replace it by the mean, median, … of 
those non-local values

Examples:
Non local means:
 Averages neighbours with similar 

neighbourhoods

Bilateral filter (Adaptive smoothing):
 Averages neighbours with similar intensities.
 Pixel-based

Anisotropic diffusion (adaptive smoothing):
 Averages neighbours with similar intensities.

Based on variational framework, where some
 image functional (cost-function) is minimized



Non-local filters: bilateral filter

Original

Concept
imagine, the kernel size of a Gaussian filter is variable… depending on the gradient magnitude 

High gradient magnitude = small kernel
Low gradient magnitude = high kernel

Noisy Original      Noisy       denoised   KernelBilateral filter

Range: the higher range radius, the more the filter mimicks Gaussian convolution
Spatial: the higher the spatial radius, the more smoothing is applied



Non-local filters: anisotropic diffusion filter

Original

Concept
Same concept of adaptive gaussian filters, but based on heat diffusion physics

High gradient magnitude = small kernel
Low gradient magnitude = high kernel

Noisy Original  Noisy  denoised  Anisotropic diffusion

Iterative!



Non-local filters: Non local means

Original

Concept
Unlike "local mean" filters, which take the mean value of a group of pixels surrounding 
a target pixel to smooth the image, non-local means filtering takes a mean of all pixels 
in the image, weighted by how similar these pixels are to the target pixel.

Noisy Original  Noisy  denoised  Non-local means

Sigma: "kernel size", or how far the pixels may derive from the target pixel
Smoothing factor: Additional local gaussian smoothing (1 means no smoothing)



Non local filters = noise reduction

Original noise added median Bilateral NLM ADNAD

NLM: non-local means (https://imagej.net/Non_Local_Means_Denoise)

AD: non-linear anisotropic diffusion (https://imagej.nih.gov/ij/plugins/anisotropic-diffusion-2d.html)

Noise = poisson noise (=shot noise), not salt and pepper



Filters: summary



Part V: Machine learning



Machine learning



Neural networks



Deep convoluted neural networks

𝑦 𝑢, 𝑣 = ℎ ∗ 𝑥 𝑢, 𝑣 + 𝑛(𝑢, 𝑣)

ො𝑥 𝑢, 𝑣 = 𝑔 ∗ 𝑦 𝑢, 𝑣

Assume you have
- y(u,v) (the observed image)
- x(u,v) ( the image without noise)
- h(u,v) (the point spread function is 1)

Brute-force calculate g(u,v) until n(u,v) is minimal
- Input: x(u,v) and y(u,v) examples
- Stochastic gradient descent
- Iterative learning algorithm

Output
- A model (readible by software)
- That can predict how to adjust pixel intensities
- How it works: ?

Plugins > CSBDeep > N2V > N2V Train

Image used for training: y(u,v)
Image used for validation: x(u,v)

Epochs: one full cycle through the training 
dataset (= many iterations)

Batch size: The number of training samples (parts of 
an image) used in one iteration

Number of steps: Total Number of Training 
Samples / Batch Size

Original

Process > Noise > Add noise



Deep convoluted neural networks

𝑦 𝑢, 𝑣 = ℎ ∗ 𝑥 𝑢, 𝑣 + 𝑛(𝑢, 𝑣)

ො𝑥 𝑢, 𝑣 = 𝑔 ∗ 𝑦 𝑢, 𝑣

Assume you have
- y(u,v) (the observed image)
- x(u,v) ( the image without noise)
- h(u,v) (the point spread function is 1

Brute-force calculate g(u,v) until n(u,v) is minimal
- Input: x(u,v) and y(u,v) examples
- Stochastic gradient descent
- Iterative learning algorithm

Output
- A model (readible by software)
- That can predict how to adjust pixel intensities
- How it works: ?

Plugins > CSBDeep > N2V > N2V Train

Image used for training: y(u,v)
Image used for validation: x(u,v)

Epochs: one full cycle through the training 
dataset (= many iterations)

Batch size: The number of training samples (parts of 
an image) used in one iteration

Number of steps: Total Number of Training 
Samples / Batch Size

Original

Process > Noise > Add noise



Deep convoluted neural networks: example

Plugins > CSBDeep > N2V > N2V PredictOriginal image

Random noise is added to the image. The 
noise is Gaussian distributed with a mean 
of 0 and SD of 25.

Noise added

Repositories
CBSDeep and Tensorflow must be installed.



Deep convoluted neural networks: example

ImageJ options: Edit > Options > Tensorflow...

FIJI repositories On The PC:



Deep convoluted neural networks: example

Original image N2V PredictionNoise added



Deep convoluted neural networks: example

Original image Plugins > CSBDeep > N2V > N2V Predict

Random noise is added to the image. The 
noise is Gaussian distributed with a mean 
of 0 and SD of 50.

Noise added



Congratulations,

You finished Part II, Advanced image processing

For Part III, 

Install from the repos:

- DeepImageJ

- LabKit

From the internet:

Ilastik (ilastik.org)
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