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Administration

Who am I?

- PhD in structural biology (University of Bern)
- PostDoc in 3D image quantification
- 2 years at Max Planck Institute of Biochemistry, Munich, Germany
- At AMI since 2012
- Author or co-author on 80+ scientific papers

- >3500 citations
- h-index: 30
- i10-index: 45

- 20 years of experience with scientific images (2D, 3D and 4D: LSM, 
SEM, TEM, FIB, etc…)

- 20 years of experience with imageJ and Fiji



Administration

Exploit the 
capacity of 
ImageJ/FIJI

To improve 
own data / 

pictures

Learning 
how 

scripting 
works

How far can 
go with FIJI

I want to 
know 

precisely 
what I am 

doing

use key 
ImageJ 
options 

correctly

(Nano)-
particle size 
distribution 

and size 
analysis

Determine 
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objects and 
size 

distribution
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number in 

a more 
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way

Distribution 
size of my 
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particles



Administration

Why ImageJ (in fact: FIJI)?

Functionality
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MS Paint

MS Powerpoint

GIMP

ImageJ

FIJI

Corel Paintshop
pro

Adobe 
Photoshop

Image Magick

Scikit-image

Avizo/Amira

Pandas

Pillow image
library (PIL)

OpenCV

Imaris

FIJI (FIJI is just imageJ)
- Graphical user interface
- Extendable with plugins
- Designed for scientific data
- Broad functionalities
- Scripting possibilities

WEKA



Image processing
Part I: digital images and pixels

• Creating digital images from analogue signals
• Hat is a pixel?
• Noise
• Image file formats
• Bitdepth



Image processing

Central idea: 

GIGO
Garbage in, garbage out

Good image in ➔ maybe better image out

Bad image in ➔  never a good image out

Image processing starts with recording good images

Sample preparation Imaging Image processing



Going digital: Continuous to discrete function

1. Spatial sampling

2. Time sampling

3.   Analog to digital conversion



What is a pixel - Cameras and detectors

Photodiode (or well, or element) 

Camera
(e.g LM, TEM)

Detector
(e.g LSM, SEM, 
STEM)



Step 1: spatial sampling

1. The continuous (=infinite) light distribution is spatially sampled to a discrete function

➔Conversion from continuous to a discrete function (artefacts: e.g. moiré)

➔Sensor geometry is relevant (e.g. binning)

➔According to Nyquist-Shannon theorem

Continuous function

Discrete function

Nature

Small chip photodiodes

Medium chip photodiodes

Large chip photodiodes

Binning



Step 2: temporal sampling

2. This resulting discrete function is sampled in the time domain (=1 still image)

 ➔ Exposure time (the regular time interval) is relevant, signal to noise ratio (SNR), shot noise

Discrete function, time domain sampled

Discrete function

Long exposure time, high SNR

Medium exposure time

Short exposure time, low SNR



Step 3: analog to digital conversion

Discrete function, time domain sampled

Discrete function, time domain sampled

3. The resulting values are quantitized to a finite set of numeric values
 ➔ Conversion from photons (or electrons, X-rays,...) to electric charge (= analog to digital converter) 
 ➔ charge is converted to a range of integers
 ➔ hot pixels, jitter, periodic noise

Salt-&-pepper noise, read noise

Scan faults, jitter, periodic noise 

1101011011010001011011101010101111010010011100100110011100111001

1101011011010001011011101010101111010010011100100110011100111001



Going digital – what is a digital image?

A digital image is an ordered, rectilinear array (or grid) of integers (numbers: 0,1,2,3…).

Each element (=number) in the grid is also known as a picture element or ‘Pixel’

1 dimensional 

array

Spectrum

2 dimensional 

array

Image

3D array
(= volume stack or

video

Stacks



What is a pixel? – it depends on the context

Digital image
Pixels

Display
Triades

Camera chip
Wells

Printed output
Dots Pixel = 

‘Pic(ture) + 

el(ement)’



What is a pixel – the little square model

Consider a grid:

Problem: how to convert a continuous spectrum (nature) to a discrete set of intensities (digital)

What are the pixels?

5x5 grid?

4x4 grid?

The corners?

 The squares? 

Where is the center of a pixel?

Pixel 𝑖, 𝑗 corresponding to square x, y → 𝑖 − 0.5 ≤ 𝑥 ≤ 𝑖 + 0.5, 𝑗 − 0.5 ≤ 𝑦 ≤ 𝑗 + 0.5

‘Integerists’

Pixel 𝑖, 𝑗 corresponding to square x, y → 𝑖 − 1 ≤ 𝑥 ≤ 𝑖 + 1, 𝑗 − 1 ≤ 𝑦 ≤ 𝑗 + 1

‘Half-integerists’A pixel is a point sample
(it exists only at one point*)

*For color pixels, there might be 3 or even 4 values at that point

An image = an array on point samples (Shannon sampling theorem!)



What is a pixel – the reconstruction filter

Image under construction Recorded image

At no point, a 

square is involved!
The footprint of a 

”reconstruction filter” 
(e.g. beam)

A 5x4 image

Problem: how to convert a continuous spectrum (nature) to a discrete set of intensities (digital)



What is a pixel – the point sample model

Q: What about the information (O) below the Shannon limit? 

A: we simply do not know! 

But you could try to guess. This is called Reconstruction 

or interpolation

Nature is continuous (has a value at every position), a digital image is a finite set of measurements: 

information will be lost. 

Using the point sample model, we include the notion that information has been lost, and can talk about the best 
ways to measure that loss

o

o
o

o



Going digital: the sampling theorem

Sampling =

process of converting continuous signal 

(time and space) into a sequence of values 
(a discrete function).

Shannon Sampling Theorem 
If a function S(t) contains no frequencies higher 
than B hertz, it is completely determined by 
giving its ordinates at a series of points spaced 
1/(2B) seconds apart

Shannon Sampling Theorem - revisted 
If a series of discrete values has been sampled
1/(2B) apart,  it does not contain information
smaller than B hertz.

Shannon Sampling Theorem - applied
If an image has been recorded at a resolution of
e.g.100 nm, it does not contain information
smaller than 200 nm.



What is a pixel: Nyquist theorem

«well edge-centered»«well-centered»

1 well diameter

2 well diameter

3 well diameter

Nyquist's theorem (“howto convert analog to digital”): 
the frequency of the digital sample should be twice that of the analog frequency

For digital images: 
= a "sampling rate" of 2 wells relative to the object image size. 

Nature Digital Nature Digital



What is a pixel

Something in a camera/detector
Photodiode dimensions

A picture element
Pixel size

Something in a display
Triade dimensions

A dot of printer ink 
Dots per inch

Pixel concept
=Point sampling



What is a resolution? And what is magnification?

Magnification Resolution Resolving power
Lo
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Easy Very difficult



Noise

Gaussian noise

Sum of all natural sources 
forming a normal distribution 
(=Gaussian distribution). 

• Johnson–Nyquist noise (thermal 
vibrations of atoms in conductors)

• Black-body radiation (radiation from 
the earth or other objects)

• Sensor noise (when not recording at 
0 K)

• Electronic circuit noise (impedance
in electronic cables)

• kTC noise (Effects of capacitors)

FFT filtering, Gaussian 
smoothing.

Salt and pepper noise
Caused by errors. Typically 
B/W distribution

• During data transmission
• Failure in a memory cell 
• Analog-to-digital converter 

errors
• Occasionally in TEM (X-rays)
• In camera-based systems: dead 

pixels

Median filtering

Poisson (shot) noise
Caused by quantum effects 
due to the movement of 
discrete, quantized, packets

• In the source (light) 
• In the electronics (electric current). 
• Dark shot noise: shot noise from 

the dark leakage current in the 
image sensor

high intensity, exposure times
Correct with bias images

Repetitive noise
caused by electrical 
interference during the 
image capturing process.

Signal deconvolution in 
reciprocal space

Additive noise Multiplicative noise



Intermezzo - how does a computer work?

1 Bit

8 Bits = 1 byte

Computer = on/off
 = binary digits (‘bit’)

Examples of decimal (=10 digits) counting
- begins with 1 digit (rightmost digit or first 

digit) 
- When all available symbols are exhausted:

- the least significant digit is reset to 0, 
- the next digit (one position to the 

left) is incremented (=overflow)
 0  1  2  3  4  5  6  7  8  9 

10 11 12 13 14 15 16 17 18 19

Examples of binary (=2 digits) counting
- begins with 1 digit (rightmost digit or first 

digit) 
- When all available symbols are exhausted:

- the least significant digit is reset to 0, 
- the next digit (one position to the 

left) is incremented (=overflow)
 0   1   10  11 100 101 110 111

(0) (1) (2) (3) (4) (5) (6) (7)

Dec  Char     Dec  Char     Dec  Char

--------     ---------     ----------

32  SPACE     64  @         96  `

33  !         65  A         97  a

34  "         66  B         98  b

35  #         67  C         99  c

36  $         68  D        100  d

37  %         69  E        101  e

38  &         70  F        102  f

39  '         71  G        103  g

40  (         72  H        104  h

41  )         73  I        105  i

42  *         74  J        106  j

43  +         75  K        107  k

44  ,         76  L        108  l

45  -         77  M        109  m

46  .         78  N        110  n

47  /         79  O        111  o

48  0         80  P        112  p

49  1         81  Q        113  q

50  2         82  R        114  r

51  3         83  S        115  s

52  4         84  T        116  t

53  5         85  U        117  u

54  6         86  V        118  v

55  7         87  W        119  w

56  8         88  X        120  x

57  9         89  Y        121  y

58  :         90  Z        122  z

59  ;         91  [        123  {

60  <         92  \        124  |

61  =         93  ]        125  }

62  >         94  ^        126  ~

63  ?         95  _        127  DEL

From numbers to text
- ASCII: American Standard Code for 

Information Interchange
- List of numbers with defined characters

‘AMI‘
(dec): 65 77 73
(bin): 1000001 1001101 1001001 



File formats

From concept: 3 different approaches:
1. Vector graphics formats
2. Raster graphics formats
3. Hierarchical file formats



File formats: Vector graphics

Formats   svg, wmf, eps, pdf, cdr, ai, …
Origin  1963, with SketchPad, the PhD thesis of Ivan Sutherland

Concept  text file (usually xml style) with information on objects to be drawn
Example <rect

         y="11.25"
         x="5.6696429"
         height="34.017857"
         width="34.017857"
         id="rect4518"
         style="fil l:#ff0000;fi ll-opacity:1;stroke:none;stroke-
width:0.52999997;stroke-linejoin:round;stroke-
miterlimit:10;stroke-dasharray:none" />

<circle
         r="11.717261"
         cy="38.464279"
         cx="30.616072"
         id="path4522"

         style="fil l:#008000;fi ll-opacity:1;stroke:none;stroke-

Important for Overlays!!



File formats: Raster graphics

Formats  tif, jpg, png, bmp, webP, psb, …
Origin  raster scan of cathode ray tubes (i.e. early TV screens) 
  ‘Raster’ comes from rastrum (Lat.) = to scrape

Concept  Tesselation (tiling) of a 2D plane with a value for every cell (‘pixel’)
 



File formats: Raster graphics – Headers

Concept  Tesselation (tiling) of a 2D plane with a value for every cell (‘pixel’)
Problem  Metadata: How large is the image? When was it made? But also:
  e.g. medical data (patient information)
  e.g. scientific data (experiment information)
  e.g. consumer data (GPS coordinates, time and date)
Solution  Header
  contains height and width of the raster (=image) +lots of other data
Example

Header

data 

01110100 (ASCII, 116 = T)
01101001 (ASCII, 105 = I)
01100110 (ASCII, 102 = F)
00000100 (width = 4 px)
00000001 (heigth = 1 px)

00000000
00110010
01100100
10010110



File formats: Raster graphics – Compression

Concept  Tesselation (tiling) of a 2D plane with a value for every cell (‘pixel’)
Problem  Data gets really big
Solution  Compression. There are 2 compression concepts:

  - lossy (ie. The original data is approximated, but not restored)
  e.g. jpg -> compression artefacts

  - lossless (the original data can be restored)
  e.g. Run Length Encoding (RLE), Lempel Ziv (LZx, uses lookups)

00000000
00110010
01100100
10010110

8x0
2x0 2x1 2x0 10
0 2x1 2x0 1 2x0 
1 2x0 10 2x1 0

A = 00
B = 11
C = 10
4XA
A B A C
0 B A 1 A 
1 A C B 0

Original data RLE compressed LZ compressed

32 bits 29 bits

38 bits

Repeated to get 1024x1024: 
Original 8 Mb
RLE 7.25 Mb (-10%)
LZ 7 bytes (!) (-99.99999%)



File formats: Hierarchical data formats (HDF) 

Formats   h5

Origin  1987 by the Graphics Foundations Task Force. Around 1992, NASA 
  investigated 15 different file formats for use in the Earth Observing 

 System (EOS) project and settled for HDF. 

Concept  Container of multiple, heterogenous data (including really big 

 datasets), with metadata

Some advantages - really really big datasets possible (e.g. tomography data)

  - hierarchical data (e.g. google maps)

  - heterogenous data (e.g. EDX spectra with images)

  - slices: only part of an image can be read (e.g. google maps)

  - embedded coding (allows advanced compression techniques)

 



File formats: raster graphics: bit depth

The range of the values a pixel can take is called the bit depth

1 bit (=black and white, =binary image)  2 shades

8 bit (=common consumer cameras)  256 shades 

~9 bit (=human eye)    ~500 shades 

12 bit (=middle range scientific cameras)  4096 shades 

16 bit (=high range scientific cameras)  65536 shades 

2n = number of shades
n = bitdepth

Binary (e.g. Thresholding!)

Grayscale

Signed (e.g. Signed 16bit). -32768 → +32768 Special

32 bit (=only computational)  4 294 967 296  shades 



File formats: raster graphics - bit depth & colour

The range of the values a Pixel can take is called the bit depth

RGB (=3 channels of each 8 bit = 24 bit)     256 x 256 x 256 colours

2n = number of shades
n = bitdepth

Additive color 

mixing

(Displays)

Subtractive color 

mixing (pigments, 

Printers)

48 bit RGB (= 3 channels of each 16 bit = 48 bit)

RGBA (=4 channels of each 8 bit = 32 bit)   256 x 256 x 256 colours x 256 Alpha

CMYK (=4 channels of each 8 bit = 32 bit) 256 x 256x 256x 256 colours

Computational

Digital images and pixels



Note: light sources and dyes/pigments

Additive color mixing

Light sources

Subtractive color mixing

Dyes and pigments

A green laser is green because it 

emits green photons

A leaf is green because it absorbs all white light except 

the green photons (which it reflects)



Image processing
Part II: How to open your data? • Updating ImageJ/FIJI

• Native file formats
• Repositories
• FIJI import
• Plugins
• Raw import



0. Update FIJI

Help > update ImageJ…

Start ImageJ, then Help > About ImageJ…



1. How to open your data in FIJI?

5 Possibilities:

• Native file formats
• Use a repository
• Use Import (Fiji only!)
• Use a plugin
• Through RAW import (raster graphics only)



1. Native file formats

Format 1 bit 8 bit 16 bit 32 bit RGB stacks Hyper-
stacks

Compression

TIFF        Lossless

GIF     Lossless

JPEG   lossy

PNG    Lossless

DICOM        Lossless

BMP    Lossless

PGM     Lossless

FITS     Lossless

AVI     Lossless

TIFF is the ‘default’ format of ImageJ (OME-TIFF) 
DICOM is a standard popular in the medical imaging community
FITS Flexible Image Transport System: adopted by the astronomical community
PGM: Portable GrayMap
AVI container format, only uncompressed AVIs supported
Red: no header information

5 Possibilities:

• Native file formats
• Use a repository
• Use Import (Fiji only!)
• Use a plugin
• Through RAW import 

(raster graphics only)



Native and non-native file formats

EXERCISE 1
Try to open example 1 A, B, D (HDR) and D (.SER)

File > open…
Or drag and drop the icon from the folder onto ImageJ/FIJI

Does it work?



Native and non-native file formats

EXERCISE 1
Try to open example 1 A, B, D (HDR) and D (.SER)

File > open…
Or drag and drop the icon from the folder onto ImageJ/FIJI

Does it work?

No… Only Example 1A and 1B open 
(or maybe not even 1B)



2. Using a plugin from the repository

Help > update… Plugins > Import > Bio-Formats > Bio-
Formats Importer

In the dialog: point to the file (Example 
1C)

Click OK

5 Possibilities:

• Native file formats
• Use a repository
• Use Import (Fiji only!)
• Use a plugin
• Through RAW import 

(raster graphics only)

EXERCISE 1
Try to open example 1B with the Bio-
Formats plugin



2. Using a plugin from the repository

3i  Sl ideBook 
AIM 
AVI (Audio Video Interleave) 
Adobe Photoshop PSD 
Al icona 3D 
Amersham Biosciences Gel 
Amira  Mesh 
Amnis FlowSight 
Analyze 7.5 
Andor Bio-Imaging Division (ABD) TIFF 
Animated PNG 
Aperio AFI 
Aperio SVS TIFF 
Appl ied Precision CellWorX 
Axon Raw Format 
BD Pathway 
Becker & Hickl SPCImage 
Bio-Rad Gel 
Bio-Rad PIC 
Bio-Rad SCN 
Bitplane Imaris 
Bruker MRI 
Burleigh 
Canon DNG 
Cel lH5 
Cel lVoyager 
Cel lomics 
DICOM 
DeltaVision 
ECAT7 
EPS (Encapsulated PostScript) 
Evotec/PerkinElmer Opera Flex 
FEI 
FEI TIFF 
Gatan Digital Micrograph 
Gatan Digital Micrograph 2 
Hamamatsu Aquacosmos NAF 
Hamamatsu HIS 
Hamamatsu VMS 
Hamamatsu ndpi 
Hitachi S-4800 

Bio-formats repository
ImageJ
Fi ji
3D ImageJ Suite
3Dscript
ActogramJ
AIC Janelia 
Angiogenesis
AngioTool
Archipelago
AxoNet
BACMMAN
BAR
BaSiC
BigDataProcessor
BIG-EPFL
BigStitcher

BigVolumeViewer Demo
Bio-Formats
Biomat
Biomedgroup
BioVoxxel
Bl ind Analysis Tools
BoneJ
CALM
CAMDU
CATS
Cel lTrackingChallenge
CIP
CircleSkinner
cl i j
cl i j2
cl i jx-assistant
cl i jx-assistant-extensions
ClearVolume
CMCI-EMBL
CMP-BIA tools
CMTK Registration
Colocalization by Cross Correlation
Colour Deconvolution2
Cookbook
CSBDeep

Update lists / repositories

5 Possibilities:

• Native file formats
• Use a repository
• Use Import (Fiji only!)
• Use a plugin
• Through RAW import 

(raster graphics only)



3. Using a Fiji resident plugin (Import)

File > Import >
5 Possibilities:

• Native file formats
• Use a repository
• Use Import (Fiji only!)
• Use a plugin
• Through RAW import 

(raster graphics only)



3. Using a Fiji resident plugin (Import)

EXERCISE 1
Try to open example 1D (HDR)

File > Import > HDF5
Point to the file example 1C

The file contains 3 datasets (!)
- Select /Cells in data set path
- load as ‘Individual stacks’
- Click 'Load'



4. Using a plugin from the internet

Installing a plugin from a downloaded .jar file (https://imagej.nih.gov/ij//plugins/tia-reader.html)
3 ways of installing the jar file (it is also provided):
1. Drag and drop the file onto Imagej (and save in the plugin folder)
2. Plugins > install plugin… and point to the .jar file
3. Copy the .jar file into the plugins folder of your FIJI folder

In any case: Restart FIJI (close it and start it again)

Find the new functionality under Plugins > 
Input / output > Tia Reader

Howto open your data in FIJI?

5 Possibilities:

• Native file formats
• Use a repository
• Use Import (Fiji only!)
• Use a plugin
• Through RAW import 

(raster graphics only)

5 Possibilities:

• Native file formats
• Use a repository
• Use Import (Fiji only!)
• Use a plugin
• Through RAW import 

(raster graphics only)

ASCII  header format 
SPE Images
PICT, Targa  using Jimi
Biorad Z-Series
Leica SP multi-channel stacks
QuickTime
Jimi  Stack Wri ter
AVI Wri ter
JMF Reader
Animated Gif
PDS Images
AVI Reader
LSM Reader (Zeiss LSM confocal microscopes)
Quess RAW
IPLab Reader
Excel  Wri ter
Multi  FDF
VFF Opener
OpenSIF (opens Andor SIF files)
EXIF Reader
Bruker NMR
Zeiss ZVI Reader
ISAC images (e.g., Fuji BAS scanners)
Gatan DM3 Reader
Deltavision Opener
Nanoscope AFM fi les
NIfTI Input/Output
UNC format images
PDF Writer
Leica SP2 TIFF Sequence
EPS (Encapsulated PostScript) Writer
PerkinElmer Reader
Nikon ND2 Reader (Windows only)
TIA Reader (FEI/Emispec .ser files)
Heyex Raw Files (imports Heidelberg Spectralis images)
CINE Fi le Reader (opens Phantom High Speed Camera files)
MRI Fi le Manager (reads Bruker MRI spectrometer files)

https://imagej.nih.gov/ij/plugins/tia-reader.html


4. Using a plugin from the internet

EXERCISE 1
Install the TIA reader plugin (TIA_Reader.jar) if you have not done so
Then  try to open Example 1D, the .ser file, using plugins > input/output > TIA reader

Installing a plugin from a downloaded .jar file
• drag and drop the .jar file onto Imagej or click Plugins > install plugin…
• Save it in the plugins folder of your FIJI folder

• Restart FIJI
•  Then find the new functionality under 
       Plugins > Input / output > Tia Reader

•  Plugins > Input / output > Tia Reader
• Point to the .ser file
• Click ‘Open’

Howto open your data in FIJI?

https://imagej.nih.gov/ij//plugins/tia-reader.html

Does it work?



4. Using a plugin from the internet (short resolution intermezzo)

EXERCISE 1
Install the image decorrelation plugin as well (ImageDecorrelationAnalysis_plugin.jar). 

• Open Example 1B – Header – Cells.lsm with the Bio-Formats plugin (Plugins > Bio-Formats > Bio-
Formats Importer)

• Run the Image Decorrelation plugin on the blue channel (Plugins > Image Decorrelation Analysis)



4. Using a plugin from the internet (short resolution intermezzo)

EXERCISE 1
Install the image decorrelation plugin as well (ImageDecorrelationAnalysis_plugin.jar). 

• Open Example 1B – Header – Cells.lsm with the Bio-Formats plugin (Plugins > Bio-Formats > Bio-
Formats Importer)

• Run the Image Decorrelation plugin on the blue channel (Plugins > Image Decorrelation Analysis)



5. RAW import

Header

Image 1 - data 

Total file size (in bytes) = Header size + Image data size

5 Possibilities:

• Native file formats
• Use a repository
• Use Import (Fiji only!)
• Use a plugin
• Through RAW import 

(raster graphics only)



5. RAW import

Header

Image 1 - data 

Total file size (in bytes) = Header size + Image data size

01110100 (ASCII, 116 = T)
01101001 (ASCII, 105 = I)
01100110 (ASCII, 102 = F)
00000100 (width = 4 px)
00000001 (height = 1 px)

00000000
00110010
01100100
10010110

Header: 5 bytes (TIF, 4x1 pixel image)

Data: 4 bytes

Total file size: 9 bytes

3 Possibilities:

• Native file formats
• Use a plugin
• Through RAW import 

(raster graphics only)



5. RAW import

EXERCISE 1
Import through RAW (file > import > Raw…) of
Example 1A, the .tif file and Example 1D, the .SER file

Example 1A
1. A priori information: Camera size = 600x412 px x 8 bit depth
2. Use your operating system to find the file size (in bytes) of Example 1A

Idea: we will only read 
the DATA – and jump 

over the HEADER

Example 1D
Camera size: Veleta at AMI (2048 x 2048, 16 bit)
Use your operating system to find the file size



5. RAW import

File > import > RAW...

If your image is black, update brightness contrast:
Image > adjust > Brightness / contrast…
And click auto, or set (between 100 and 450)

Example 1A 
1. Camera size: 600x412 px x 8 bit
2. 247 348 bytes

Example 1D
1. Camera size: Veleta at AMI (2048 x 2048, 16 bit)
2. 8 388 754 bytes

EXERCISE 1
Import through RAW (file > import > Raw…)
 Example 1A, the .tif file
 Example 1D, the .ser file

Idea: we will only read 
the DATA – and jump 

over the HEADER



5. RAW import

1. Data size: 600 x 412 = 247 200 bytes
2. File size : 247 348 bytes

Therefore: header is 247 348 – 247 200 
= 148 bytes

1. Data size: 2048 x 2048 x 2 = 8 388 608 bytes 
(why x 2??)
2. File size : 8 388 754 bytes
Therefore: header is 8 388 754 – 8 388 608 = 
146 bytes

Endian: big-endian is often an “Apple thing”



Header

Files may (must) contain meta data (additional, useful information about the image)
F.A.I.R. Principles (https://www.go-fair.org/), open source data

Open Example 1D using File > import > RAW...
Select Image > Show info...

Title: Example 1D - non-native file formats - SiO4.ser
Width:  2048 pixels
Height:  2048 pixels
Size:  8MB
Pixel size: 1x1 pixel^2
ID: -77
Bits per pixel: 16 (signed)
Display range: 100 - 450
No threshold

Open Example 1D using the TIA Plugin >
Select Image > Show info...
 
Title: /home/.../Example 1D - non-native file formats.ser 
Width: 8.3029 microns (2048)
Height: 8.3029 microns (2048)
Size: 8MB 
Resolution: 246.6609 pixels per microns
Pixel size: 0.0041x0.0041 microns^2
ID: -63 
Bits per pixel: 16 (unsigned, grayscale LUT) 
Display range: 0-922 
Pixel value range: 0-922 
Image: 1/1 (1) No threshold
...



Summary: Howto open your data in FIJI

Native file 
formats
Use TIF whenever 
possible
Forget JPEG (has 
no header)
Metadata properly 
imported

Metadata is a love
note to the future

Raw import
Last resort, if 
everything else 
fails
Typically: a priori 
information about 
the file needed 
(dimension, bit 
depth)
Opens only the 
image data. No 
metadata.

Repositories
500+ scientific file 
formats available 
through 
Repositories. 
Metadata is (very 
very often) 
imported
E.g. Zeiss, Leica, 
Olympus, Nikon, 
FEI, ...

Install a plugin
Using the 
repositories or 
from the internet

FIJI Import
Not under plugins, 
but a bit hidden 
under file > import



Part III: Histograms

• Histograms of grayscale image
• Color images
• Histogram normalization and histogram equalization



Histograms

EXCERCISE 2
Open Example 1A and produce a histogram

Analyze > histogram (or CTRL+H)

• What can you deduce from the histogram?
• Try: List, Copy, Log, Live
• Save the histogram itself to a TIFF?
• Also try CTRL+ALT+H

Histogram
a representation of the 
distribution of numerical data.
Pearson, K. (1895)

The intensity distribution of the 
image (= it plots the number of 
pixel for each intensity or tonal 
value)



Histograms

EXCERCISE 2
Open Example 2A and 2B and look at the image

• Do you see a difference between the images?
• Check the histograms
• Do you see a difference between the histograms?



Histograms

EXCERCISE 2
Open Example 2A and 2B and look at the image



Histograms

What can you deduce from the histogram?
-   1. Bitdepth: 8 bit image (ranging from 0 to 255)
-   2. Pixel value distribution:
 Mean pixel value, variance of the intensity, 
 Min, Max & modal
- 3. Type of distribution: e.g. bimodal, exponential, …
-    4. Spikes: image normalization or equalization occurred (see later)
- 5. Contrast and Lookup table (see later): the range between maximum 

and minimum (in this case: 255)
- 6. Dynamic range: the number of distinct pixel values. Eg. Compression 

will affect the dynamic range
- 7. Overillumination effects
-    8. The intensity at each grayscale value

1

2

3

4

5

7

6

8



Histograms→ Linear transfer function

Find the contrast brightness window (Image > adjust > brightness/contrast) 

Each image intensity value is mapped to its corresponding screen value:
The linear transfer function is running from bottom left to top right

The linear transfer function 
assigns every original pixel value a new value on a 
linear scale. The endpoints of the function 
determine what value is white, and what black



Histograms→ Linear transfer function

Histogram: Attribute of 
the image

Transfer function: Attribute of 
visual perception 

Brightness Contrast

The transfer function is shifted

Pixels to the left of TFmin = black
Pixels to the right of TFmax = white
Pixels > TFmin and < TFmax = gray (linearly)

The transfer function is tilted

KEY: Changing the transfer function does not alter 
your data, only the way it is depicted

Find the contrast brightness window (Image > adjust > brightness/contrast) 



Histograms

EXCERCISE 3
Load Example 3 – GrayscaleLUT, and read out the grayscale values in the ImageJ 
statusbar.

- Use (+ to zoom in, - to zoom out)
- Hoover with the mouse over the image and check the status bar in ImageJ
- Image > adjust > Brightness/Contrast (CTRl+Shift+C)
- Make a histogram of this image. How do you interpret the histogram?
- Play around with the Minimum and Maximum in the transfer function (Image > 

Adjust> Brightness/Constrast). Check the effect on the values.
- Do you delete information?



Histograms: other lookup tables (LUTs)

Image = 2D array of numbers

Grayscale = giving a graphical meaning to these
Look-Up Tables.
But Grayscale is just one of these Look-Up tables!



Histograms: other lookup tables (LUTs)

EXCERCISE 3
Load Example 3 or Example 1A and try different LUTs

- Image > Lookup Tables > ...
- Image > Color > Show LUT
- Change brightness and contrast with some exotic LUTs

- You can make your own LUT using Image > color > Edit LUT



Histograms: color model

A color model
is a method of describing a color. Color models can be represented as tuples of 
numbers, typically as three or four values or color components.

RGB
- 3 values: Red, green & 

blue
- Additive

CMYK
- 4 values: Cyan, Mangenta, 

Yellow and black 
- Subtractive

HSL
- 3 values: Hue, Saturation 

and Lightness
- Additive

HSV
- 3 values: Hue, Saturation 

and Value
- Additive



A color space
is a way of mapping real colors to the color model's particular values. the goal 
having reproducible, unambiguous representations of color – whether such 
representation entails an analog or a digital representation.

Histograms: color space

Based on human perception
CIE 1931 XY
CIEUVW

Uniform color spaces CIELUV
CIELAB
HSLuv

RGB primaries (for CRT & LED displays)
sRGB (created by HP & Microsoft for on line use)
Adobe RGB (designed for CMYK color)
Adobe Wide Gamut RGB (wider range than 
sRGB: 77.6% vs 50.6%)
Rec. 2020 (used for HDR-TV)



Histograms: the color gamut

CIE 1931 XY colorogram

The color gamut
The entire range of colors and tones achievable by an imaging system (eyes, 
printer, display)

 

Inside the diagram:
All colors visible to the average 
human eye (= CIELAB color space)

Color mixing:
The colors along any line between 
two points can be made by mixing 
the colors at the end points

Spectral locus:
The edge of the diagram 
represents pure monochromatic 
light (single wavelength, in nm)

Color gamut:
Subset of colors that can be 
represented by mixing the colors 
at it's corners

Line of purples:
Non-monochromatic saturated 
colors (cannot be represented by a 
single wavelength)

White: sRGB color space
Gray: color space defined by CMYK



Histograms: color images

- Color image = 3 grayscale images combined (=composite). 
- with a red LUT
- With a green LUT
- With a blue LUT 

They are also called RGB images, or 24 bit images (=3x8 bit)



Histograms: color images

- Color image = 3 grayscale images combined (composite). 
- with a red LUT
- With a green LUT
- With a blue LUT 

They are also called RGB images, or 24 bit images (=3x8 bit)

Header

Image – 
red data 

Image – 
green data 

Image – 
blue data 



Histograms: color images

- Color image = 4 grayscale images combined (composite). 
- with a cyan LUT
- With a magenta LUT
- With a yellow LUT 
- With a black LUT

They are also called CMYK images, or 32 bit color images 
(=4x8 bit)

Header

Image – 
cyan data 

Image – 
Magenta

Image – 
blue data 

Image – 
blue data 



Converting color to grayscale

2
5
5
,2

0
6
,0 0,53,128

0, 149, 67

Direct conversion

1
5
4

60

72

46

1
9
7

95

Weighted conversion

Edit > Options > Conversions…



Converting formats, saving data

EXCERCISE 4
Load the clown test image and convert it to another format

- File > Open Samples > Clown
- Image > Type
- Change the type to e.g. 8-bit and check what happened to the size
- Can you change back to RGB (without Edit > undo, off course)? 
- Save as 8-bit, 16-bit and RGB TIFF. Compare file sizes

- Convert to CMYK: https://imagej.nih.gov/ij/plugins/cmyk/index.html

Bit depth Channels Filesize (bytes) Data Header

8 bit 1 64 236 bytes 64 000 bytes (=320x200x1) 236

16 bit 2 128 254 bytes 128 000 bytes (=320x200x2) 254

RGB 3 192 166 bytes 192 000 bytes (=320x200x3) 166

32 bit 4 256 266 bytes 256 000 bytes (=320x200x4) 266

L*a*b (3x32 bit) 3x4 768 672 bytes 768 000 bytes (320x200x4x3) 672



Histogram normalization, histogram equalization

Goal: to use the entire range of intensities in the histogram 

Solutions:

- Histogram normalization (histogram stretching)

- Histogram equalization 

WARNING: 

1. GIGO

2. We will now change the actual data, 

not longer only the transfer function.



Histogram normalization

Contrast: the range between 

the maximum and minimum 

intensity in the image

Contrast: 195 (204-9)

(of a possible 255)

Contrast: 255 (255-0)

(of a possible 255)



Histogram normalization: attention!

Problem: hot/cold pixels

Contrast: 255 (255-0)

(of a possible 255)

Contrast: 255 (255-0)

(of a possible 255)



Histogram equalization

= the normalization of the 

cumulative histogram of the 

image
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223223 255

Histogram equalization

Values

5

20

30

40
50

100

*PMF = Probability mass function

*CDF = Cumulative distribution function = cumulative histogram

CDF*

0.111

0.333

0.555

0.666
0.888

1

CDF norm

0

0.25

0.5

0.625
0.875

1

8 bit

0

63

128

159
223

255

5 20

20 30 30

40

5050 100

= the normalization of the 

cumulative histogram of the 

image

𝑔 𝑥, 𝑦 =
0.333 − 0.111

(1 − 0.111)
= 0.25

Note to the not-so-mathematically-inclined:

This is exactly the same formula as 3 slides

back, but now we use the newly created

cumulative histogram instead of the 

histogram



Histogram equalization: attention!

Watch out with Histogram equalization!

- Unrealistic artefacts in 8 bit (grayscale images)

- Image gradients in images with low depth (it will further reduce dynamic range)

- Undesired effects when histogram is not continuous



Histogram equalization: attention!

Process > Enhance contrast…
Amount of Saturated pixels: default = 0.3% (but play with it)
(usually, you want this very low)

Histogram normalizationEXCERCISE 5
Open Example 5B.tif and try the histogram normalization and histogram equalization



Histogram equalization: attention!

Example (Galaxy M51) Histogram normalization Histogram equalization



Part IV: Overlays and preparation for publication

• Overlays
• Annotations and scale bars
• Preparing figures for publications
• Inkscape
• FigureJ



Overlays

Overlays are vector graphics: non-active, 
non-destructive selections displayed ‘over’ 
the rastered graphics data.

Overlay selections are 
- Mathematically-defined paths (=not rastered), not affected by scaling, i.e., do not become pixelated. 
- Overlays are saved in the header (e.g. of tif images), and do not need to be saved externally.
- Examples: Scalebars, annotations, …



Selections

EXCERCISE 6
Open Example 4 – Manual scale

- Select the line selection and draw lines on the image. Check the status bar. Length? Unit of length?
- Try out the other selection options
- Right-click the icons with a red triangle at the bottom right.
- Use Analyze > Tools > ROI manager to

- Add selections, rename them and remove them
- Save selections to a file and open them again



Scale bars

EXCERCISE 6
Add a scale bar to Example 1D (the .ser file)

- Open Example 1D (Plugins > Input-Output > TIA reader)
- Check the info in the header:  CTRL + i (or Image > Show info …) 
- Analyze > Tools > Scale bar…



Scale bars

EXCERCISE 6
Try to repeat for Example 4 – Manual scale. Retrieve the scale and add a scale bar to a cropped version of 
Example 4

- Open Example 4
- Image > show info…

Overlays & preparation for publication



Scale bars

- Open Example 4
- Image > show info… The pixel size is NOT calibrated →
- But! There is a scale bar burnt into the rastered image.
- Draw a line exactly the length of the burnt-in scalebar

- Use Analyze > Set Scale
- The length of the line (in pixels) will be automatically filled in
- Enter the known distance (1) and the unit (um, there is no 𝜇)
- (Global will set this scale to all open images)
- Click OK. Your image is now calibrated (Check the info!)

Now add the overlay scalebar
- Analyze > Tools > Scale bar…
- Note: the burnt-in scale cannot be removed, only cropped out

EXCERCISE 6
Try to repeat for Example 4 – Manual scale. Retrieve the scale and add a scale bar to a cropped version of 
Example 4



Annotations

EXCERCISE 7
Open Example 4 – Manual scale and annotate the image

Arrows, lines, text
- Image > annotate > Arrow.. 

Accepting the annotation
- Press CRTL+B to make the annotation in overlay (recommended)
- Press CTRL+D to draw the annotation in the image (burn in: convert vector to pixels)

Note: ImageJ/FIJI is not great for annotations

Illustrator, Affinity designer, Inkscape, CorelDraw, … are superior tools for vector graphics design.



Annotations

EXCERCISE 7
Open Example 4- Manual scale and annotate the image

Image > Overlay > List elements



Preparing for publication - semantics

Some semantics:

Image

Line art

Graph or plot

Line art

Figure



Preparing for publication - DPI

Images: from camera to printer: PPI and DPI Dots per inch (DPI)
is a measure of spatial dot density in printing, in particular the 
number of individual dots that can be placed in a line within 
the span of 1 inch (2.54 cm).

Points per inch (PPI)
is the same but with concerning electronic displays. Not 
relevant here.

Rule of thumb: what is the resolution I need to publish my data?
Images: at least 300 DPI, but 600 DPI has been requested
Line art: higher: 1200 DPI, but I have seen 2400 DPI requests
Graphs: 600 DPI and up

Low resolution High resolution



Preparing for publication - example

Images: from camera to printer: PPI and DPI

Dots per inch (DPI)
is a measure of spatial dot density in printing, in particular the 
number of individual dots that can be placed in a line within 
the span of 1 inch (2.54 cm).

Info: 
1 inch = 2.54 cm
Expected Image width in print: 10 cm
Expected printed resolution: 300 DPI

Question: how many pixels wide does my digital picture have to be?

Calculation:

Width (printer) = 
10 𝑐𝑚

2.54
𝑐𝑚

𝑖𝑛𝑐ℎ

= 3.937 inch

at 300 dots per inch = 3.9737 inch x 300 
𝑑𝑜𝑡𝑠

𝑖𝑛𝑐ℎ
= 1181 dots

Result:
The image must be 1181 pixels wide to get a 10 cm wide figure at 300 DPI 

Resizing and cropping
What happens with my image during resizing? Am I 
allowed to crop an image?
==> See lecture 2 Advanced Image processing



Preparing for publication - pica

Publishers and printers work often with PICA (pc) and POINTS (pt).
• 12 points (pt) 1 pica (pc)
• 1 pc 1/6 of an inch
• 1 pc 4.23333 mm
• 1 pt 0.35277 mm
• Text height 1 pica (12 points)
• Text width (page) 41 pica
• Column width (2 / page) 20 pica
• Central space 1 pica

1 pica (12 points)

20 pica

41 pica

1 pica

Info
Expected Image width in print: 20 pc
Expected printed resolution: 300 DPI
Question: how many pixels wide does my digital picture have to be?
Calculation:
20 pc = 20/6 inch = 3.333 inch (= 8.333 cm)
Width (printer) = 3.333 inch

at 300 dots per inch = 3.333 inch x 300 
𝑑𝑜𝑡𝑠

𝑖𝑛𝑐ℎ
= 1000 dots

Result:
The image must be 1000 pixels wide to get a columnwide figure at 300 DPI 



Preparing for publication – Example using InkScape

EXCERCISE 8
Create a 300 dpi, 20 pica PNG figure containing Example 4 in Inkscape

1. Start the software (inkscape.org)
2. Adjust the window size
 File > Document properties
 Set Display units to pica (pc) and custom size to 20 pc width to pc (pica)
 Close the Document properties window
3.  Import the image
 File > Import… and point to Example 4
 In the import dialog box: do not change anything
  (the default is 96 dpi = 96 PPI = screen resolution)
 Edit > Preferences > Imported Images

4. Set the image dimensions 
Left tool bar: make sure you selected the black pointer
Select the image, you can find the dimensions in the horizontal toolbar 

Try out different units (px, mm, in, pc, …)



Preparing for publication – Example using InkScape

EXCERCISE 8
Create a 300 dpi, 20 pica PNG figure containing Example 4 in Inkscape

5. Scale the image
 With the lock ticked (keeps W/H ratio constant), change W to 20 pc

6.   Align and distribute
 Object > Align and distribute… you get new possibilities on the right 

side of the screen
 Align relative to: Page and click         and then         (order is 

irrelevant) 
 The image is now aligned to your 20 pc wide page
7.   Add annotations 
8.   Export to PNG

File > Export (you get a new window on the right)
Set the Image size … pixels at to 300 DPI. Click Export.
Check its dimensions in your Operating system



Preparing for publication

FigureJ: attempt to create Figure panels for scientific publications in ImageJ
Plugin download: add the IBMP-CNRS, ImageScience and BioFormats repository, then restart.
Plugin start: Plugins> FigureJ > new

Set the resolution 
in DPI at the start

https://imagejdocu.tudor.lu/plugin/utilities/figurej/start

Advantage
FigureJ takes care of the DPI conversion of your images

MUTTERER, J., & ZINCK, E. (2013). Quick-and-clean article 
figures with FigureJ. Journal of Microscopy, 252(1), 89–91.

https://doi.org/10.1111/jmi.12069


Annotations: FigureJ



Finished!

✓ Congratulations,

You finished Part I, Basics!
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