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1 Overview 

Introduction
NanoBuilder is a standalone application for rapid nano-prototyping using all FEI 
beam processes: ion milling, gas-assisted milling, electron beam- and ion beam-
induced deposition (EBID, IBID) to create desired structures available in CAD 
files. 

NanoBuilder allows the creation of structures that are not possible with other 
lithographic methods (e.g., a sloping surface to make a tilted nano-mirror). Users 
can modify their designs faster and more economically than the traditional 
lithography process, resulting in quicker iteration and a shorter time-to-market. 
Customers involved in micro-fluidics, nano-optics (optical resonators, nano-
mirrors), and nano-imprinting will benefit from NanoBuilder. 

NanoBuilder Product Line
In addition to NanoBuilder itself, the product line consists of NanoArchitect™ 
and NanoBuilder LTL™. 

 NanoArchitect is for use on a PC without a microscope. It allows you to 
create, view, and edit NanoBuilder jobs.

 NanoBuilder LTL is the limited trial license 60-day version.

Additional Benefits
NanoBuilder automatically sets the parameters for the microscope using 
information available in the beam chemistry module. Its editor allows you to 
specify data such as beam and pattern settings and automates the execution.

NanoBuilder also:

 Makes it easy to pattern CAD (GDSII CAD file) designs with the SEM/FIB.

 Optimizes unique parameters for EBID and IBID operation.

 Adds SEM- and FIB-specific information such as beam energy, current, 
patterning parameters, GIS parameters.

 Automates the alignment of layers/patterns to fiducials on the sample, not 
only beam shift, but also rotation, magnification and shear errors.

 Automatically patterns the layers/patterns with the given settings at multiple 
locations on the sample.

 Allows designing structures without the need for an external GDS editor. 

 Allows creating structures that span multiple write fields.

 Create structures that span multiple write fields.
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Finding a GDSII Editor 
For creating GDS files you may want to try one of the editors below; FEI does not 
endorse the use of any particular editor.  

More information about the GDSII format and the available commercial and open 
source products supporting it can be found at 
http://en.wikipedia.org/wiki/GDSII.

Table 1-1   GDSII Editors

Editor Web Page

Layout Editor http://www.layouteditor.net/

KLayout http://www.klayout.de

CleWin http://www.wieweb.com

L-Edit Pro http://www.tannereda.com/l-edit-pro

Electric http://www.staticfreesoft.com
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2 User Interface

Overview 
Topics in this chapter include:

 “Terminology” on page 5

 “UI Elements” on page 6

Terminology
The following terms are used in NanoBuilder: 

 Alignment: A corrective step to align the microscope scan field to the 
substrate.

 GDSII: A file format (Graphic Data System) that is the industry conventional 
standard for the transfer of IC layout data between design tools.

 Job: The entire set of instructions for creating or modifying devices on the 
DualBeam™ microscope. Jobs are organized in projects (what) and site lists 
(where).

 Layer: Defines a set of patterns and shapes the microscope settings (process) to 
use when patterning them. Optionally, it can have an alignment.

 Pattern: An extension of the shape object that describes an area to be exposed 
by the beam.

 Process: Contains all the settings that should be applied when patterning a 
layer: the beam (electron/ion), settings for the beam (energy, current, etc.), 
patterning parameters (dwell time, overlap, etc.), and the GIS (and its 
parameters). 

 Project: The DualBeam instructions to be performed at a single site consisting 
of alignments, layers, shapes, and templates. 

 Reference: A shape or pattern created by shifting or rotating another shape or 
pattern.

 Shape: A two-dimensional geometric object.

 Composite Shape: A shape that is composed of other shapes.

 Site List: A list of programmed locations, called sites, on the substrate.

 Template: A shape or pattern that is being referenced.
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UI Elements
The main elements of the NanoBuilder user interface are shown in Figure 2-1. 

Figure 2-1   NanoBuilder User Interface

Menu bar Graphical view of job

Status bar

Job overview
structure

Describes 
properties of 
job item 
selected in 
overview

Help area explaining what the selected item controls. 
(In this example, the selected item is HFW.)

Mouse 
location
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User Interface    UI Elements

File Menu

Use the File menu to open, import, and save NanoBuilder jobs. 

Table 2-1   File Menu Overview (1 of 2)

Menu Item Description

New Opens a new job or project.

Open (Ctrl+O) Displays the Open dialog box to select a job.

Merge Job (Ctrl+M) Displays the Open dialog box to select a job for merging 
with the loaded job.

Import GDSII... Displays the Open dialog box for importing a GDSII file.

Save (Ctrl+S) Saves the job. If the job is new and hasn’t yet been named, it 
opens the Save As dialog box.

Save As... Opens the Save As dialog box to save the job under a 
different file name and/or location.

Recent jobs Displays a list of recent jobs opened during this session.
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Preferences... Opens the Preferences dialog box.  

Use this dialog box to set default parameters. 
Note: Normally you can leave ServerPassword and 
ServerUserName and NanoBuilder will reuse the credentials you 
used when logging into the xT UI. To run NanoBuilder without 
xT UI, you must enter those credentials here.

Exit Closes the NanoBuilder application.

Table 2-1   File Menu Overview (2 of 2)

Menu Item Description
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User Interface    UI Elements

Edit Menu 

Use the Edit menu to perform basic editing functions that help in working with 
NanoBuilder jobs. 

Table 2-2   Edit Menu Overview (1 of 3)

Menu Item Description

Undo Edit selection 
(Ctrl+Z)

Erases the last change done, as if not done.

Redo (Ctrl+Y) Reverses the undo action.
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Select all Layers Selects all layers on the job, highlights the layers in the Overview, and 
provides layer details in the Properties portion of the UI. This allows you to 
make changes to all layers at the same time, rather than having to set them 
one at a time. This is particularly useful for parameters that you want to be 
common to all layers, e.g., HFW or beam current.

Select all Shapes Selects all shapes on the job, highlights the shapes in the Overview, and 
provides shape details in the Properties portion of the UI. This allows you 
to make changes to all shapes at the same time, rather than having to set 
them one at a time.

Table 2-2   Edit Menu Overview (2 of 3)

Menu Item Description
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User Interface    UI Elements

Select shapes in After choosing a layer from the sub-menu, this option selects all the shapes 
on that layer. Displays a list of the various layers containing shapes. 

When you select the shapes in a layer, NanoBuilder displays those shapes, 
highlights them in the Overview, and provides shape details in the 
Properties portion of the UI. This allows you to make changes to all shapes 
at the same time, rather than having to set them one at a time.

Toggle enabled This enables/disables the currently selected item in the tree view.

Delete Deletes the selected layer, shape, or alignment, etc.

Table 2-2   Edit Menu Overview (3 of 3)

Menu Item Description
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Insert Menu 

Use the Insert menu to add a layer, pattern, reference, or alignment to the project. 

Table 2-3   Insert Menu Overview (1 of 2)

Menu Item Description

Layer Adds another layer, which is also added to the Overview and detailed in 
the Properties portion of the UI.  

Note: The newly inserted layer will be inserted after the currently selected layer, 
or appended to the list of layers if none is selected. You can move its position using 
the methods described in “Change the Patterning Order” on page 22.

Basic shapes Displays a submenu of basic shapes: 
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User Interface    UI Elements

Composite shapes Displays a submenu of composite shapes: 

Special shapes Displays a submenu of special shapes: 

Alignment Displays a submenu of alignment shapes: 

• Correlation: Inserts a correlation alignment, which is also added to the 
Overview and detailed in the Properties portion of the UI (see 
“Correlation Alignment” on page 51).

• Line Scan: Inserts a line scan alignment, which is also added to the 
Overview, along with settings and user controls in the lower portion of 
the UI (see “Line Scan Alignment Properties” on page 47). 

Table 2-3   Insert Menu Overview (2 of 2)

Menu Item Description
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View Menu 

The View menu provides zooming and viewing options. 

Table 2-4   View Menu Overview

Menu Item Description 

Zoom all (*) Place your cursor over the area of interest and click *.

Zoom in (+) Place your cursor over the area of interest and click +. To zoom 
to another area, you must first zoom out and then reposition 
your cursor.

Zoom out (-) Place your cursor over the area of interest and click -.

Grid Toggles grid in the viewer on or off. The grid scales 
automatically when zooming in or out; shapes will snap to the 
grid when moving or resizing. 

Process Window Shows or hide the progress popup window. Note that the 
progress window can also be shown by double clicking the 
status bar or progress bar.

Always on top Keeps the NanoBuilder interface and dialog boxes on top of all 
other user interface components, other than Task Manager and 
a few other system component windows.
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User Interface    UI Elements

Microscope Menu 

The Microscope menu serves as the communication link between NanoBuilder 
and the microscope system. 

Table 2-5   Microscope Menu Overview (1 of 2)

Menu Item Description

Execute Starts the project and begins patterning.

Stop Stops the project.

Set Stage Origin Marks the current stage location as the origin for relative stage 
position in the site list.

Wakeup Initializes the beam, high voltage, and ion source, including 
heating if necessary.
Note: When using only the SEM, use BeamOn in the xT UI to avoid 
unnecessarily switching on the FIB source and reducing its lifetime.

Sleep Stops the beam, high voltage, and ion source.
Note: When the FIB will be used again within the next hours, use 
BeamOn in the xT UI to avoid switching the FIB source off and on, 
which can reduce its lifetime.

Connect Automatically connects to the microscope system if xT is 
running. Make sure that the login settings are set correctly in 
the Preferences dialog box (“Preferences...” on page 8).

Disconnect Keeps you in NanoBuilder, but disconnects from the 
microscope system.
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Help Menu

The Help menu shows the About box and this online user’s guide.

Calibrate 
Detectors

Acquires a series of images with different detector gain and 
offset settings to measure the detector response for optimal 
performance of the Auto Gain Offset function. 
Calibrate Detectors should be run after the installation of 
NanoBuilder on the microscope, and thereafter at periodic 
intervals depending on the aging of the used detectors. Before 
selecting Calibrate Detectors, position the sample with a 
uniform surface, such as an unpatterned area on a piece of a 
silicone wafer, under the E-beam. The Calibrate Detectors 
functions will then go through a series of image acquisitions 
for each enabled detector and save the results of the calibration 
to disk for later use by the Auto Gain Offset function.

Table 2-5   Microscope Menu Overview (2 of 2)

Menu Item Description
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3 Basic Operations

Overview 
Topics in this chapter include:

 “Getting Started” on page 17

 “Stitching Multiple Write Fields” on page 30

 “Job Editing” on page 39

Getting Started
This section shows how to load a GDSII file into NanoBuilder, specify how it 
should be patterned, add an alignment, and execute the resulting job.

Setting up the Microscope
1. Load the sample to be patterned. 

2. Set the sample to eucentric height.

3. Tilt to 52°.

NanoBuilder does not adjust focus and stigmation, so the beam currents 
being used (100 pA, 1 nA, and 3 nA) must be in focus and stigmated. Small 
amounts (< 2 µm) of beam shift between the currents are allowed.

4. Move the stage to the position on the substrate where you want to pattern.

Making a Job
A job in NanoBuilder terms is the complete set of data that describes what needs 
to be patterned—layers, shapes, sequences, beam settings, alignments, etc. 

Go to Start > Programs > FEI Company > Applications > NanoBuilder to start 
the program. Alternatively, click the NanoBuilder desktop icon to launch the 
application. 
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Load the GDSII File

Go to File > Import GDSII... and select Tutorial01.gds file 
(a sample .gds file is located at: 
c:\Program Files (x86)\Fei\NanoBuilder\ Documentation\Tutorials\Tutorial01). 

NanoBuilder displays an interface similar to the one below. 

N
O

T
E Although you can create your design in NanoBuilder, this tutorial uses a GDSII file, as this 

is a common use case.

Load 
GDSII 

File
Configure 

Layers

Change 
Pattern 
Order

Add 
Align-
ment

Save 
Job

Disable 
Layers

Use Align-
ment in 
Layers

Pattern 
the 

Fiducial
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Basic Operations    Getting Started

Configure the Layers for Patterning

As shown in Figure 3-1, the project contains five layers:

 Layer 0 is the fiducial.

 Layers 1, 2, and 3 contain the shapes to be patterned: the thin cross in the 
center, the four squares around it, and the four 
L-shape polygons around the four squares.

 The Line Scan Alignment Layer is used to align the layers.

Click on a layer to select it, then view and edit its properties. 

More than one layer can be selected; (hold Shift or Control) and change the 
properties for all at the same time.

Figure 3-1   NanoBuilder Layers
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Select Layer 1 in the Overview. Click the + to the left of Process to expand this 
item, then expand the Beam item that appears in the same way. 

Change the specifications for each layer in this manner, as needed. NanoBuilder 
will select the closest possible current on the microscope when executing the job. 

Load 
GDSII 
File

Configure 
Layers

Change 
Pattern 
Order

Add 
Align-
ment

Save 
Job

Disable 
Layers

Use Align-
ment in 
Layers

Pattern 
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Fiducial
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Basic Operations    Getting Started

Change the default values for new (imported GDSII) jobs from File > Preferences 
> Project Defaults.  

Load 
GDSII 
File

Configure 
Layers

Change 
Pattern 
Order

Add 
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ment

Save 
Job

Disable 
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Use Align-
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Change the Patterning Order 

The layers will be patterned in the sequence in which they are shown, e.g., Layer 0 
will be patterned first, then 1, 2, and 3. However, we want to change the order of 
Layers 1, 2, and 3 so they are patterned in decreasing beam current order. The 
layer order can be changed via drag and drop. To inverse the order of the layers:

1. Select the bottom layer and drag it onto the first layer.

2. Select the new bottom layer and drag it onto the second layer.

Alternatively, use the right mouse button to click on a layer and use Move 
Up/Down/To Top/To Bottom to change the order layer. 

Load 
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File

Configure 
Layers

Change 
Pattern 
Order

Add 
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ment
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Job
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Layers

Use Align-
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Basic Operations    Getting Started

Pattern the Fiducial

In this GDSII file, the fiducial is defined in Layer 0. 

1. With the electron beam, navigate from xT to an unpatterned area of at least 
300 µm.

2. Set the beam current to 1 nA from NanoBuilder.

3. Save the job. If AutoSave Job is enabled, this will happen automatically.

4. To execute only Layer 0, right-click it in the tree view and select “Execute at 
current location”.

5. Verify that fiducial patterning was successful.

Load 
GDSII 

File

Configure 
Layers

Change 
Pattern 
Order

Add 
Align-
ment

Save 
Job

Disable 
Layers

Use Align-
ment in 
Layers

Pattern 
the 
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N
O

T
E Tutorials are located under Program Files. Do not save your data to this location, as 

it will be lost upon subsequent reinstallation.
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Add an Alignment

Using alignments achieves two things:

 Align a layer to the sample: Accurately position the patterns in a layer 
relative to these marks by finding marks on the sample. Even if the position 
relative to the sample is not critical, it is useful to align layers with respect to 
each other.

 Drift correction: Correct for drift while patterning by realigning at fixed 
intervals during patterning.

To add an alignment:

1. Select Alignments in the Overview. 

2. Add an alignment either by right-clicking the alignment selection or by 
selecting to Insert > Alignment. In this example, choose Line scan 
alignment from the list.
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Basic Operations    Getting Started

The new line scan alignment will be selected automatically. The line scans that 
were generated can be seen by expanding the Line Scan Alignment in the 
tree view. 

3. To re-generate the line scans (converting the shapes on the Line Scan 
Alignment layer to lines scans) click Generate Lines. This can be used to 
update the alignment after you have modified the design. Set 
HorizontalFieldWidth to 300 µm. 
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4. Set IntegrationWidth to 4. 
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The line diagnostics are shown when you select a line.
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Use the Alignment in Layers

After defining an alignment, the alignment must be assigned to each layer that 
should use it. This extra step allows having different alignments for different 
layers, having layers without alignment, and sharing a single alignment in 
multiple layers.

1. Select Layers 1–3 (Shift + click).

2. Click in the box to the right of Alignment in the Properties area (where it 
says No alignment).

3. Click on the dropdown arrow that appears and select Line scan alignment 1. 

4. Enable layers 1, 2, and 3 by selecting them and right-clicking Toggle 
enabled from the popup menu, or right-clicking True in the Enabled 
property. 

5. Set HFW to 300 µm for each layer.

6. Set the thickness to 10 nm. 
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The greater the current, the faster the mill.
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7. Click on each layer and set the beam current for each. Choose one of the 
available apertures. The range of typical beam current settings is 1 pA to 
1 nA.

Disable Layers Not To Be Patterned

Layer 0 (fiducial) and the Line Scan Alignment layer help define the line scan 
alignment and should not be patterned, so they should be disabled.

Right-click on Layer 0 and choose Toggle enabled from the popup menu. Or, 
right-click True in the Enabled property. 

Disabled layers have a gray icon and are not drawn in the graphical view.
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Save the Job
1. Use File > Save to save the job as an .nbj. file.

Or use File > Save as to give it a new name.

GDSII is not savable, since that format cannot store the extra data that was 
added.

Execute the Job 

Select Microscope > Execute and begin patterning.

The job will now be executed. The progress is shown in the progress window and 
in the status bar. The progress window is minimized by clicking Hide and re-
opened by double-clicking the status bar. 

Failed Site Strategy

If an error occurs during job execution, a failed site strategy message displays in 
the Job window. 
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it will be lost upon subsequent reinstallation.
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successful line scan alignment at that line. Red indicates failure.
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There are two strategies:

 ContinueWithNextSite: Stops execution at the current stage position and 
continues processing at the next site. 

 AbortJob: Stops execution of the entire job.

Stitching Multiple Write Fields
This tutorial creates a repetitive design, using the stage to move from one write 
field to the next and correlation alignments to correct for the stage inaccuracy. For 
the sake of execution speed (so the demo can be executed in a few minutes) it only 
creates a small, shallow pattern at each write field.

Final Result
The final result will be an array as shown in the figure below. Each cell consists of 
an outer circle (donut), a cross and a central dot. Between any two cells there is a 
stage move.  
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At each stage location the elements as shown in red (for the bottom-left stage 
location) will be milled: a large donut in the write field center, the 4 lines that 
make a cross in the column to the left, and a small dot in the row below. At the 
edges only some of these elements are visible, while the central area contains 4 x 4 
complete cells. If the alignment after a stage move fails then the donut, cross and 
dot will be displaced relative to each other–allowing a quick visual check of the 
alignment quality.

To allow judging the alignment quality each cell consists of parts patterned at 3 
different stage positions. In other words, if the alignments fail then the donut, 
cross and dot will not be aligned to each other.  

To create a single cell, the results from 3 different stage positions must be 
combined.

Creating the Job
This section describes how to create the entire job in NanoBuilder (without 
making use of a GDSII file).

Creating the Layers and Shapes
1. Open NanoBuilder. This job starts with a single layer.

2. Right-click Layers in Tree View and select Add Layers to add a second 
layer. Repeat to add a third layer. The first two layers will only be used to 
run an alignment; they will not contain any shapes.  
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3. Select all three layers (so we only have to set the values below once):

 Set the horizontal field width to 50 µm.

 Expand the Process section.

— Expand Beam and set the Ion Beam to 10 pA and 30 kV.

— Expand Patterning and set 1 µs dwell and 0% overlap.

— Ensure GIS is set to <no gis>.

— Set up all three layers at the same time to ensure they have identical 
settings. The time shows as (0 s) because no shapes have been added 
yet.

4. Select only Layer 2 (so newly added shapes will be on this layer).

5. Click in the graphical area and press the * key on the numeric key pad to 
center the zoom. This ensures that newly added shapes will not have an 
offset.

6. From the Insert menu, choose Basic Shapes > Circle.

 Set the OuterRadius to 3 µm.

 Set the InnerRadius to 2.8 µm.

7. From the Insert menu, choose Basic Shapes > Circle.

 Set the OuterRadius to 0.5 µm, 0.

 Set the Position to 0, -10 µm.

8. From the Insert menu, choose Basic Shapes > Path.

 Expand the Points section.

 Set the first point to 1 µm, 0.

 Set the second point to 2 µm, 0.

 Set the Line width to 200 nm.



P N  1 0 4 8 0 2 7 - B   1 / 1 5 / 1 5 33

NanoBuilder UG (2.0 and higher)FEI CONFIDENTIAL, Limited Rights Data

Basic Operations    Stitching Multiple Write Fields

9. Drag the Path from the Shapes into the Templates section. It becomes 
available for Reference shapes.  

10. From the Insert menu choose Composite Shapes > Reference (to a 
Template). In the dialog that appears:

 Ensure the Template is set to Path 0.

 Ensure the Rotation is set to 0°.

 Click OK.

11. Repeat 3 more times, setting the Rotation to 90°, 180°, and 270°, respectively.

12. Select all 4 References and set the Position to be –10 µm, 0.

13. Select Layer 2 and set the Time to 10s.

14. Save.

Creating the Alignments
You must first create an image that the correlation alignments can use as their 
reference image (the image to search for). You could directly acquire this image 
from within NanoBuilder, but in practice it is often more convenient to acquire it 
in the xT UI, save it to disk and load that image into NanoBuilder. It is easier then 
to reuse the image if you later need to add a similar alignment (as you cannot 
export the image).

Acquiring the Reference Image
1. Load a sample that is easily marked by the FIB, like a piece of silicon wafer 

(for example the calibration wafer on the standard multi-stub sample).

2. Using the xT UI, set the stage to eucentric position and 52° tilt, optimize 
focus and stigmation for the FIB at 30 kV, 10 pA (take the nearest available 
current).

3. Select a FIB image resolution like 1024 x 884 or 1536 x 1024 and set the dwell 
time to 10 µs. The detector should ideally be in SE mode. Run Auto Contrast 
and Brightness.

4. Move to a fresh piece of sample, with as few existing features and particles 
as possible.

5. In NanoBuilder, right-click on Layer 2, select Execute at current location and 
wait until patterning has completed.
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6. In the xT UI grab a FIB image, for example by un-pausing and immediately 
clicking Pause again (so the button becomes orange and acquisition stops at 
the end of the frame). Any shift between patterning and acquisition will 
result in an alignment error, so don't wait too long (drift) and certainly don't 
use beam shift or stage moves to position the image.

7. In the xT UI select File > Save as, select Tiff 8 bit gray scale Image Files and 
unselect both Save Image with Databar and Save image with overlaid 
graphics. Save the image in the folder where you saved the job. Right-click 
to execute it (without executing the other layers).  

Aligning to the Previous Column
1. Right-click Alignments and choose Add alignment > Correlation 

alignment. 

2. Click Browse in the dialog that appears, select the saved image, and click 
OK. 

3. The new alignment is automatically selected:

 Set the ReferenceImageOffset to –10 µm, 0 to make the alignment search 
at the previous site.

 Set the name to “Align to previous column”.

4. Select Layer 0.

 Set the alignment to be the newly created alignment.

 Ensure the AlignmentStrategy is CorrectShiftWithMicroscope.
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5. Click in the center of the alignment to select the Template area and resize it 
to only just contain the central circle (by zooming in you are able to decrease 
the grid pitch and make smaller steps when dragging). It is important to 
have as few other features visible as possible, because the alignment may 
otherwise try to align these to random features (dirt) on the specimen.  

6. To test the alignment:

 In the xT UI, make a relative stage move of 0.01 mm in x-direction (the 
circle needs to be about 10 microns left of the screen center).

 In NanoBuilder, right-click Layer 0 and select Test alignment.

 If the alignment fails the most common problem is that the minimum 
score is set too high. The dialog that appears upon failure tells the actual 
score. Select the alignment and set the MinScore to a value somewhat 
lower (e.g., half of) the value in the dialog. 
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 If the alignment fails for a different reason you can often understand the 
cause by expanding the alignment in the tree view and selecting the 
Diagnostics item. If you do not see the template in the Matched Image 
then most likely the detector settings are wrong or the shift is larger than 
the scan area.  

 Select the diagnostics node to see more information about failed 
correlation alignments. In this example, the quad 4 detector was set to 
External, resulting in a uniform gray image.

 If the alignment succeeds, you get the option to set the beam shift to 
correct for the error. It is a good idea to select Yes and re-run the 
alignment. The second time should also succeed, and the measured shifts 
should now be very close to zero. 

Aligning to the Previous Row
1. Add a second correlation alignment, setting it up identically to the first one, 

except that:

 The ReferenceImageOffset is 0, –10 µm (this will cause it to get a red 
border because you are now trying to scan outside the field of view - we 
will fix this below).

 Set the name to “Align to previous row”.

2. Select Layer 1 and sets its Alignment to be this alignment.
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3. Set the template area to only just contain the circle; this also reduces the size 
of the scan area and it should be possible to make the red border disappear.

4. When testing the circle needs to be about 10 µm below the screen center, so 
make a relative stage move of –0.010, 0.010 mm (assuming you still are 
where the previous alignment was tested).

Adding the Stage Sites
1. Right-click Sites and choose Add stage site array. In the dialog that appears

 Set the row and column pitch to be 10.2 µm. Theoretically these should be 
10 µm, but we're going to introduce an intentional error so the alignments 
have something to correct. Note that the error is cumulative, so the last 
site will have 0.8 µm error. 

 Set the number of rows and columns to be 5 each (25 sites).

 Leave the origin blank.

 Press OK.

2. Select the first site, select Execute specific layers and select only Layer 2.

3. Select the next 4 sites (remainder of the first row), select Execute specific 
layers and select Layer 0 and Layer 2.

4. Select the remaining sites, select Execute specific layers and select Layer 1 
and Layer 2.

5. Select the Job in the tree view and set the Failed site strategy to AbortJob. If 
one site fails there is no sense in continuing with the rest, as they all align to 
each other.
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6. Save the job.  

Executing the Job
1. Move to a fresh piece of the specimen.

2. Select Microscope > Set stage Origin from the Microscope menu to define 
the current position as the starting point.

3. Use Execute from the same menu to run the job.
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Job Editing
NanoBuilder allows creating designs, by inserting shapes, and then resizing, 
moving, or deleting them. Note that it supports shapes not available in GDS, such 
as circles, Boolean shapes, bitmaps, and stream files. 

Creating a Job
Start NanoBuilder.

Or, if NanoBuilder is already running, go to File > New Job to create a new job.

Creating a Layer
1. Go to Insert > Layer to add a layer.

2. Change the HorizontalFieldWidth and Thickness properties to the 
appropriate value for the size of the job. 

Creating a Circle 
1. Go to Insert > Basic Shapes > Circle.

2. Click on the circle that appears to select it. Resize the circle using the drag 
handles or enter the exact radius numerically. 

3. Change the inner radius to 10 µm.

N
O

T
E NanoBuilder currently cannot save in the GDSII format, and the format of its native .nbj 

files may change in the future. Therefore, for long-term design use, it is better to make a 
GDSII file and convert that to NanoBuilder.

N
O

T
E New shapes are placed in the screen center and are sized to about 10% of the 

screen width.
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4. Change the outer radius to 12 µm. 

5. Select the scan direction for patterning. See also “Scan Direction” on page 45. 

Creating a Reference
1. Create a circle.

2. Drag the circle from Shapes to Templates (in the tree view).



P N  1 0 4 8 0 2 7 - B   1 / 1 5 / 1 5 41

NanoBuilder UG (2.0 and higher)FEI CONFIDENTIAL, Limited Rights Data

Basic Operations    Job Editing

3. Go to Insert > Composite Shapes > Shape Reference. The Define Reference 
dialog displays.  

This allows you to select a template shape (for reference), the rotation and 
scale, and the position (offset with respect to the template’s position).

4. Under Template, select the circle pattern you just created.

5. Change the scale to 3.

6. Click OK. 

Your job now looks something like this: 
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Creating an Array
An array is similar to a reference, but it allows you to make multiple copies at 
once.

1. Assuming the circle has been moved to the Templates section as described 
above, go to Insert > Reference > Array. The Define Array dialog box 
displays. This allows you to quickly make multiple copies. 

2. Select the circle pattern you created as the template.

3. Change the scale to 0.5 to reduce the size of the ring.

4. Change the number of columns to 3 and the number of rows to 3.

5. Change the width to 30 µm and the height to 3 µm.

6. Click OK.
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The result should be similar to that shown below. 

Changing Array Properties

Change the array’s properties, if necessary, after defining it:

1. Select Array 0 in the Shapes list in the Overview pane.

2. Change the Magnification to 0.2, and set the column pitch to 5 µm.

Array references

Single reference
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Reference Shape Influences Design

To see how changing the reference shape influences the design: 

1. Select the circle template.

2. Set the inner radius to 2 µm.

As shown below, both references have changed. When you change a template, all 
references to that template will change. Also note that the original circle displays 
when it is selected in the Overview pane.  
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Scan Direction 
NanoBuilder defines six different scan directions:

 Serpentine bottom to top

 Serpentine top to bottom

 Serpentine left to right

 Serpentine right to left

 Circular inside to outside

 Circular outside to inside

A schematic illustration of a serpentine scan for a rectangle is shown below.   
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4 Alignments 

Overview 
Topics in this chapter include:

 “Line Scan Alignment” on page 46

 “Correlation Alignment” on page 51

Line Scan Alignment
The line scan alignment works by scanning several line segments with the beam 
and measuring the detector signal along each line. Assuming the lines intersect 
with known features on the sample, transitions (jumps in the signal) will occur at 
these intersections. By comparing the actual transition locations with the expected 
locations, or the measured line profile with a reference profile, you can find the 
shift for each line. A fit to all the lines gives the shift, rotation, scale, and shear 
parameters that best match the measured shifts. These can then be used to correct 
these errors. 

Creating a Line Scan Alignment
1. Create a GDSII file with shapes on the Line Scan Alignment Layer that 

indicate where the lines are to be scanned and shapes on any other layer that 
indicate the features that the lines will scan over (the fiducial marks).

2. Load this file into NanoBuilder.

3. Use Insert > Alignment > Line Scan Alignment (or right-click on 
Alignments in the Overview tree) to create a new line scan alignment. 

4. The new alignment will automatically import the shapes on the Line Scan 
Alignment Layer as the lines to scan, checking for intersections with shapes 
on other layers.

5. Optionally, train the alignment if you need best layer-to-layer accuracy (at 
the cost of absolute accuracy to the fiducial marks). 

N
O

T
E

Make sure that LineScanAlignmentLayer is set to 61 in the Preferences dialog box. 
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Line Scan Alignment Properties  

Table 4-1   Line Scan Alignment Properties (1 of 2)

Property Description

DwellTime This is the pixel dwell time for scanning the lines. A larger value will give 
better signal to noise, but also cause more damage per scan. It will also 
increase the total time to scan the alignment lines, but this is generally not 
a limiting factor.

Elasticity If a line has more than a single transition, the real spacing between the 
transitions might be different from the expected spacing, causing the 
match to fail. This number influences how much the actual spacing may 
differ from the expected spacing by broadening each transition with a 
Gaussian. For example, for a line segment of 5 µm length, a value of 1% of 
the Gaussian has a sigma of 0.05 µm, meaning that each edge can be off 
by that amount relative to the other edges.

EqualizeDose Keeps the dose constant at varying beam currents.

HorizontalFieldWidth This is the horizontal field width (HFW ~ 1/magnification) at which to 
scan the lines. Use the same HFW in the alignment and in the layers that 
use the alignment to avoid small errors that might be caused by changing 
the HFW. This value must at least be so large that an image acquired at 
this HFW will contain all the lines that are to be scanned.

IntegrationWidth By setting a number larger than 1, you can automatically scan multiple 
parallel lines. This will increase accuracy and reliability.

MinScore Each line scan line receives a score from 0 to 1 indicating the confidence 
in the correctness of the measurement. The alignment accepts only lines 
with a score greater or equal to the value specified by the MinScore 
parameter. Use the MinScore parameter to control the probability of a 
false measurement. 

Name The name of the particular line scan alignment.
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Optimization Determines the impact of redundant scan lines with a failed 
measurement on the alignment. There are two selections:
• HighestAccuracy requires that all scan lines successfully measure the 

location of the underlying fiducials. Use this setting when the 
patterning process demands consistent alignment with the highest 
achievable accuracy. 

• BestRobustness tolerates measurement failures of redundant scan 
lines. The number of redundant scan lines is the total number of lines 
minus the number of parameters calculated by the alignment, which 
depends on the AlignmentStrategy field for the layer. 
The AlignmentStrategy field for the layer has two selections:
— CorrectShiftWithMicroscope calculates two scalar parameters, 

namely shift in X and Y,
— CorrectWithShapes computes scale in X, scale in Y, shear and 

rotation, in addition to shift in X and Y, resulting in a total of six 
scalar parameters. 

For example, a job uses the line scan alignment module located in the 
documentation folder to define an alignment. The alignment module 
defines four pairs, with each pair consisting of one horizontal and 
one vertical line. When using CorrectShiftWithMicroscope, the line scan 
alignment will tolerate the measurement  failure of up to three 
horizontal and three vertical lines. On the other hand, the 
CorrectWithShapes selection will only tolerate the failure of one 
horizontal and one vertical line because of the higher number of 
alignment parameters calculated in this case. 

SearchWindow Reduces the search range to a fraction of the profile data acquired over 
the entire scan line. The search range is centered to form equal margins 
from either end of the scan line. Decrease this parameter to suppress the 
detection of scan artifact peaks near the extremes of the scan line.

Sensitivity The Transition method matches inflection points in the scan profile to line 
transitions. The Sensitivity parameter filters the inflection points 
according to the strength of the slope at which they occur. A small value 
will suppress inflection points with soft slopes and, consequently, will 
lead to fewer detected inflection points to be matched to transitions. 

SmoothSigma Sets the width of the Gaussian used to smooth the detector signal. It is in 
units of points on the line that was scanned (similar to pixels).

UseAutoGainOffset When set to True, the detector contrast and brightness will automatically 
be adjusted if the signal is too dark or bright. When set to False, you must 
manually adjust the detector signal while patterning with the real time 
monitor enabled.

Table 4-1   Line Scan Alignment Properties (2 of 2)

Property Description
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Line Properties
The line scan alignment has a list of lines that are to be scanned when the layer is 
executed. At least two lines (nonparallel, ideally perpendicular) are required for 
measuring and performing a translation (shift) in X and Y. At least six lines (not 
all parallel) are needed to measure translation, rotation, scaling and shear. 

Use Single Lines with IntegrationWidth Parameter
Line scan lines can be widened to a larger scan area by using the 
IntegrationWidth parameter. All pixels perpendicular to the line direction are 
averaged to reduce noise and lessen the impact of fiducial line roughness. Values 
of 4–8 typically achieve good results for beam currents ranging from 50 pA–1 nA. 
In general, use larger values for smaller beam current.

Table 4-2   Line Properties

Property Description

StartPoint The starting point of the line. Expand to edit the x- and y value.

EndPoint The end point of the line.

Length Read only, the distance between the start and end points.

SearchMethod • Transition: This method searches for inflection points in the profile 
and matches them to the line transitions. This is typically used when 
the intersection information comes from a GDSII CAD file and no 
knowledge is available on the actual detector signal profile. This 
works best if there are multiple transitions; the algorithm can then 
search for a sequence of jumps at the correct intervals. The more 
transitions, the less likely other features (like a piece of dirt) will 
match, decreasing the chance of a false match.

• ScanProfile: Compare trained line profiles with the measured line 
profiles. This defines the scan field location where the training was 
done as the 'perfect' location, which the alignment will try to 
reproduce. 

If you want to position patterns with absolute accuracy relative to 
existing features, use Transition. For the best layer-to-layer alignment, 
use ScanProfile.

TrainedBeam The beam that was used for training.

TrainedDetector The detector that was used for training.

TrainedHFW The horizontal field width at which training was done.
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Choose Search Method for Line Scan Alignment
The line scan alignment can search for the fiducial location in two different ways: 

 The Transitions method matches inflection points in the line profile with 
material or topography transitions described by the fiducial layer in the GDSII 
file. Depending on the nature of the fiducial and the particular imaging 
conditions, the location of the detected inflection points may differ slightly 
from their respective calculated transitions. The Transitions method calculates 
the total shift from the average of the transition deviations to achieve “center 
of mass” alignment.

 The ScanProfile method, on the other hand, uses a sample scan profile 
recorded during the training step of the line scan alignment to find the 
fiducial. 

Use the Transitions method when absolute pattern placement is critical and the 
edges of the fiducial display as bright narrow lines in the image. Typically, this is 
the case for features produced by a lithography process applied to a silicon 
substrate. The ScanProfile method is recommended when robust and precise 
alignment of the layers to each other is more important than absolute placement 
of the entire structure. 

Line Scan Alignment Capture Range and Line Placement
The capture range of the line scan alignment is determined by the length of the 
fiducial line. Individual fiducial lines milled by NanoBuilder should be spaced 
from each other by at least their length to avoid the sample-staining or mill 
artifact of one scan line to alter the acquired profile of a neighboring scan line. 
This is illustrated by the figure below on the left. For fiducial crosses, place the 
scan line 3/4 from the center and set its length to 1/2 of the length of the cross 
arm. This will ensure a maximum capture range without scan line interference.  

Figure 4-1   Line Scan Alignment Capture Range & Line Placement
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Correlation Alignment 
The correlation alignment is based on cross correlation techniques, using a pre-
defined template image that is searched in an image that is acquired on the 
microscope during the alignment task.

Correlation alignment is most useful when:

 Aligning to sites with prefabricated alignment fiducials. The following 
example demonstrates how multiple crosses on the mapping wafer test 
substrate can be modified consistently with one NanoBuilder job. 

 You expect a relatively large shift. The line scan alignment typically has 
limited range, while the correlation alignment can handle much larger shifts.

 When the amount of noise in the acquired line scans is too significant for a 
stable line scan alignment. Cross correlation is generally less sensitive to 
noise.

Before beginning, prepare the microscope for patterning. Drive to a location on 
the mapping wafer sample, bring it to eucentric height, optimize the SEM and FIB 
images, and then align the ion beam with the E-beam using beam shift. 

1. Start NanoBuilder and go to File > Import GDSII... > Tutorial03 and select 
the file Tutorial03.gds 

C:\Program Files (x86)\FEI\NanoBuilder\Documentation\Tutorials\
Tutorial03\tutorial03.gds. 

2. Right-click on Alignments in the Overview window and select Correlation 
alignment from Add alignment. 

3. In the Properties window, set HFW to 150 µm.
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4. In the Template pane, click Reference Image to enable a Browse button at 
the right of that property.

5. Click the Browse button to display the Change Image dialog box. 
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6. Expand the Acquisition Parameters and Beam Parameters properties and set 
the following:

 Resolution: 1024x884

 Current: 100 pA

 HFW: 150 µm  

7. Click Acquire.

8. Click OK to close the dialog box.

9. In the Template pane, set the following parameters: 

 X: –13%

 Y: 26%

 Width: 12%

 Height: 12% 

N
O

T
E If the correlation alignment is not good, increase the 

dwell time for better signal-to-noise.
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Figure 4-2   Aligning Template to Fiducial

Display is enlarged 
to show a good 
alignment.

Representation of fiducial 
in GDSII file

Image
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10. Set the ReferenceImageOffset to precisely align the template to the fiducial 
displayed in Layer 0. The display of the fiducial pattern in Layer 0 helps 
align the image template, as shown in Figure 4-2. 

11. Right-click on Layer 0 to disable it so that the fiducial will not be patterned. 

12. Right-click on the Site List and select Add stage site array. 

H
IN

T

Once you have developed a robust alignment job, you can reuse it from different 
projects. To do so, save the alignment job for later use. Then when you need an 
alignment during the development of a new job, use the Merge Job selection on 
the File menu to include the previously saved alignment job. After you have merged 
the alignment job, move the fiducial layer and the burn-in layer, if present, to the 
start of the patterning list.



Alignments    Correlation Alignment

P N  1 0 4 8 0 2 7 - B   1 / 1 5 / 1 5 56

NanoBuilder UG (2.0 and higher)FEI CONFIDENTIAL, Limited Rights Data

13. Click OK on the Create array of sites dialog box that displays. 

14. Select Layer 1 in the Overview window and make the following property 
changes:

 HFW: 100 µm (to pattern with the same HFW that is used for the 
alignment)

 Thickness: 20 nm (to shorten patterning time)

 Alignment: Correlation alignment 1 

15. Go to File > Save and save the job.

16. Execute the NanoBuilder job to modify the fiducials at four sites. 
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5 Advanced Operations

Overview
Topics in this chapter include:

 “Patterning with a Certain Dose” on page 57

 “Parallel and Sequential Patterning” on page 59

 “Shapes in NanoBuilder” on page 60

 “Sites” on page 71

 “Creating Stream Files” on page 78

 “Setting Default Processes” on page 82

Patterning with a Certain Dose 
Patterning with a certain dose is useful when exposing a resist layer. 

Dose and Fluence
The term dose is often loosely used, sometimes to express the total number of 
particles that hit the sample, sometimes to express the number of particles per 
area. The latter is called the fluence, while dose refers to the total number of 
particles. Assuming singly charged particles (electrons or Ga+ ions), the dose is 
more easily expressed in Coulomb (typically in the pC or nC range), while fluence 
is in units C/m², typically in the nC/µm² or pC/µm² range.

The relation between dose and fluence is that the dose is the fluence times the 
exposed surface area. For a specific layer in NanoBuilder, the dose is its fluence 
multiplied by the combined surface area from all the patterns on the layer.
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Thickness, Fluence, Passes, and Time
Specify the exposure for a layer by setting either Thickness, Fluence, Passes, or Time 
in the Layer Properties section. NanoBuilder will automatically calculate the other 
quantities and display their values in parentheses to indicate that they were 
calculated rather than specified. 

For example, if you specify the Thickness, then the Fluence, Passes, and Time will be 
calculated as follows:

Selecting Apertures
When a current is selected that is available by more than one aperture, the one 
closest to the lowest index (lowest beam current) is used.

N
O

T
E

Calculated exposure values may be inaccurate as a consequence of the rounding to an 
integer in the calculation for the Passes property. Moreover, the Passes property cannot 
be smaller than 1. To reduce the dose with a Passes value of 1, you can select a smaller 
beam current or dwell time.
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Parallel and Sequential Patterning
The concept of Parallel and Sequential patterning in NanoBuilder is the same as in 
xT, but there are some subtle differences. Conceptually the meaning is as follows:

 Parallel: All shapes in a layer receive a single pass of the beam, then they all 
receive the next pass, etc., until the required number of passes has been 
reached.

 Sequential: The first shape receives the number of passes specified for its 
layer, then the next shape, etc., until all shapes on the layer have been 
patterned.

Sequential Patterning Displays as Parallel in the xT UI
Even if you set a NanoBuilder Layer to pattern Sequentially, the Patterning page 
in the xT UI will still show Parallel. The reason is that NanoBuilder patterns the 
shapes one by one, starting/stopping patterning for each shape. This allows it to 
use the maximum number of points (currently 8 million) per shape, rather than all 
shapes having to fit in this limitation together.

Always Pattern Parallel

Arrays

By default the individual elements of an Array will be patterned one-by-one in 
Sequential mode. However, this can result in a very high number of start/stop 
patterning cycles, which is slower due to the cumulative overhead (especially for 
nested structures like Arrays of Arrays). If the total number of points for the 
Array is less than the maximum number of points it is more efficient to select the 
Always Pattern Parallel option of the array. This will pattern all the points for the 
array in one go, treating it as a monolithic shape.

Structures

Structures are collections of shapes, which can even be on different layers. When a 
layer is executed in Sequential mode all the shapes in the structure that are on the 
executing layer will be patterned one by one. As with the Arrays, the overhead of 
start/stopping patterning can be reduced by selecting the Always Pattern 
Parallel option for the Structure, in which case all the shapes in the structure 
which are on the executing Layer will be patterned in one go, treating the 
structure as a single shape. 
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Shapes in NanoBuilder
The shapes in NanoBuilder are grouped in a number of categories:

 Basic shapes: Simple geometric shapes

 Composite shapes: Shapes that are combinations of other shapes

 Special shapes: Shapes that deviate from the general concept of a shape

Shape Properties
Each shape has a number of properties that are shown in the property box when 
the shape is selected. Some properties are applicable to all shapes (Name, 
Position, Layer), while others will vary from shape to shape. The available 
ScanDirections, (in the order which the pattern points are generated/rastered), 
will also depend on the specific shape.

Display and Selection
Shapes are visualized with the color of their layer and drawn in the same order as 
they are listed in the project. A slight transparency is applied to ensure 
overlapped shapes are still visible.

A shape is selected by clicking on the shape in the viewer or by clicking on its 
node in the overview tree. When a shape is selected, additional annotation is 
shown: its position (red cross), the bounding box, and drag handles. 

Figure 5-1   Selecting a Shape
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Shape Editing
When a shape is selected, its size and position is editable directly in the viewer. 
Adjust the size by using the drag handles that are attached to the bounding box of 
the shape. To move the shape, position the mouse cursor inside the bounding box 
and drag the shape (hold the mouse button down while moving). 

For ultimate precision, use the property box (lower-right part of the screen) to edit 
the position and dimensions (and other properties of the shape) using numeric 
keyboard input.

Adjust the order in which the shapes are patterned (and displayed) by dragging 
their nodes in the overview tree. Alternatively, right-click on the shape in the 
overview tree and use the menu items Move Up, Move Down, Move to Top, 
and/or Move to Bottom to adjust the order. 

Grid and Snap
A grid with drag handles that snap is available to facilitate shape editing in the 
viewer. The grid can be enabled via View > Grid.

The grid will scale dynamically with the zoom level with no need to specify the 
grid-spacing. If you need a higher grid density, just zoom in.

Basic Shapes
The basic shapes are the straight-forward geometrical shapes and can be 
considered as the NanoBuilder primitives. 

Circle

The circle represents a solid disk. If the inner radius has a value greater than 0, it 
becomes a donut (a circle with a line width that is equal to the outer radius minus 
the inner radius).

Shape‐Specific Properties

 Outer radius

 Inner radius 
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Path

A path is a single line or a number of connected lines, all with the same line width. 
To edit the points (or add/delete points), select the path shape, right-mouse click 
and select Edit Points. The shape will now be shown in Edit Mode, allowing you 
to drag the points. Add points by dragging the red line between two points; this 
will insert a new point between the two points. Alternatively, enter the exact 
point coordinates in the shapes property area.  

Figure 5-2   Shape-Specific Properties

Figure 5-3   Path
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Shape‐Specific Properties

 EndStyle: Specifies how the two ends are drawn (rounded or straight)

 Width: The line width of the path

 Points: The end points of the line segments that define the path 

Rectangle

The rectangle represents a solid rectangular area, specified by its width and 
height. 

Shape‐Specific Properties

 Width: Horizontal dimensions

 Height: Vertical dimensions 

T
IP

When you want to close a path shape, define the first and last point to be at the 
same position, and choose them such so they are on a straight line (between the 
second point and second to last point).
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Polygon

A polygon is a solid multi-line shape, varying from three-point triangle to any 
number of points. To edit the points (or add/delete point), select the polygon, 
right-mouse click, and select Edit Points. The shape is now shown in Edit Mode, 
with points that drag. Points can be added by dragging the red line between two 
points. This will insert a new point between the two points. Alternatively, enter 
the exact point coordinates in the shapes property area. 

Shape‐Specific Properties

The points are the end points of the line segments that circumference the polygon.

Text

With the text shape the design can be annotated with text labels; these labels are 
patterned and behave just like any other shape. 

Shape‐Specific Properties

 Alignment: Specifies how the text is placed with respect to the position

 Font: Specifies font type, style, and size

 Text–the text to display and pattern

Figure 5-4   Polygon
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Composite Shapes
Composite shapes are shapes that are a combination of other shapes. The specific 
composite shape defines how the shapes are combined. Boolean Shapes and 
Reference Shapes can be identified within the composite shapes. 

Reference shapes implement the concept of re-using copies of an existing shape 
(the template). Such references are based on a transformation or repetition of one 
of the shapes that has been placed in the Templates collection (see “Reference” on 
page 68).

Boolean shapes use logical operations like AND, OR, XOR to combine the child 
shapes. The child shapes can be composed by dragging the shapes into the 
composite within the tree view. Though Boolean operations are typically applied 
to two operands, in NanoBuilder any number of child shapes is allowed.

The individual shapes that make up the composite can be edited independently. 
With Boolean Shapes, all child shapes will inherit the layer of the composite. 

Composites can be nested allowing you to create complex shapes. 

Structure

A structure is a collection of shapes, typically used for grouping shapes in a 
functional block. The individual shapes can reside on different layers.  

Shape‐Specific Properties

If Always pattern parallel is selected, the shapes within the structure are 
patterned in a parallel fashion, even if the layer is set to serial pattering. This 
means the whole structure is treated as if it was a single shape. Patterning is still 
by layer, so only the shapes on the currently executing layer are combined. In 
previous versions, the structure was called “shape collection”.
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Union

The union shape is the equivalent of the Boolean OR operation, merging the 
constituents into one big shape. Unlike the Structure, overlapping parts are not 
patterned twice.  

Intersection

The intersection shape is the equivalent of the Boolean AND operation, only 
patterning the overlapping parts of the shapes.  
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Exclusion

The exclusion shape is the equivalent of the Boolean XOR operation, patterning 
everything except for the overlapping parts of the shapes. This is the inverse of 
the Intersection shape.  

Difference

The Difference shape is the equivalent of subtraction operation, removing the 
parts from the first shape that are overlapped by the other shapes. 

The difference shape can be used to invert part of a design: use a rectangle as the 
first shape to define the 'exclusion zone' (which is milled away), in which the 
other shapes will not be patterned. 
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Reference

The Reference shape holds the concept of re-using an existing shape (the 
template) at different locations and optionally adjusting its size and/or rotation. 
In order to re-use another shape, that shape first has to be promoted to a template, 
which is accomplished by dragging the shape to the templates node in the tree 
view. 

The image below shows two instances of a reference shape; with and without a 
rotational offset. In this example the referenced shape is a structure.  

Shape‐Specific Properties

 Template: The shape that is used as the template for this shape

 Rotation: Angle to rotate the template with (default is 0)

 Scale: Scale factor to increase or decrease the size of the template (default is 1)

Array

The Array shape allows you to repeat in existing shape in a regular grid. 
Optionally the repeated shape–which has to be a template–can be rotated and 
rescaled when it is repeated in the grid.
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The following image is a shape array using a 3 x 4 grid and a rotational offset. In 
this example the repeated shape is a structure. 

Shape‐Specific Properties

 Template: The shape that should be repeated in the array (the referenced 
template)

 Rotation: Angle to rotate the template with (default is 0)

 Scale: Scale factor to increase or decrease the size of the template (default is 1)

 Columns, rows: The number of columns and rows for repeating the template

 Pitch X,Y: The spacing between the repeated shapes

 Center X,Y: This is an alternative representation of the position of the array, 
using the center as the point of reference; this facilities aligning the center of 
the array to a specific position

 Always pattern parallel: If selected, the shapes within the array are patterned 
in a parallel fashion, even if the layer is set to serial patterning

Special Shapes
The special shapes are shapes that deviate from the general concept of shapes, for 
example in how they are rastered or how process parameters are applied. 
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Bitmap Shape

The bitmap shape is a pattern that uses an image from disk as the basis for 
patterning. The different gray scale values of the pixels are translated to specific 
dwell times at the corresponding pixel locations, such that after patterning an 
imprint of the image remains. The result of the Bitmap Shape is equivalent to 
patterning a bitmap in the xT UI.  

Shape‐Specific Properties

 Bitmap: The image used for the shape; to change files, click the [...] button in 
the field. A bitmap shape is always patterned in a row-by-row serpentine, 
starting at top-left corner.

 Physical height and width: The actual dimensions of the image when it is 
patterned

 Pixel: The size of a pixel when patterned (pixel size = physical size/bitmap 
resolution). The maximum possible dwell time of a pixel–if it has value 255–is 
the dwell time as set for the layer. 
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StreamFile Shape

The StreamFile shape allows you to add an existing stream file (a native xT format 
for specifying pattern points) to be included in the design. The stream file has to 
be specified when the shape is added.

 The dwell times of the points in the stream file are not determined by its layer, 
but merely by the times specified for each point in the stream file.

 The number of passes is determined by the layer. When loading a stream file 
the number of passes for the layer is initially set to the value from the stream 
file, but you can edit this afterwards.

 Because the number of points in a stream file can be considerable, not all 
points are drawn for performance reasons. They may lead to interference 
patterns in the display. Zooming in to scale of a pattern point will show all 
points within the view port. 

Sites
By default, NanoBuilder executes the Project at the current stage location. By 
adding one or more sites to the Job, it is possible to:

 Execute the same Project at multiple stage locations (simplest use case).

 Do perpendicular patterning with both the e-beam and i-beam, by tilting the 
stage per beam (see “Tilt per Beam” on page 76). 

 Create a design that spans multiple write fields (see “Stitching Multiple Write 
Fields” on page 30). 

Site List
The SiteList contains zero or more sites. If it is empty, the Project is executed at the 
current position, otherwise the sites are visited one by one (starting at the topmost 
one in the list). Drag the sites up or down to change the order.
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Site

A site describes a stage location. There are two flavors:

 Absolute sites define an absolute position. For example, move the stage tilt-
axis to 0°.

 Relative sites define a change in position. For example, move the stage x-axis 
by 100 µm.

For both, the user can define which axes need to move, e.g., move the x- and y-
axis, but leave the z-, tilt- and rotation-axis where they are. It is also possible to 
define a site that changes no axes at all (leaves the stage where it is). You can mix 
relative and absolute sites.

You add sites through the context menu of the SiteList (right-click the site list). 

Figure 5-5   Site List



P N  1 0 4 8 0 2 7 - B   1 / 1 5 / 1 5 73

NanoBuilder UG (2.0 and higher)FEI CONFIDENTIAL, Limited Rights Data

Advanced Operations    Sites

You can add multiple relative sites efficiently by choosing Add stage site array…; 
this will open a dialog where you can specify the number of rows and columns 
and the distance to move per row and column. 

By default the x-axis is moved per column and y-axis per row. By setting this up 
differently you could, for example, also sweep the tilt axis.

The Origin column is empty by default; this will result in the first site being 
relative, with no change for any axis (leaves the stage where it is). If instead you 
specify an (absolute) stage position for one or more axes then the first site will be 
an absolute site. You can use the Reload button to copy the current stage location 
(when connected to the microscope) for the corresponding axis. 

Figure 5-6   Create Array of Sites
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The dialog just creates a list of sites; it is not possible to re-run the dialog to 
change the sites. Instead you need to clear the existing sites and define a new list 
from scratch. You can manually change, delete or re-arrange the sites after 
creation.

Origin

When using relative sites the concept of the stage Origin becomes important: this 
is the position relative to which the first move is made. You can specify the 
current stage position to be the origin by selecting Microscope, Set stage Origin 
in the menu. If you don't do this step, then the first move (e.g., by executing the 
Job) will automatically set the current position to be the stage Origin.  

Having the Origin means you can right-click any site and select Move stage here. 
Conceptually all the (relative) moves are made one by one until the selected site is 
reached, starting from the Origin. This means you can move to the last site to 
check where that is on the sample, then move back to the first site before starting 
execution. And after the job has executed you can visit any site for inspection by 
right-clicking and selecting Move stage here. 

You may get the warning dialog below when starting Job execution. This happens 
when the Origin has been defined and the current position is elsewhere. Selecting 
Yes will drive back to the previously defined Origin; No will use the current 
position as the Origin, and Cancel will stop execution.  
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When using absolute sites, the Origin is not used; when mixing absolute and 
relative sites, the Origin defines the starting point for any axes that have not been 
set yet by an absolute site. 

Layers per Site
By default, the entire Project is executed at each site. By selecting one or more 
sites, then selecting Execute specific layers and selecting one or more layers to 
execute, you can define per site which layers need to be executed. In principle, 
each site could execute only its own layer or layers, but usually sites will share 
some layers.  
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Visualization

By default, the zoom level only shows the first site. By zooming out, you can see 
where the other sites are relative to the first site. Only the layers selected for 
execution are visualized at each site; this should help to verify that the right layers 
have been selected. 

Tilt per Beam

To let both beams be perpendicular to the specimen, the stage needs to tilt 
between 0° (SEM) and 52° (FIB). When patterning with both beams, you will need 
at least two layers; one for the SEM and one for the FIB. Perpendicular patterning 
can be achieved by also creating two absolute sites, one setting the stage tilt to 0° 
and the other to 52°, and letting these execute the SEM and FIB layer, respectively. 
You can even add an alignment to the second layer, letting it search for the 
structure created by the first layer, and in this way align the beams to each other.

Figure 5-7   Visualization
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Multiple Write Fields

A typical scenario is spanning a large design with multiple write fields, using 
stage moves between the write fields (stitching). Typically, such a design consists 
of a repeating structure; in this example, we assume that a single layer can create 
a cell of the design, and that stage moves are used to stitch as many of these cells 
together as needed to create the entire structure. 

Stitching an array of cells typically shows three different situations:

1. At the first site, there is nothing to align to yet, so we just need to execute the 
design (to create the first cell). 

2. At the second site, you need to align to the previous site to remove the stage 
inaccuracy. In a similar way the third site can align to the second one and by 
repeating this concept we can create the whole first row or first column. All 
these sites can reuse the same alignment. 

3. When starting on the second row or column, you need to align in a different 
direction, i.e., to a site in the previous row or column. This requires a second 
alignment, that is set up differently from the first one.

One way to achieve this with a single Job is to define three layers (with identical 
Process parameters):

 Layer 1: Uses the alignment that aligns to the previous site in the same row, 
setting the beam shift to correct for the stage error. It has no shapes, but the 
beam shift will be inherited by the following layers so they will also be 
corrected.

 Layer 2: Uses the alignment that aligns to the site in the same column but the 
previous row, again setting the beam shift and not having any shapes.

 Layer 3: Contains the actual shapes to pattern (to create a single cell). 

And to set the layers-per-site as follows:

 The first site only executes Layer 3, as there is nothing to align to yet.

 The sites for the first row execute Layer 1 (to align to the previous site in this 
row, starting with the first site) and Layer 3 (to create the cell).

 The remaining sites execute Layer 2 (to align to the site in the same column 
but in the previous row) and Layer 3 (to create the cell).
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Creating Stream Files
This section shows how to create stream files with GDStoDB and import them 
into NanoBuilder. 

Creating Stream Files in GDStoDB
1. Start GDStoDB.

2. In the System menu, select the tool type you will use (e.g., Helios NanoLab™).

3. Go to File > Open GDSII and navigate to tutorial02.gds and click Open.

4. Select Layer 1 by clicking on the corresponding tab. 

5. In the Layers Parameters dialog box that displays, make the following 
selections: 

 Material: Si 

 Dwell time: 1 µs 

 Overlap: 50% 

 Beam current: 93 pA 

 Scan mode: Serpentine

 Depth: 0.1 µm 
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6. Click the down arrow next to the Apply button to display the Apply To All 
Layers button and click the button.

7. Select Layer 2 and change the beam current to 920 pA (for this layer only).

8. Select Layer 3 and change the beam current to 2.8 nA (for this layer only).

9. In the Fields of View dialog box, select 288 µm for Field width. 

10. Go to Add field and click in the center of the structure to create a field.

11. Select the CenterX box in the Field 1 row that was just added to the Fields of 
View box and change the value to 0. Do the same for CenterY. 

12. Repeat Steps 11 and 12 for Layers 1 and 2.

13. Navigate to File > Save > ASCII Stream File and open the Browse for Folder 
dialog box.

14. Select the folder that contains the tutorial02.gds file (or create a new folder) 
and click OK. This will create two files in the selected folder.

15. Select Layer 2 and repeat the above step, using the same folder.
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16. Repeat for Layer 3.

The folder should now contain 6 files:

 Layer 1 - Field 1 [288µm 93pA].str

 Layer 1 - Field 1 [288µm 93pA].txt

 Layer 2 - Field 1 [288µm 920pA].str

 Layer 2 - Field 1 [288µm 920pA].txt

 Layer 3 - Field 1 [288µm 2.8nA].str

 Layer 3 - Field 1 [288µm 2.8nA].txt

Load GDStoDB Output into NanoBuilder
To add a stream file to a job, you must first have a layer to which to add it.

 If you load a GdsToDb.txt output file, NanoBuilder will create a layer based 
on the settings in the file and will load the stream file into that layer.

 If you load the .str file, it will end up in the active layer. You will need to set 
the layer parameters manually.

1. Start NanoBuilder.

2. Select Layer to create a new layer.

3. Select Insert > Special Shapes > Stream File.  

4. In the Open dialog that appears, navigate to the folder that contains the 
result of Step 16, above. Select the three .txt files and click Open.



P N  1 0 4 8 0 2 7 - B   1 / 1 5 / 1 5 81

NanoBuilder UG (2.0 and higher)FEI CONFIDENTIAL, Limited Rights Data

Advanced Operations    Creating Stream Files

5. After loading the stream files, you should see three new layers.  

Executing the Job
Select Microscope > Execute and begin patterning.

The job will now be executed. The status bar at the bottom of NanoBuilder 
displays the overall progress (0…100%), as well as a progress bar for the current 
activity. 
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Setting Default Processes
A process in NanoBuilder contains all the settings that should be applied when 
patterning a layer, i.e., the beam and the beam settings, the patterning parameters, 
and the GIS and its parameters. This approach achieves two goals: 

 Set all the parameters at once, without having to know any of the details, by 
selecting a predefined process from a list. 

or

 Easily fine-tune any of the parameters by expanding the Process.
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Changing Available Processes
1. Open the Preferences dialog box by selecting File > Preferences. 

2. Select the field to the right of ProcessTemplates (where it says “0 processes” 
in the example below) to display the Browse button. 

3. Click the Browse button to display the Available Processes dialog box. 
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Available processes are shown on the left. 

 Import from Server: This link is enabled if NanoBuilder is connected to a 
microscope. Selecting it will import all the patterning applications from 
xT to equivalent processes (as far as possible, as the applications do not 
specify a beam or its settings). 

 Import from Current Project: This link will import the processes from the 
layers in the currently open project in NanoBuilder (also see Editing a 
process below).

 Remove Selection from List: This link will remove the items you have 
selected in the list. This is useful when importing more items than you 
need; trimming the ones you won’t be using makes it easier to find the 
desired process in the list.

4. Click OK to store the new list, which you can use in any project. The list is 
stored per user (i.e. not as part of the current project), so if you log on as a 
different user, you will see a different list. 

Editing a Process
It is easy to modify a layer's process. However, it is important to realize that these 
changes only influence that layer. In other words, if two layers are assigned the 
“Pt dep” process and you edit the process for one of these layers, the changes will 
not show up in the other layer. Similarly, the changes will not show up in a later 
layer that gets assigned the “Pt dep” process. The way to make the changes 
available to other layers is to change the name of the process (give it a unique 
name), then select the Import from Current Project link as described above.

N
O

T
E If you change a process called “ABC”, its name will change to “Modified ABC” to indicate 

it no longer corresponds to the original ABC. By typing in a new name, the “Modified” is 
removed, as it is now clearly a different process.
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6 Troubleshooting 

Overview
Topics in this chapter include:

 “FEI Customer Service” on page 85

 “Known Issues” on page 85

FEI Customer Service
For help, contact FEI Customer Service at 1-866-693-3426 (US) or email 
cshelpdesk@fei.com. 

Known Issues
Table 6-1 lists the known issues along with workarounds for each.

Table 6-1   Known Issues (1 of 4)

Issue Workaround

When a particular thickness is 
specified for a given layer in a 
NanoBuilder job, the actual 
thickness can vary from this 
value. 

There are two main causes for this variation:
• NanoBuilder does not read the actual current before 

calculating patterning times. Thus, if the aperture is 
delivering more current than its nominal value, the does 
applied to the sample also will be off by that factor. 
Apertures allow more current through as they age (wear 
out), and this will lead to deeper mills or thicker than 
expected depositions. 

• Beam chemistry depends on the precursor flux. If the needle 
alignment is off, or if the precursor has aged, the actual 
process speed will differ from the expected value. 

Perform a test exposure of critical layers, and if the actual mill 
depth or deposition height is different from what is expected, 
adjust the layer’s thickness correspondingly. For example, if the 
requested thickness is 1 µm but the actual depth is 1.2 µm, change 
the layer thickness to 1/1.2 = 0.833 µm.

NanoBuilder does not support 
the xT wide screen display.

NanoBuilder sets the display area automatically to fit with the 
server XT display screen ratio. For example: when setting HFW in 
NanoBuilder to 150 µm, the height is automatically set to 100 µm 
for the patterning area.
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When the xT server is restarted 
while NanoBuilder is connected, 
NanoBuilder crashes after you 
select the Microscope menu. 

Shut down NanoBuilder before you start xT.

The graphical display updates 
slowly when a job containing a 
large number of shapes is 
loaded. 

Reduce the number of shapes in the design to only those that 
need to be patterned with NanoBuilder. 

Using dwell times shorter than 
25 ns will fail with a general 
error message.

Use larger dwell times.

E-Beam patterning fails with the 
message:
“Cannot set the target value of 
ElectronBeamSourceTilt...”

At the start of job execution NanoBuilder prepares Quad 3 for 
patterning and Quad 4 for alignments. As part of this 
preparation, NanoBuilder grabs an image frame with the beam 
blanked so that sensitive areas on the sample are not 
unintentionally exposed to the E-Beam. The workaround for this 
issue turns off blanking and consequently exposes the entire 
write field to the E-Beam for a short period. 
Instructions:
1. Start Windows Explorer and set the folder path to 

C:\Program Files\FEI\NanoBuilder. 
2. Create a backup copy of NanoBuilder.exe.config.
3. Open NanoBuilder.exe.config in Notepad.
4. Find line <add key="UseSourceTiltForBlankingEBeam" 

value="true"/>.
5. Set the value property to “false”. 

<add key=”UseSourceTiltForBlankingEBeam" 
value="false"/>.

6. Save the file.
7. If NanoBuilder does not start up after the modification to 

NanoBuilder.exe.config file, restore the original file and start 
over. 

Line scan alignments:

• Linescan alignment for layer 
fails with the error message: 
“Cannot access data pipeline 
for RTM.”

Save your NanoBuilder job and close the application. Restart the 
xT UI and the xT server, then start the NanoBuilder application 
again and load the job to continue. 

• Line scan alignment 
limitation

A standard detector mode must be used during line scan 
alignment.

• Alignment fails because the 
real-time monitor cannot be 
accessed.

Restart the xT server.

Table 6-1   Known Issues (2 of 4)

Issue Workaround
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• Line scan alignment fails 
with insufficient signal 
error.

Use the build-in diagnostics of the line scan alignment (see “Line 
Scan Alignment Properties” on page 47), try to identify the root 
cause of the failure. 
If the transitions are not visible at all in the scan profiles, the scan 
field may be outside of the alignment’s capture range. Either 
increase the length of the scan lines to increase the capture range, 
or realign the beam apertures. 
If the scan profiles contain noise that obscures the transitions, 
increase the dwell time and the IntegrationWidth parameter.
If the transitions are too broad, calibrate focus and stigmation for 
the beam aperture that is being used. 

Mode II Snapshot causes job to 
fail.

Do not perform this action.

SEM blur does not work. If you 
specify a value for the blur and 
the SEM as the beam, the blur 
(defocus) is not applied during 
patterning.

None.

Unreliable connection on the 
Quanta™ 3D FEG platform.

Set the ServerPassword in the Preferences dialog so that 
NanoBuilder can log on to the microscope server with an explicit 
password. 

The immersion lens is not 
available after closing 
NanoBuilder.

Closing the NanoBuilder application may switch off the UHR 
lens. When this happens, restart xT to reactivate the UHR lens 
and make sure to leave the password field empty in the 
Preferences dialog. 

Text:

• Text shapes do not display 
after creation.

Change the zoom level of the shape display to force the newly 
created Text shape to be drawn. 

• Text position does not 
refresh after changing 
coordinates.

Zoom in/out to refresh the changes.

Table 6-1   Known Issues (3 of 4)

Issue Workaround
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• The font size of a Text 
pattern cannot be set from 
the Font dialog.

• Text size does not change 
when using Insert Pattern > 
Text > Change Font/Size.

Expand the Font property and set the size of the font directly. 

• The Strikeout and Underline 
properties in the Text Font 
dialog do not work. 

Do not use.

Table 6-1   Known Issues (4 of 4)

Issue Workaround

Do not use 
Font dialog 
box to set font 
size.
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